Bug 139089 - kudzu doesn't detect/configure madwifi/ath0 devices correctly
kudzu doesn't detect/configure madwifi/ath0 devices correctly
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-12 15:56 EST by Satish Balay
Modified: 2014-03-16 22:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-12 16:08:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Satish Balay 2004-11-12 15:56:33 EST
Description of problem:

http://madwifi.sourceforge.net provides a driver for 'Atheros' based
wireless cards - and this driver works on 'FC3'. This driver binds
atheros' devices to 'athX' namespace instead of 'ethX' namespace.

However - on installing this driver - kudzu attempts to configure the
device as 'eth1' instead of 'ath0'. It also thinks this is an
'ethernet' device' - not 'wireless'

Version-Release number of selected component (if applicable):

kudzu-1.1.95-1
kernel-2.6.9-1.667
http://madwifi.otaku42.de/2004/11/madwifi-cvs-snapshot-2004-11-11.tar.bz2

How reproducible:

Always

Steps to Reproduce:
1. Install FC3
2. download/install madwifi driver (from the above link)
3. reboot
  
Actual results:
Kudzu adds the following:
- in /etc/modprobe.conf
alias eth1 ath_pci

- in /etc/sysconfig/hwconf
class: NETWORK
bus: PCI
detached: 0
device: eth1
driver: ath_pci
desc: "Atheros Communications, Inc. AR5211 802.11ab NIC"
vendorId: 168c
deviceId: 0012
subVendorId: 17ab
subDeviceId: 8310
pciType: 1
pcidom:    0
pcibus:  2
pcidev:  2
pcifn:  0

- creates /etc/sysconfig/network-scripts/ifcfg-eth1
# Atheros Communications, Inc. AR5211 802.11ab NIC
DEVICE=eth1
ONBOOT=yes
BOOTPROTO=dhcp

Expected results:
- in /etc/modprobe.conf
alias ath0 ath_pci
- in /etc/sysconfig/hwconf
device: ath0
driver: ath_pci
- create /etc/sysconfig/network-scripts/ifcfg-ath0, keys-ath0

Not sure where 'wireless' part would fit in here.

Additional info:
'madwifi' is not a component of Fedora. But hopefully this is a simple
fix to kudzu. 

I'm filing this as an RFE - instead of a bug.

Also - once the above things are manually fixed up - 'neat' is able to
 reconfigure 'ath0' properly.
Comment 1 Bill Nottingham 2004-11-12 16:08:22 EST
The madwifi driver needs to support ethtool GDRVINFO; that should
clear most of this up.
Comment 2 Satish Balay 2004-11-12 17:49:04 EST
Looking at the madwifi source - it appears to support 'GDRVINFO'. What
is the exact filed that should be set to 'ath' for kudzu to work?

I'm guessing its probably a 1 line change to the driver.

Thanks,

--
ath_ioctl_ethtool(struct ath_softc *sc, int cmd, void *addr)
{
        struct ethtool_drvinfo info;

        if (cmd != ETHTOOL_GDRVINFO)
                return -EOPNOTSUPP;
        memset(&info, 0, sizeof(info));
        info.cmd = cmd;
        strncpy(info.driver, dev_info, sizeof(info.driver)-1);
        strncpy(info.version, version, sizeof(info.version)-1);
        return copy_to_user(addr, &info, sizeof(info)) ? -EFAULT : 0;
}

Comment 3 Bill Nottingham 2004-11-12 20:42:19 EST
It needs to set the pci path:

        strcpy(info.bus_info, pci_name(whatever its private pci struct
is));
Comment 4 Dr. Peter Boy 2004-11-13 03:28:37 EST
The problem with kudzu seems to be not only the eth1 config files.

Kudzu must do something else, which breaks the functionality of
madwifi. Unfortunately I don'nt know enough details about how kudzu works.


The Workaround, which works for me, is:

-  Install madwifi as described in it's readme ( make; make install) 
-  check, if the line  "alias ath0  ath_pci" is present 
   in /etc/modprobe.conf
-  reboot
-  if kudzu comes up to tell you it found new atheros hardware,
   tell kudzu to *ignore* it completely, i.e. not to change
   any configuration and not to care about it in the future
-  open neat and create a new interface. With the current
   version (fc3) ath0 is listed in the hardware section, so you can
   easily do that and don't need to edit the files in
   /etc/sysconfig/network-scripts etc. manually

If madwifi doesn't work, try the following:

-  undelete the files in /lib/modules/<version>/net/*
-  run depmod  -ae  
-  eventually reboot
-  reinstall madwifi using the procedure above. 


If you follow that procedure, an entry ath0 is generated in
/etc/sysconfig/hwconfig.  Eventually you have to delete a formerly
generated entry for eth1.
Comment 5 Satish Balay 2004-11-13 04:57:47 EST
Bill, the following addition appears to work.

 strcpy(info.bus_info, pci_name((struct pci_dev *)sc->sc_bdev));

However kudzu is unable to configure 'ath0' (does it do any wireless
devices?) - but 'neat' does configures it fine.

thanks,
Satish
Comment 6 Bill Nottingham 2004-11-15 00:50:17 EST
How exactly does it *not* configure it, on first detection - does it
pop up that it's new, etc?
Comment 7 Satish Balay 2004-11-15 01:45:15 EST
'not configure' refers to 'wireless settings'

kudzu does pop-up a menu with configure option. Choosing configure
lets me set dhcp/static ip adress settings (which makes sense for
wired network cards). This creates
/etc/sysconfig/network-scripts/ifcfg-ath0 with:

[root@asterix etc]# cat /etc/sysconfig/network-scripts/ifcfg-ath0
# Atheros Communications, Inc. AR5211 802.11ab NIC
DEVICE=ath0
ONBOOT=yes
BOOTPROTO=dhcp
HWADDR=xx:xx:xx:xx:xx:xx

The wireless require at-least TYPE=Wireless/ESSID/KEY options - which
kudzu currently doesn't set.  And I'm not sure if kudzu is supporsed
to do anything more (code/functionality overlap with
system-config-network)

So, for wireless devices - perhaps kudzu shouldn't even pop up this
'configure' option - since it can't configure it anyway?
Comment 8 Bill Nottingham 2004-11-15 13:51:14 EST
Correct; the tool kudzu calls doesn't do wireless options.

Note You need to log in before you can comment on or make changes to this bug.