Bug 139093 - redhat-ready: hangs opening /dev/stdout on serial console w/ r3u4/r4b1/r4b2
redhat-ready: hangs opening /dev/stdout on serial console w/ r3u4/r4b1/r4b2
Status: CLOSED WONTFIX
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: other (Show other bugs)
beta
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Will Woods
:
Depends On:
Blocks: 191897
  Show dependency treegraph
 
Reported: 2004-11-12 16:29 EST by erik nguyen
Modified: 2008-07-17 18:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-17 18:04:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
trace of serial console hang in ttyS1 (396.69 KB, text/plain)
2004-11-12 16:30 EST, erik nguyen
no flags Details

  None (edit)
Description erik nguyen 2004-11-12 16:29:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20030925

Description of problem:
Running redhat-ready on the serial console (ttyS1) hangs on r3u4 (see
the attached strace -f file). The problem seems to be that the open of
/dev/stdout is hanging. This can be recreated simply by

echo ha > /dev/stdout

This same simple hang occurs on r4b1 in the serial console (ttyS1).

Note that the bios console redirect feature is in use.

Here is an example grub.conf file:

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this
file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/sda2
#          initrd /initrd-version.img
#boot=/dev/sda
default=0
timeout=10
#serial --unit=1 --speed=9600
#terminal --timeout=10 serial console
title Red Hat Enterprise Linux AS (2.4.21-21.ELsmp)
        root (hd0,0)
        kernel /vmlinuz-2.4.21-21.ELsmp ro root=LABEL=/
console=ttyS1,9600n8
        initrd /initrd-2.4.21-21.ELsmp.img

XXX: provide output of lspci -V command

/var/log/messages output:

Nov  4 07:42:50 cob-dhcp-145 kernel: Serial driver version 5.05c
(2001-07-08) with MANY_PORTS MULTIPORT SHARE_IRQ SERIAL_PCI ISAPNP enabled
Nov  4 07:42:50 cob-dhcp-145 kernel: ttyS0 at 0x03f8 (irq = 4) is a 16550A
Nov  4 07:42:50 cob-dhcp-145 kernel: ttyS1 at 0x02f8 (irq = 3) is a 16550A

Nov  4 07:43:18 cob-dhcp-145 login(pam_unix)[1483]: session opened for
user root by LOGIN(uid=0)
Nov  4 07:43:18 cob-dhcp-145  -- root[1483]: DIALUP AT ttyS1 BY root
Nov  4 07:43:18 cob-dhcp-145  -- root[1483]: ROOT LOGIN ON ttyS1

Version-Release number of selected component (if applicable):
rhr2-0.9-14.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1. setup serial console on ttyS1 and telnet to it
2. install rhr2 rpms
3. run 'redhat-ready' and will see no output of the script.
    

Expected Results:  expects to see output/menu of redhat-ready script.

Additional info:

if i ssh into the same system then output of redhat-ready will be
fine/normal.

should be fixed asap since the network test portion of rhr2 can only
be run in serial console mode to keep the current status of the screen
dump.
Comment 1 erik nguyen 2004-11-12 16:30:54 EST
Created attachment 106609 [details]
trace of serial console hang in ttyS1
Comment 2 Rob Landry 2004-12-06 16:29:22 EST
when logged into the serical console; will ssh'ing to localhost then
running the tests work correctly?
Comment 3 erik nguyen 2004-12-07 00:15:12 EST
ssh'ing to localhost then running 'redhat-ready' test script works
correctly. is this a workaround for now?
Comment 4 Rob Landry 2004-12-07 16:52:26 EST
if it's holding up a cert; yes use this work around, though it should
not be the perm. fix.
Comment 5 Rob Landry 2005-04-14 13:03:41 EDT
Is this still an issue?  Assuming so, I would guess that we need to open a
bugzilla on serial console redirection for IA-64 or move this bug to RHEL/kernel.
Comment 6 Christopher P Johnson 2005-04-14 13:36:13 EDT
Yes, this is still an issue. ssh isn't a workaround, as network tests bring the
interface up and down.

The issue has been seen with x86 and x86-64 systems, so it is probably not
architecture specific. I agree we should move it to where it will get attention.

It may not be related to the serial console, just the tty driver.
Comment 7 Rob Landry 2005-04-15 09:33:46 EDT
re: ssh - hmm.  the network test should not be bringing down the loop interface
so an ssh to 127.0.0.1 from the serial console should work AFAIK.  Is this not
the case?
Comment 9 Rob Landry 2008-07-17 18:04:27 EDT
rhr2 has been deprecated, closing these remaining bugs as WONTFIX.  Future bugs
against the "hts" test suite should be opened agains the "Red Hat Hardware
Certification Program" product selecting either "Test Suite (harness)" or "Test
Suite (tests)" components.

Note You need to log in before you can comment on or make changes to this bug.