Bug 1390992 - thrift package pulls in qt
Summary: thrift package pulls in qt
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: thrift
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Will Benton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-02 11:26 UTC by Avi Kivity
Modified: 2017-01-15 04:47 UTC (History)
2 users (show)

Fixed In Version: thrift-0.9.1-14.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-15 04:47:44 UTC


Attachments (Terms of Use)
Proposed patch (4.07 KB, application/mbox)
2016-11-02 11:26 UTC, Avi Kivity
no flags Details

Description Avi Kivity 2016-11-02 11:26:33 UTC
Created attachment 1216499 [details]
Proposed patch

Description of problem:


Pulling in the thrift package pulls in qt and related packages, where are unexpected in a server environment.

Version-Release number of selected component (if applicable):

0.9.1-13.el7

How reproducible:

Always

Steps to Reproduce:
1. yum install thrift

Actual results:

Installing:
 thrift                                                                    x86_64                                                             0.9.1-13.el7                                                                    epel                                                                1.0 M
Installing for dependencies:
 hwdata                                                                    x86_64                                                             0.252-8.1.el7                                                                   base                                                                2.1 M
 pciutils                                                                  x86_64                                                             3.2.1-4.el7                                                                     base                                                                 90 k
 pciutils-libs                                                             x86_64                                                             3.2.1-4.el7                                                                     base                                                                 45 k
 qt                                                                        x86_64                                                             1:4.8.5-12.el7_2                                                                updates                                                             4.5 M
 qt-settings                                                               noarch                                                             19-23.5.el7.centos                                                              base                                                                 17 k



Expected results:

No qt packages pulled.

Additional info:

Already fixed in Fedora; I backported the patch.

Comment 1 Avi Kivity 2016-11-16 21:18:06 UTC
Ping.  Is anyone reading this?  All that's needed is to apply the provided patch.

Comment 2 Will Benton 2016-11-16 21:20:27 UTC
Thanks, Avi!  I'll make the change soon.

Comment 3 Avi Kivity 2016-11-30 17:50:14 UTC
Will, have you had time to apply the patch?

Comment 4 Avi Kivity 2016-12-11 11:33:50 UTC
Ping?

Comment 5 Avi Kivity 2016-12-25 22:01:16 UTC
:(

Comment 6 Christopher Tubbs 2016-12-27 20:28:37 UTC
It looks like this was addressed in Fedora, but not in EPEL7.

Comment 7 Fedora Update System 2016-12-29 16:22:05 UTC
thrift-0.9.1-14.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-46d50541a8

Comment 8 Fedora Update System 2016-12-31 08:48:50 UTC
thrift-0.9.1-14.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-46d50541a8

Comment 9 Fedora Update System 2017-01-15 04:47:44 UTC
thrift-0.9.1-14.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.