Bug 139106 - Assertion message (metadata_length>0) at disk_dos.c: 1813
Assertion message (metadata_length>0) at disk_dos.c: 1813
Status: CLOSED DUPLICATE of bug 138419
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-12 17:17 EST by Tony Tsui
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tony Tsui 2004-11-12 17:17:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020 Epiphany/1.4.4

Description of problem:
This error message appears when the graphical installer starts. The
full error message is below:

Assertion (metadata_length > 0) at disk_dos.c: 1813 in function
add_logical_part_metadata() failed.

I have to ignore a lot of these message, > 20, to continue the install
process. The install appears to work fine.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start installer

Additional info:

I have used Partition Magic in the past to modify my partition table.
My partition table is below:

Disk /dev/hda: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1         756     6072538+   b  W95 FAT32
/dev/hda2             757        1020     2120580    b  W95 FAT32
/dev/hda3            1021        4865    30884962+   f  W95 Ext'd (LBA)
/dev/hda5            1021        3313    18418459+  83  Linux
/dev/hda6            3314        3379      530145   82  Linux swap
/dev/hda7            3380        4020     5148801   83  Linux
/dev/hda8            4021        4661     5148832+  83  Linux
/dev/hda9            4662        4865     1638598+  83  Linux
Comment 1 Jeremy Katz 2004-11-15 09:43:42 EST

*** This bug has been marked as a duplicate of 138419 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:06:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.