Bug 1391156 - who command returns unknown user
Summary: who command returns unknown user
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gdm
Version: 7.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Ray Strode [halfline]
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1420851 1479818
TreeView+ depends on / blocked
 
Reported: 2016-11-02 16:23 UTC by Chinmay Paradkar
Modified: 2020-03-11 15:20 UTC (History)
4 users (show)

Fixed In Version: gdm-3.26.1-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 12:55:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 788784 Normal RESOLVED manager: don't record wtmp entries when user unknown 2020-08-12 01:36:07 UTC
Red Hat Product Errata RHBA-2018:0770 None None None 2018-04-10 12:57:08 UTC

Description Chinmay Paradkar 2016-11-02 16:23:25 UTC
Description of problem:
The "unknown" user in who and last command appears when running in graphical.target mode. It does not appear when running in multi-user.target mode

Version-Release number of selected component (if applicable):
gdm-3.14.2-12.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. ssh in when no user is logged into the console
2. run 'who -u'
3. run last 

Actual results:
# who -u
(unknown) :0           2016-11-01 15:28   ?          1710 (:0)
root     pts/0        2016-11-02 21:48   .         15132 (10.76.0.219)

Expected results:
# who -u
root     pts/0        2016-11-02 21:48   .         15132 (10.76.0.219)

Additional info:
Upstream bug: https://bugzilla.redhat.com/show_bug.cgi?id=760834

Code is here:
-------------
        if (user_name != NULL) {•
                username = user_name;•
        } else {•
                username = "(unknown)";•
        }•
-------------

Comment 5 Michael Boisvert 2018-01-04 18:07:49 UTC
I could not find an unknown user in 3.26.

Comment 8 errata-xmlrpc 2018-04-10 12:55:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0770


Note You need to log in before you can comment on or make changes to this bug.