Bug 1391217 - Rebase to valgrind 3.12
Summary: Rebase to valgrind 3.12
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: valgrind   
(Show other bugs)
Version: 7.4
Hardware: All Linux
unspecified
unspecified
Target Milestone: rc
: 7.4
Assignee: Mark Wielaard
QA Contact: Miloš Prchlík
Vladimír Slávik
URL:
Whiteboard:
Keywords: Rebase
Depends On:
Blocks: 1371219 1390370 1465627 1385006
TreeView+ depends on / blocked
 
Reported: 2016-11-02 19:46 UTC by mbenitez
Modified: 2017-08-01 22:07 UTC (History)
8 users (show)

Fixed In Version: valgrind-3.12.0-7.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
_valgrind_ rebased to version 3.12 The _valgrind_ package has been upgraded to upstream version 3.12, which provides a number of bug fixes and enhancements over the previous version. Notable changes include: * A new option "--ignore-range-below-sp" has been added to the memcheck tool to ignore memory accesses below the stack pointer. This is a generic replacement for the now deprecated option "--workaround-gcc296-bugs=yes". * The maximum number of callers in a suppression entry generated by the "--gen-suppressions=yes" option is now equal to the value given by the "--num-callers" option. * The cost of instrumenting code blocks for the most common use case, the *memcheck* tool on the AMD64 and Intel 64 architectures, has been reduced. * Performance has been improved for debugging programs which discard a lot of instruction address ranges of 8KB or less. * Support for IBM Power 9 (ISA 3.0) architecture has been added. * Partial support for AMD FMA4 instructions has been added. * Support for cryptographic and CRC instructions on the 64-bit ARM architecture version 8 has been added.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 22:07:18 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:2021 normal SHIPPED_LIVE valgrind bug fix and enhancement update 2017-08-01 19:31:52 UTC

Description mbenitez 2016-11-02 19:46:01 UTC

Comment 10 Miloš Prchlík 2017-06-01 11:20:32 UTC
Verified with build valgrind-3.12.0-8.el7.

Comment 11 errata-xmlrpc 2017-08-01 22:07:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2021


Note You need to log in before you can comment on or make changes to this bug.