Bug 139126 - Assertion (heads > 0) at disk_dos.c:485 in function probe_partition_for_geom() failed.
Assertion (heads > 0) at disk_dos.c:485 in function probe_partition_for_geom(...
Status: CLOSED DUPLICATE of bug 138419
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-12 19:58 EST by Nathan G. Grennan
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan G. Grennan 2004-11-12 19:58:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
Assertion (heads > 0) at disk_dos.c:485 in function
probe_partition_for_geom() failed.

Assertion (sectors > 63) at disk_dos.c:490 in function
probe_partition_for_geom() failed.


It is a Samsung SP1213N 120gb. It has 255 heads, 63 sectors, and 14596
cylinders as reported by the kernel used during installation. fdisk
reports now problems.

Selecting Ignore for both errors would cause the installer to crash.

Selecting Cancel repeatedly, and in more than one location during the
install would allow it to go on.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot disc 1
2. Press Enter at the boot: prompt
3. Skip cd check
4. Click Next
5. Click Next
6. Click Next 

Actual Results:  Assertion (heads > 0) at disk_dos.c:485 in function
probe_partition_for_geom() failed.


Expected Results:  No error

Additional info:
Comment 1 Robert Morrison 2004-11-12 20:15:59 EST
Same bug on my system.  Primary drive (hda) is a Samsung SP1203N, 
also installed in system are Maxtor 6Y120L0 (hdc) and Maxtor 6Y160L0 
(hdd).

By pressing cancel enough times you can progress through Anaconda up 
to the actual point of installation of packages, at which time it 
dies a fatal death in one of the .py scripts.  If I get some time I 
will go through the process again and make note of what/where exactly.
Comment 2 Nathan G. Grennan 2004-11-12 21:59:03 EST
The install finished properly by clicking cancel enough in my case.
Comment 3 Jeremy Katz 2004-11-12 22:45:19 EST
Can you try the update image at
http://people.redhat.com/~katzj/fc3-part-upd.img and see if that helps?

(Instructions for using an update disk are available at
http://rhlinux.redhat.com/anaconda/updatedisks.html)

*** This bug has been marked as a duplicate of 138419 ***
Comment 4 Robert Morrison 2004-11-13 12:38:04 EST
That update image had the effect of changing the line number in 
disk_dos.c.  Nothing else.  I'll follow up in the other bug thread, 
138419.
Comment 5 kashif shah 2005-06-17 14:50:30 EDT
i have the same problem plz tell what can i do so that i can easily install 
fedora core 3.plz tell me any body
Comment 6 Elio Linarez 2005-07-20 12:31:24 EDT
Hey the comment#3 solution work fine for me... Thank a lot
Comment 7 arn vollebregt 2006-01-09 08:15:18 EST
I encountered this error on a HP Proliant DL360 G3.
The update image solved the problem for me.
Comment 8 Red Hat Bugzilla 2006-02-21 14:06:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.