Bug 139140 - FC3 grub hangs on stage2 after install
FC3 grub hangs on stage2 after install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-12 23:04 EST by Chris Thomas
Modified: 2007-11-30 17:10 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-15 01:58:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Thomas 2004-11-12 23:04:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; 
SV1; .NET CLR 1.0.3705)

Description of problem:
After the computer reboots 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install FC3
2. reboot after install
3.
    

Actual Results:  system freezes at the stage2 line when grub starts

Expected Results:  to see grub menu

Additional info:

I here are my computer specs:
AMD Athlon 64 2800+
VIA K8M800/VT8237 Chipset
Nvidia FX 5200
512mb PC 2700 ram
SATA WD Raptor 36.7GB 10k rpm drive
PATA DVD burner

FC3 x86_64 edition
Windows XP 64-bit edition installed before FC3
Comment 1 Thorsten Leemhuis 2004-11-13 16:26:41 EST
Also have two x86_64 machines. Both seem two have this problem. 
One of them fresh install (new machine, FC2 grub i386 works fine from
old i386 install). The other machine was an update from FC2 x86_64. 
Comment 2 Chris Thomas 2004-11-13 23:44:30 EST
Yes, Ive tried my box with the FC2 i368 dvd that i got from 
Linuxworld and grub worked. (BTW, Thanks RH Linuxworld Reps.!)
Comment 3 Mark Rush 2004-11-14 12:47:21 EST
Saw it on my fresh install of fc3.

P4 3.0e, Asus P4C800-E Deluxe, 4x512 Geil DDR400, eVGA Geforce FX 5900
128, SBAudigy Gamer, Seagate 80G sata, Toshiba DVD, Lite-On CDRW,
rt8139 nic, PS/2 keyboard and mouse.
Comment 4 Thorsten Leemhuis 2004-11-14 13:17:04 EST
Just wondering, both my boards are also from Asus (SK8N, A8V). But
Mark, I suspect that you have a EM64T Processor for the P4C800 -- so
your case on i386 might be different from the one here. 
Comment 5 Chris Thomas 2004-11-14 17:00:07 EST
I dont think the 3.0e has EM64T. I think right now, only the new 
XEONs have it.
Comment 6 Mark Rush 2004-11-14 17:36:00 EST
Simply reinstalling grub fixes this, btw.
Comment 7 Chris Thomas 2004-11-14 23:04:16 EST
after you boot into rescue mode, how do you reinstall grub?
Comment 8 Thorsten Leemhuis 2004-11-15 00:41:36 EST
Re #6
>Simply reinstalling grub fixes this, btw.

Not for me...
Comment 9 Thorsten Leemhuis 2004-11-15 02:18:39 EST
Re #8
>>Simply reinstalling grub fixes this, btw.
>Not for me...

It did not when I installed it using grub-shell [root (hd0,7); setup
(hd0)]. But after installing the grub package from the FC3-i386 tree,
installing it with "grub-install" it worked. Then I installed the
package from the FC3 x86_64 tree again -> now this works also. Will
try to reproduce that on the other machine later.
Comment 10 Thorsten Leemhuis 2004-11-15 02:22:09 EST
BTW, I installed both my machines via Network, booted with an
USB-Stick. Could the stick have impact on the grub install behaviour
during installation?
Comment 11 Roger E Critchlow Jr 2004-11-16 13:21:37 EST
This failed for me, too, on an i386 upgrade from redhat 9.0.  The
machine was a Toshiba Tecra 8100 laptop.

Reinistalling grub from the grub shell off the rescue cd failed.

Using grub-install off the rescue cd after chroot succeeded.
Comment 12 Serge Rossi 2004-11-17 14:30:33 EST
I installed FC3 on 4 machines with similar choices (4 CD install, IDE
hard drives, custom install, international install) and the first boot
after the install failed on 3 of the 4 machines.

I corrected it every time by booting "linux rescue" with the first
install CD, chroot /mnt/sysimage, grub-install /dev/hda

PCs on which the install failed (hang on grub2 after the bios screen)

PC 1 : Athlon XP 3000+, SiS 748 chipset, 512 MB Ram, 30 GB HD @
/dev/hda, CD @ /dev/hdc

PC 2 : Athlon XP 2400+, SiS 735 chipset, 512 MB Ram, 8 GB HD @
/dev/hda, 10 GB HD @ /dev/hdb, CD @ /dev/hdc

PC 3 : P4 2 GHz, Intel chipset (can't remember which one), 512 MB Ram,
40 GB HD @ /dev/hda, DVD @ /dev/hdc

PC which booted correctly after the install :

P4 3.0 C, i865PE chipset, 2 GB Ram, 160 GB @ /dev/hda, DVD/RW @ /dev/hdc

Hope this helps...
Comment 13 Mark Rush 2004-11-19 12:44:11 EST
This happens every time I install FC3.
Comment 14 Carlos Rodrigues 2004-11-21 11:14:08 EST
Also happened to me, on my Athlon with abn ASUS a7v8x (via kt400).

On first boot it hang on stage 2. Then I booted into FC3 by
configuring grub on my FC2 installation which was still on disk, on
another partition. I then reinstalled grub from FC3 and it now hangs
after stage 1.5.

This is a critical bug, it never happened on my box and grub from FC2
works perfectly and is able to boot FC3 with no problems.
Comment 15 Thorsten Leemhuis 2004-11-22 03:23:58 EST
Jeremy, do you have any hints how we could track down this issue? Any
logs to watch during install? How does anaconda install grub?
Comment 16 christoff_pale 2004-11-23 09:57:54 EST
Also happens to me on my IBM T42p laptop, 2GHz, 1.5 Gig RAM, 60 Gig HD

$ /sbin/fdisk -l

Disk /dev/hda: 60.0 GB, 60011642880 bytes
240 heads, 63 sectors/track, 7752 cylinders
Units = cylinders of 15120 * 512 = 7741440 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1        3093    23383048+   7  HPFS/NTFS
/dev/hda2            7158        7752     4498200   12  Compaq diagnostics
/dev/hda3            3094        7157    30723840    f  W95 Ext'd (LBA)
/dev/hda5            3095        3838     5622750   83  Linux
/dev/hda6            3838        7089    24579418+  83  Linux
/dev/hda7            7090        7157      514048+  82  Linux swap

Partition table entries are not in disk order
Comment 17 James R. Babb 2004-11-28 23:23:35 EST
this happened on a p4 2.4 ghz non-ht system also

I had no other partitions other than Linux mounted at / and linux swap.

But mostly I am glad to see that its not just me with the error.
Comment 18 Gene Czarcinski 2004-12-21 17:43:28 EST
This report appears to be being ignored by Red Hat/Fedora Core
maintainers and I believe that it should really be against anaconda
(the installer) rather than grub itself.

I have opened a new report against anaconda --
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=143527
Comment 19 Bart Van Cutsem 2004-12-22 10:06:26 EST
Tried fc3 on a Toshiba Satellite 1800 with 1GHz Celeron. Grub hangs on
stage2.

Tried to install grub manually using grub shell and issuing command
setup(hd0,2) (boot partition is nr 3). Grub hangs on stage1.5.

Dumped stage1 and stage2 on a floppy. Boot hangs on stage2.

Thanks for not installing lilo. I've installed it for you. This works
fine.

Grub gets easily confused over different flavors of bioses - disks -
disk parameters. It's not the first time it messed up on me.

I've read grub is about to obsolete lilo? Lilo has always worked and
when it didn't it was always my own stupid fault. Please try to keep
lilo around until grub gets a little stable.
Comment 20 Thorsten Leemhuis 2004-12-22 14:22:29 EST
Re: Comment #18 From Gene Czarcinski  on 2004-12-21 17:43 -------

>This report appears to be being ignored by Red Hat/Fedora Core
>maintainers 

Seems so ;-)

>I have opened a new report against anaconda --
>https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=143527

IMHO it whould have been easier to change the component here. IMHO you
should mark the other bug as duplicate of this one. No one likes to
search for the same issue in two different bugs AFAIK. And the bug is
Assigned To: Jeremy Katz -- that is the correct person IMHO. Bug maybe
I'm wrong. :-)

Re: Comment #19 From Bart Van Cutsem  on 2004-12-22 10:06 -------

>Dumped stage1 and stage2 on a floppy. Boot hangs on stage2.

Did you dump the files from /boot/grub or the ones from
/usr/share/grub/i386-redhat/? If the first, you you please try it with
the files from the latter location? 
Comment 21 Michael Moores 2005-01-01 21:43:13 EST
I just went through this issue while upgrading from FC2 to FC3 via a
CD upgrade.
The installer asked me if i wanted to upgrade GRUB, and I chose "
"yes" for that option.

It seems that the installer did something bad with the master boot record.

So I booted on the CD, executed the rescue mode "linux rescue", and
was able to mount /dev/hda1.

I then ran grub shell and executed:

root (hd0,0)
setup (hd0)

This fixed the grub crash problem.

--Michael



Comment 22 tony 2005-01-07 08:04:19 EST
I have found the same issue on both dual P3-600 and dual P4-2.4/533
systems (Supermicro m'boards). System hangs at stage 2 on reboot. This
happens about 25% of the time in my case. If you are using a kickstart
install you can add "grub-install /dev/hda" to the %post. On my boxes
that always seems to lead to a proper install of grub. At least the
systems have not hung up on reboot.
Comment 23 Chris Thomas 2005-01-08 22:35:15 EST
I have a SATA drive and FC3 sees it as a /dev/sda device. In the
device.map, the configuration is correct but grub still doesn't work.
Comment 24 Oli Wade 2005-01-13 17:14:56 EST
This just got me after a "yum upgrade" including the installation of a new
kernel. Grub hung on reboot, just saying "GRUB" (no prompt).

I am running FC3 on an Athlon64 3500 (Abit AV8 motherboard, WD SATA disk drive).

The following fixed the problem:
 boot install dvd with "linux rescue"
 chroot /mnt/sysimage
 grub
  root (hd0,0)
  setup (hd0)
  quit
 reboot

I did try the "grub-install" script, but it failed - complaining about bios
drives not corresponding or somesuch.
Comment 25 Warren Togami 2005-01-16 15:37:11 EST
Is the common failure element here a specific SATA controller?  Which kernel module?
Comment 26 Carlos Rodrigues 2005-01-16 16:00:50 EST
No, I experienced this on a plain PATA controller (via KT400 chipset).
Comment 27 Gene Czarcinski 2005-01-16 18:08:23 EST
Recently (last couple of days) had to reinstall FC3 on a Compaq R3000z
(Athlon64 notbook) and this happened to me (hang on stage2).

The particulars are ... dual/multi boot with WinXP and FC3 "boot
director) and then full FC3 install with  grub pointed at the
partition ... hang on stage2 ... booted up the install cdrom in recue
mode and ran:

  grub-install /dev/hda7

and now everything works.

This was a i386 install but the same thing happened for x86_64
installed into /dev/hda8
Comment 28 James R. Babb 2005-01-17 01:42:42 EST
I've found that if i do an install from iso images on the hard disk
booting from the rescue cd, i do not have any problem with GRUB....its
odd.
Comment 29 Thorsten Leemhuis 2005-01-19 01:45:35 EST
Warren, I also use PATA on both machines where I had this problem (one is an
nForce3 150, the other a nForce3 250)
Comment 30 Warren Togami 2005-01-19 01:48:07 EST
Come to think of it, I've seen this exact problem 100% reproducible on a
PentiumII 400MHz 440BX with PATA.  Very frustrating.

Jeremy mentioned earlier today that he suspects this could be somehow related to
some disk geometry issue.  Something related to that was fixed in FC4 rawhide,
but he didn't specify which packages to try.
Comment 31 Warren Togami 2005-01-26 02:46:41 EST
Saw this behavior on a fresh install of FC3 onto a Dell Inspiron 8500 today. 
Behavior that I've seen is sometimes instant reboot when it reaches grub, or
sometimes hang at stage2.  Rescue boot and "grub-install /dev/hda" seemed to fix
the problem on this laptop, but not the PentiumII 400MHz mentioned in Comment #30.

I suspect that Bug #125808 may be somehow related.  We could possibly test this
by someone affected installing rawhide.  Unfortunately any fix discovered now is
too late for the FC3 installer, so it would be best to document this in the FAQ's.
Comment 32 Mike Iglesias 2005-01-27 11:18:04 EST
I had this happen on a P3 system upgraded from FC2 to FC3.  It booted
fine after the upgrade, but exhibited the problems mentioned above
after I did a "yum update" to get all the patches installed.  Running
grub-install did not fix it; I had to use the grub shell after booting
from the rescue CD to get it going again.
Comment 33 Chris Thomas 2005-02-15 11:32:19 EST
It looks like Redhat let this one slip into RHEL 4. Check out the first 
section of this article:

http://business.newsforge.com/business/05/02/14/0545216.shtml?
tid=152&tid=17&tid=2
Comment 34 Chris Thomas 2005-03-24 14:23:13 EST
This might be a problem with Grub 0.95. I get the same stage2 thing with 
FC4T1. I also tried Ubuntu and got the same results. All three of these use 
Grub 0.95. I intalled Gentto and FC2 and they both worked. They also both use 
Grub 0.94. I hope Grub 0.96 solves the problem. Will it be included in the 
next test release?
Comment 35 pj 2005-04-02 20:13:21 EST
Nforce3 150 Shuttle AMD64 3000+ with FC4 T1 does this same thing for me. I did
not for the i686 install of FC2.
I added a SATA drive to the existing FC2 to install the FC4 T1. I asked the FC4
install to update the grub conf.
Comment 36 Peter Jones 2005-04-04 13:11:38 EDT
OK, so for any of the x86_64 cases, is there an "NX support" or "NX bit" flag in
your bios?  If so, is it turned on?

If there is, and it is on, try with it turned off.
Comment 37 Chris Thomas 2005-04-05 13:35:01 EDT
(In reply to comment #36)
> OK, so for any of the x86_64 cases, is there an "NX support" or "NX bit" 
flag in
> your bios?  If so, is it turned on?
> If there is, and it is on, try with it turned off.

The No Execute Support thing isn't in the bios of my DFI K8M800-MLVF board.
Comment 38 pj 2005-04-06 11:05:27 EDT
I noticed no "NX" option for my board. I got the FC2 and FC4 T1 both going again
by grub-install'ing onto the original hd1,3 and then adding a grub.conf entry
for the SATA drive hd2,3 I think and then HAD TO enable the SATA RAID Rom in my
Shuttle ANR50 MB before the T1 would grub boot. (then I ended having some kinda
GDM issue I have not yet resolved besides going to runlevel 3)
Comment 39 Chris Thomas 2005-04-15 01:01:45 EDT
Just installed FC4T2 and still the same hang on stage2
Comment 40 Warren Togami 2005-04-15 01:58:39 EDT
The vast majority of users will find this fixed with FC4.  For just about every
computer in the past 3 months that I saw with this behavior (grub gets stuck or
instantly reboots at stage2), installing FC4's grub solved the problem.  Because
this report is a combination of the "old problem" which is solved and "new
problem" which affects a much smaller # of users, I am closing this report
because it is far too confusing to make any diagnosis.  Please follow the
procedure below:

FC3 users
=========
http://forums.fedoraforum.org/forum/showthread.php?t=49276
Follow the procedure that I wrote here in order to install FC4's grub onto FC3.
 For 99% of people with grub stage2 "spontaneous reboot" or "stuck at stage2"
problems, this will make it work properly.

DO NOT COMPLAIN HERE ABOUT FC3 grub.  We know it is broken (for a small
percentage of computers with a certain kind of partition table), but nothing can
be done about that grub that is installed during anaconda.  For these small
number of users with this problem in FC3, try this procedure.  If it fails read
below.

FC4 users
=========
Report your hardware details in Bug 154968.

Note You need to log in before you can comment on or make changes to this bug.