Bug 139141 - Unable to capture any log files in case X crashes
Summary: Unable to capture any log files in case X crashes
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-13 04:12 UTC by Eugene Kanter
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-15 14:58:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eugene Kanter 2004-11-13 04:12:47 UTC
Description of problem:
Attempted to install on Toshiba Portege 7100 series notebook. Video is
Trident CyberBlade (generic).

Attempt one. X server started - black screen, no responce on any known
keystoke combination. Hard reset.
Attempt two. X server started - I happen to move the mouse and saw X
cursor for short time, then X server apparently crashed:

XIO: fatal IO error 104 (Connection reset by peer) on X server ":1.0"
after 0 requests (0 known processed) with 0 events remaining.

Then install sends termination/kill signals and unmounts all
filesystems leaving me unable to examine X log.

Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:
1. make X crash
  
Actual results:

unable to examine X log file to determine the cause of a crash.

Expected results:

at least one VT should be left active (or anything else in order to
examine/copy log files)

Comment 1 Jeremy Katz 2004-11-15 14:58:55 UTC
We have to kill the shell to be able to be guaranteed to be able to
unmount filesystems (which is important to ensure that, eg, your
rootfs gets unmounted cleanly).  

Booting with 'linux nokill' will not kill the shell, but this is a
debugging aid only.

It looks like you were seeing bug 108777, though.

Comment 2 Eugene Kanter 2004-11-15 15:57:54 UTC
I think you are right. I am positive I am seeing bug 108777. That bug
also lists 'ctrl s' trick to delay shell kill.

I think anaconda should upon abnormal termination always pause and ask
user to capture log files (and submit them to bugzilla?) and then kill
the shell.


Note You need to log in before you can comment on or make changes to this bug.