Bug 1391508 - StorwizeSVCISCSIDriver missing target_{portals,luns,iqns} in connection_info when Nova is using multipath
Summary: StorwizeSVCISCSIDriver missing target_{portals,luns,iqns} in connection_info ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder
Version: 11.0 (Ocata)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: Upstream M3
: 11.0 (Ocata)
Assignee: Eric Harney
QA Contact: Tzach Shefi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-03 13:02 UTC by Lee Yarwood
Modified: 2017-05-17 19:37 UTC (History)
8 users (show)

Fixed In Version: openstack-cinder-10.0.0-0.20170106133027.458153d.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 19:37:51 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 308882 None None None 2016-11-03 13:02:55 UTC

Description Lee Yarwood 2016-11-03 13:02:56 UTC
Description of problem:
StorwizeSVCISCSIDriver provided Cinder volumes do not provide the required target_{portals,luns,iqns} via connection_info when Nova is using multipath. This is currently being worked on upstream as part of the following change and blueprint :

Add multipath enhancement to Storwize iSCSI driver
https://review.openstack.org/#/c/308882/

Storwize iSCSI Multipath enhancement
https://blueprints.launchpad.net/cinder/+spec/storwize-iscsi-multipath-enhancement

Version-Release number of selected component (if applicable):
Ocata / OSP 11

How reproducible:
Always.

Steps to Reproduce:
1. Using the StorwizeSVCISCSIDriver Cinder volume driver attach a volume to a single instance.
2. Review the connected portals, targets, path devices etc.

Actual results:
Nova does not correctly connect to or disconnect from all required portals when using StorwizeSVCISCSIDriver supplied Cinder volumes. Only a single target_portal is listed in connection_info with a sendtargets query against this portal not returning the additional portals required to correctly form a multipath'd connection from the compute host.

Expected results:
Nova correctly connects to or disconnects from all required portals when using supplied Cinder volumes.

Additional info:

Comment 3 Tzach Shefi 2017-03-21 18:37:09 UTC
Eric, 

I don't have access to a Storwize storage, you know of any such system we can access? 

Is this a specific driver issue, or can I try to verify with any other iscsi driver instead, I'm guessing probably specific. 

In which case how would I verify this?

Comment 4 Paul Grist 2017-04-06 01:25:02 UTC
as discussed on email, this one needs to go back to IBM for partner verification.

Comment 6 errata-xmlrpc 2017-05-17 19:37:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.