Bug 139151 - Missing BuildRequires
Summary: Missing BuildRequires
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Colin Walters
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-13 07:53 UTC by Michael A. Peters
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: 0.8.7-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-05 22:31:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael A. Peters 2004-11-13 07:53:48 UTC
Description of problem:
Either gstreamer-plugins is missing some BuildRequires, or some devel
packages it requires are missing Requires.

Missing header files needed to build some of the plugins are from:

libmusicbrainz-devel
libavc1394-devel (maybe that should be Required by libraw1394-devel? I
don't know)

Version-Release number of selected component (if applicable):
0.8.5-1

How reproducible:
always

Steps to Reproduce:
1. build src.rpm w/o those devel packages
2.
3.
  
Actual results:
rpm fails to build

Expected results:
missing build requires

Additional info:

Comment 1 Anthony Rumble 2004-11-22 08:18:30 UTC
I think theres more than this thats missing from the buildreq's.

I have an FC3 + errata installed.. with all those devels you suggested
plus some more and I get this..

RPM build errors:
    File not found by glob:
/var/tmp/gstreamer-plugins-0.8.5-root/usr/lib/gstreamer-0.8/libgstgdkpixbuf.*
    File not found by glob:
/var/tmp/gstreamer-plugins-0.8.5-root/usr/lib/gstreamer-0.8/libgstmng.*
    File not found by glob:
/var/tmp/gstreamer-plugins-0.8.5-root/usr/lib/gstreamer-0.8/libgstsmoothwave.*
    File not found by glob:
/var/tmp/gstreamer-plugins-0.8.5-root/usr/lib/gstreamer-0.8/libgsttextoverlay.*
    File not found by glob:
/var/tmp/gstreamer-plugins-0.8.5-root/usr/lib/gstreamer-0.8/libgsttimeoverlay.*

The configure script is so obfiscated around the area of these
modules, it's almost impossible to work out what it's looking for to
see what's missing!



Comment 2 Colin Walters 2005-01-05 22:31:32 UTC
musicbrainz and avc1394 are required now in rawhide.

libmng-devel is now required too.  It looks like everything else is
just a missing dep on gtk2-devel.  I added that now.



Note You need to log in before you can comment on or make changes to this bug.