Bug 1391522 - unknown input device type 'virtio1.0-input'
Summary: unknown input device type 'virtio1.0-input'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stephen Gallagher
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F25FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2016-11-03 13:27 UTC by Stephen Gallagher
Modified: 2016-11-28 09:59 UTC (History)
17 users (show)

Fixed In Version: virt-manager-1.4.0-4.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-08 04:59:38 UTC


Attachments (Terms of Use)
Picture of the auto-added devices (65.83 KB, image/png)
2016-11-03 14:05 UTC, Stephen Gallagher
no flags Details
fpaste sysinfo (44.32 KB, text/plain)
2016-11-03 18:17 UTC, Stephen Gallagher
no flags Details
Patch for dist-git to apply upstream patch (5.95 KB, patch)
2016-11-04 18:19 UTC, Stephen Gallagher
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1399083 None CLOSED ppc network model name incorrectly set to virtio1.0-net 2019-07-03 07:17:57 UTC

Internal Links: 1399083

Description Stephen Gallagher 2016-11-03 13:27:25 UTC
Description of problem:
Attempting to create an x86_64 virtual machine of Fedora 25 Server Beta, I get "unknown input device type 'virtio1.0-input'" and a backtrace when I click "Begin Installation".

Version-Release number of selected component (if applicable):
libvirt-2.2.0-1.fc25.x86_64
virt-manager-1.4.0-3.fc25.noarch


How reproducible:
Every time

Steps to Reproduce:
1. Download Fedora-Server-dvd-x86_64-25_Beta-1.1.iso from the official Fedora mirrors
2. Attempt to install using this media in virt-manager.
3.

Actual results:
unknown input device type 'virtio1.0-input'"

Expected results:
Successful installation

Additional info:


Unable to complete install: 'unsupported configuration: unknown input device type 'virtio1.0-input''

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 88, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/create.py", line 2288, in _do_async_install
    guest.start_install(meter=meter)
  File "/usr/share/virt-manager/virtinst/guest.py", line 461, in start_install
    doboot, transient)
  File "/usr/share/virt-manager/virtinst/guest.py", line 396, in _create_guest
    self.domain = self.conn.createXML(install_xml or final_xml, 0)
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 3782, in createXML
    if ret is None:raise libvirtError('virDomainCreateXML() failed', conn=self)
libvirtError: unsupported configuration: unknown input device type 'virtio1.0-input'

Comment 1 Fedora Blocker Bugs Application 2016-11-03 13:29:30 UTC
Proposed as a Blocker for 25-final by Fedora user sgallagh using the blocker tracking app because:

 "The release must be able host virtual guest instances of the same release." (Beta Criterion)

Comment 2 Kamil Páral 2016-11-03 13:52:24 UTC
I can't reproduce this. Can you upload your VM xml definition file (virsh dumpxml VM_name)?

Comment 3 Daniel Berrangé 2016-11-03 13:57:34 UTC
"virtio1.0-input" is a device name in libosinfo, and not valid to pass to libvirt. IOW, this is probably a virt-manager bug, mistakenly doing straight passthrough from libosinfo.

Comment 4 Stephen Gallagher 2016-11-03 14:05:55 UTC
Created attachment 1217016 [details]
Picture of the auto-added devices

I'm attaching a screenshot of the custom hardware dialog. The offending device appears to be the one I selected here.

I didn't add it manually; it just showed up by default.


For further information, I selected "Linux: Fedora 24" as the OS type, created a custom qcow2 file for the storage and picked 4096MB RAM and 2 CPUs.

Comment 5 Stephen Gallagher 2016-11-03 14:15:00 UTC
For the record, I'm running libosinfo-1.0.0-1.fc25.x86_64 as well.

Comment 6 Stephen Gallagher 2016-11-03 18:17:10 UTC
Created attachment 1217113 [details]
fpaste sysinfo

Attaching system info.

Comment 7 Paul Whalen 2016-11-03 20:07:40 UTC
Seeing the same error, reproducible with:

sudo virt-install --name Fedora_25 --ram 4096 --arch x86_64 --disk size=8 --nographic --os-variant fedora23 --location http://kojipkgs.fedoraproject.org/compose//branched/Fedora-25-20161103.n.0/compose/Everything/x86_64/os/ --extra-args="console=ttyS0"

Starting install...
Retrieving file vmlinuz...                                                                                                                                                                                            | 6.5 MB  00:00:00     
Retrieving file initrd.img...                                                                                                                                                                                         |  49 MB  00:00:04     
Allocating 'Fedora_25-2.qcow2'                                                                                                                                                                                        | 8.0 GB  00:00:00     
ERROR    unsupported configuration: unknown input device type 'virtio1.0-input'
Removing disk 'Fedora_25-2.qcow2'                                                                                                                                                                                     |    0 B  00:00:00     
Domain installation does not appear to have been successful.
If it was, you can restart your domain by running:
  virsh --connect qemu:///system start Fedora_25
otherwise, please restart your installation.


libosinfo-1.0.0-1.fc25.x86_64
libvirt-2.2.0-1.fc25.x86_64
virt-install-1.4.0-3.fc25.noarch
virt-manager-1.4.0-3.fc25.noarch

Comment 8 Stephen Gallagher 2016-11-04 13:14:59 UTC
I can confirm I see the same error as Paul when running virt-install also.

Comment 9 James Hogarth 2016-11-04 15:31:01 UTC
also failing here with:

virt-install -n ${vmname} \
            --memory memory=1536,maxmemory=4096 \
            --vcpus vcpus=1,maxvcpus=3 \
            --cpu host \
            --clock offset=utc,kvmclock_present=yes \
            --features acpi=on,apic=on \
            --location "${vmurl}" \
            --extra-args "ks=${vmks}" \
            --disk pool=default,size=20,bus=scsi,sparse=yes,format=raw \
            --network network=default,model=virtio \
            --graphics spice \
            --sound none \
            --controller scsi,model=virtio-scsi \
            --channel spicevmc,target_type=virtio \
            --channel unix,target_type=virtio,name=org.qemu.guest_agent.0 \
            --video qxl \
            --memballoon virtio \
            --rng /dev/random \
            --noautoconsole 

where vmurl is the fedoraproject repo url for install

this fails with bot a fraw and f25 target ... it worked for a rhel6 target with a 6.8 iso loop mounted

virt-install-1.4.0-3.fc25.noarch

cpuinfo:

processor	: 3
vendor_id	: GenuineIntel
cpu family	: 6
model		: 94
model name	: Intel(R) Core(TM) i5-6300HQ CPU @ 2.30GHz
stepping	: 3
microcode	: 0x9e
cpu MHz		: 1015.655
cache size	: 6144 KB
physical id	: 0
siblings	: 4
core id		: 3
cpu cores	: 4
apicid		: 6
initial apicid	: 6
fpu		: yes
fpu_exception	: yes
cpuid level	: 22
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc art arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm 3dnowprefetch epb intel_pt tpr_shadow vnmi flexpriority ept vpid fsgsbase tsc_adjust bmi1 hle avx2 smep bmi2 erms invpcid rtm mpx rdseed adx smap clflushopt xsaveopt xsavec xgetbv1 xsaves dtherm ida arat pln pts hwp hwp_notify hwp_act_window hwp_epp
bugs		:
bogomips	: 4611.91
clflush size	: 64
cache_alignment	: 64
address sizes	: 39 bits physical, 48 bits virtual
power management:

Comment 10 Stephen Gallagher 2016-11-04 15:37:17 UTC
I booted up another laptop I had (Dell XPS 15 L502x) using the Workstation Live image snapshot from yesterday. I installed the virt-install package in the live environment and tried the virt-install command from comment #7 above.

Same result. (Which tells me it's not likely to be an upgrade-related issue). Perhaps hardware?


processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 42
model name	: Intel(R) Core(TM) i7-2720QM CPU @ 2.20GHz
stepping	: 7
microcode	: 0x15
cpu MHz		: 827.551
cache size	: 6144 KB
physical id	: 0
siblings	: 8
core id		: 0
cpu cores	: 4
apicid		: 0
initial apicid	: 0
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm epb tpr_shadow vnmi flexpriority ept vpid xsaveopt dtherm ida arat pln pts
bugs		:
bogomips	: 4390.15
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:

Comment 11 Stephen Gallagher 2016-11-04 15:43:33 UTC
OK, I did some further investigation. It looks like this incorrect device only gets added when `--os-variant is fedora23 or fedora24. Older Fedora selections and all RHEL selections are unaffected.

So presumably someone made a mistake in the defaults provided by those two profiles.

Comment 12 Daniel Berrangé 2016-11-04 15:51:13 UTC
THis isn't a mistake in libosinfo defaults - the data is all correct. The mistake is virt-manager's interpretation of the data per comment #3.

Comment 13 Daniel Berrangé 2016-11-04 16:01:45 UTC
It is in fact already fixed in virt-manager upstream

commit 1d2cd306773064258f5d02c980b09a683ae77798
Author: Cole Robinson <crobinso@redhat.com>
Date:   Fri Jul 29 13:17:36 2016 -0400

    osdict: Fix incorrect usage of virtio input

Comment 14 Stephen Gallagher 2016-11-04 18:19:30 UTC
Created attachment 1217480 [details]
Patch for dist-git to apply upstream patch

I'm attaching a patch for virt-manager dist-git that applies the upstream fix for this issue.

Dan or Cole, would one of you please review it and either apply and build it or else give me permission to do so? (I have provenpackager status, so I can take care of it).

Comment 15 Stephen Gallagher 2016-11-04 18:27:48 UTC
I've done a scratch build at http://koji.fedoraproject.org/koji/taskinfo?taskID=16290113

I tested it locally; it appears to resolve this issue for me. Paul, James: can you confirm as well?

Comment 16 Paul Whalen 2016-11-04 18:34:00 UTC
(In reply to Stephen Gallagher from comment #15)
> I've done a scratch build at
> http://koji.fedoraproject.org/koji/taskinfo?taskID=16290113
> 
> I tested it locally; it appears to resolve this issue for me. Paul, James:
> can you confirm as well?

Confirmed, working here after installing the scratch build.

Comment 17 Adam Williamson 2016-11-04 22:51:17 UTC
I'm probably +1 blocker on this, I tend to consider virt-manager and boxes part of the 'official' virt stack. Definitely +1 FE.

Comment 18 Cole Robinson 2016-11-06 16:16:13 UTC
Sorry for the delay, I'll do a build now

Comment 19 Fedora Update System 2016-11-06 16:35:06 UTC
virt-manager-1.4.0-4.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-878c340781

Comment 20 Fedora Update System 2016-11-07 02:22:52 UTC
virt-manager-1.4.0-4.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-878c340781

Comment 21 Stephen Gallagher 2016-11-07 12:56:33 UTC
I can confirm that this update fixes the bug (I've provided karma on Bodhi).

Comment 22 James Hogarth 2016-11-07 13:51:17 UTC
This update is tested working for me as well using virt-install on a fedora 25 host to install a f25 guest.

Comment 23 Geoffrey Marr 2016-11-08 00:51:49 UTC
Discussed during the 2016-11-07 blocker review meeting: [1]

The decision to classify this bug as an AcceptedBlocker was made as this is a violation of "The release must be able host virtual guest instances of the same release" in the case of using virt-manager, which is one of the two prime front ends for the 'Fedora virt stack'.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2016-11-07/f25-blocker-review.2016-11-07-17.01.txt

Comment 24 Fedora Update System 2016-11-08 04:59:38 UTC
virt-manager-1.4.0-4.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.