Bug 1391528 - RHOS 9 Keystone catalog not populated - get_password() takes exactly 3 arguments (2 given)
Summary: RHOS 9 Keystone catalog not populated - get_password() takes exactly 3 argume...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 10.0 (Newton)
Assignee: Julie Pichon
QA Contact: Arik Chernetsky
URL:
Whiteboard:
: 1391552 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-03 13:36 UTC by Ian Pilcher
Modified: 2016-12-29 16:56 UTC (History)
12 users (show)

Fixed In Version: python-tripleoclient-5.3.0-6.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:29:16 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 393192 None None None 2016-11-03 13:36:44 UTC
OpenStack gerrit 394573 None None None 2016-11-08 08:51:22 UTC
Launchpad 1639174 None None None 2016-11-04 13:34:21 UTC

Description Ian Pilcher 2016-11-03 13:36:44 UTC
I just tried deploying OSP 9 with today's rhos-release packages:

* python-tripleoclient-5.3.0-3.el7ost.noarch
* openstack-tripleo-heat-templates-compat-2.0.0-34.3.el7ost.noarch

$ openstack overcloud deploy \
    --templates /usr/share/openstack-tripleo-heat-templates/mitaka/ \
    --ntp-server 10.16.255.1 --control-scale 1 --compute-scale 1 \
    --neutron-tunnel-types vxlan --neutron-network-type vxlan \
    --control-flavor control     --compute-flavor compute

The deployment completed, but the only endpoint in the Keystone catalog
was Keystone itself.

 Stack overcloud CREATE_COMPLETE

Started Mistral Workflow. Execution ID: 8a585067-1c51-4339-bbe5-5b8efcdd9cf0
/home/stack/.ssh/known_hosts updated.
Original contents retained as /home/stack/.ssh/known_hosts.old
get_password() takes exactly 3 arguments (2 given)
[stack@undercloud images]$ . overcloudrc
[stack@undercloud images]$ openstack catalog list
+----------+----------+---------------------------------------------+
| Name     | Type     | Endpoints                                   |
+----------+----------+---------------------------------------------+
| keystone | identity | regionOne                                   |
|          |          |   publicURL: http://172.16.0.22:5000/v2.0   |
|          |          |   internalURL: http://172.16.0.22:5000/v2.0 |
|          |          |   adminURL: http://172.16.0.22:35357/v2.0   |
|          |          |                                             |
+----------+----------+---------------------------------------------+

Comment 1 Ian Pilcher 2016-11-03 13:50:51 UTC
Just tried deploying RHOS 9 after applying the patch from Gerrit.  I don't get the get_password error message anymore, but I'm still only getting the Keystone endpoint in the catalog:

 Stack overcloud CREATE_COMPLETE 

Started Mistral Workflow. Execution ID: 3e1ff357-32a9-46d4-b132-21f2d2d4ba15
/home/stack/.ssh/known_hosts updated.
Original contents retained as /home/stack/.ssh/known_hosts.old
Overcloud Endpoint: http://172.16.0.23:5000/v2.0
Overcloud Deployed

real    14m55.398s
user    0m2.015s
sys     0m0.209s
[stack@undercloud ~]$ . overcloudrc
[stack@undercloud ~]$ openstack catalog list
+----------+----------+---------------------------------------------+
| Name     | Type     | Endpoints                                   |
+----------+----------+---------------------------------------------+
| keystone | identity | regionOne                                   |
|          |          |   publicURL: http://172.16.0.23:5000/v2.0   |
|          |          |   internalURL: http://172.16.0.23:5000/v2.0 |
|          |          |   adminURL: http://172.16.0.23:35357/v2.0   |
|          |          |                                             |
+----------+----------+---------------------------------------------+

Comment 2 Julie Pichon 2016-11-03 14:09:57 UTC
Thank you for testing the patch, I will look into it.

I'm surprised that it seems like OSP10's python-tripleoclient is being shipped with OSP9, is this expected?

Comment 3 Ian Pilcher 2016-11-03 14:14:51 UTC
(In reply to Julie Pichon from comment #2)
> Thank you for testing the patch, I will look into it.
> 
> I'm surprised that it seems like OSP10's python-tripleoclient is being
> shipped with OSP9, is this expected?

We are using OSP director 10 to deploy OSP 9.

(We're doing this as a part of a course that we're developing, so you can see all of the details at https://gitlab.cee.redhat.com/roxenham/director-osp10/tree/master/content if you're interested.  This issue is occurring in lab 3.)

Comment 4 Marios Andreou 2016-11-03 14:53:39 UTC
Thanks very much for filing the BZ Ian and thanks for looking Julie - fyi Dan has filed a possibly related BZ 1391552 - seems like it is displaying what Ian in seeing in comment #1 (no error but only Keystone endpoint). We can mark it as duplicate once we're sure.

Comment 5 Ian Pilcher 2016-11-03 15:15:13 UTC
(In reply to marios from comment #4)
> Thanks very much for filing the BZ Ian and thanks for looking Julie - fyi
> Dan has filed a possibly related BZ 1391552 - seems like it is displaying
> what Ian in seeing in comment #1 (no error but only Keystone endpoint). We
> can mark it as duplicate once we're sure.

Sure looks like the same thing to me.

Comment 6 Julie Pichon 2016-11-03 18:35:15 UTC
I posted an updated version of the patch that appears to resolve the problem in my environment (make sure to use the --force-postconfig if updating an existing stack), please let me know how it works for you.

Comment 7 Ian Pilcher 2016-11-03 20:23:30 UTC
(In reply to Julie Pichon from comment #6)
> I posted an updated version of the patch that appears to resolve the problem
> in my environment (make sure to use the --force-postconfig if updating an
> existing stack), please let me know how it works for you.

Seems to work.

 Stack overcloud CREATE_COMPLETE 

Started Mistral Workflow. Execution ID: 3771b18c-fa66-4572-8e73-476a155e7832
/home/stack/.ssh/known_hosts updated.
Original contents retained as /home/stack/.ssh/known_hosts.old
DEPRECATED: It appears Keystone was not initialized by Puppet. Will do initialization via os-cloud-config, but this behavior is deprecated. Please update your templates to a version that has Puppet initialization of Keystone.
PKI initialization in init-keystone is deprecated and will be removed.
Warning: Permanently added '172.16.0.25' (ECDSA) to the list of known hosts.
The following cert files already exist, use --rebuild to remove the existing files before regenerating:
/etc/keystone/ssl/certs/ca.pem already exists
/etc/keystone/ssl/private/signing_key.pem already exists
/etc/keystone/ssl/certs/signing_cert.pem already exists
Connection to 172.16.0.25 closed.
Overcloud Endpoint: http://172.16.0.25:5000/v2.0
Overcloud Deployed

real    15m31.561s
user    0m2.433s
sys     0m0.261s
[stack@undercloud ~]$ . overcloudrc
[stack@undercloud ~]$ openstack endpoint list
+----------------------------------+-----------+--------------+-----------------+
| ID                               | Region    | Service Name | Service Type    |
+----------------------------------+-----------+--------------+-----------------+
| 8822139c1a3641eea9314bec01cdfa61 | regionOne | aodh         | alarming        |
| 9e6b4d7854cb4c3ba842c86ec220ea9a | regionOne | keystone     | identity        |
| 57b495f9c51a475baf51e0c1cff29143 | regionOne | neutron      | network         |
| ba8e694d80cb44f9be768611337fd778 | regionOne | cinder       | volume          |
| 4c42b2bd437248839d4c6046aee68aa6 | regionOne | nova         | compute         |
| e468b358ab0148a6bd89d0e948a12409 | regionOne | glance       | image           |
| 724ce0e2fb7a418f98a8d9fa41e4cff1 | regionOne | heat         | orchestration   |
| 0359ac79ef0d47fdb6548775c3525a02 | regionOne | cinderv2     | volumev2        |
| 8534371520c44643ae8309d6f3df93cf | regionOne | gnocchi      | metric          |
| 98ee6da73faf40b5a022b7c12e155d5d | regionOne | swift        | object-store    |
| 2df5ff87dac044528b675b2bd9f8ebb3 | regionOne | sahara       | data-processing |
| 73f37a42a0f5421ba78e56e45f2101c8 | regionOne | ceilometer   | metering        |
+----------------------------------+-----------+--------------+-----------------+

Comment 8 Dan Yasny 2016-11-04 00:01:57 UTC
Tested the patch in a mixed version environment, UC10-OC9, the endpoints are now created and available.

Comment 9 Adriano Petrich 2016-11-04 09:38:24 UTC
Also works for me on UC10-OC9 but I applied these two patches

curl https://review.openstack.org/changes/392593/revisions/current/patch?download | base64 -d  > patch1.diff
curl https://review.openstack.org/changes/393192/revisions/current/patch?download | base64 -d  > patch2.diff
cd /usr/lib/python2.7/site-packages/
sudo patch -p1 < /home/stack/patch1.diff
sudo patch -p1 < /home/stack/patch2.diff


[stack@undercloud ~]$ . overcloudrc 
[stack@undercloud ~]$ openstack endpoint list
+----------------------------------+-----------+--------------+-----------------+
| ID                               | Region    | Service Name | Service Type    |
+----------------------------------+-----------+--------------+-----------------+
| 09f8be98fd0f41719cc297e40b557843 | regionOne | neutron      | network         |
| 0da813b3842a4dbba26b5cf49e9f9fee | regionOne | aodh         | alarming        |
| f65f7e2ceeac4777a3ded913a14bc979 | regionOne | nova         | compute         |
| 2a6bd4e9830442a0b62f769f04004589 | regionOne | glance       | image           |
| 1366cf4945e34152974e9089610db3cb | regionOne | gnocchi      | metric          |
| 9eb2dde5bf7b4fd0aa2e7374a6ef7dba | regionOne | cinderv2     | volumev2        |
| 49ea201b7a0149c599e73e876a779447 | regionOne | sahara       | data-processing |
| 5e591caf9dab4e14bbd52a341bfdeb04 | regionOne | ceilometer   | metering        |
| 096122eaa4c84005aa6b3e86c6025325 | regionOne | heat         | orchestration   |
| 817a6e86fc5d476cb9ac0be8b0d64d48 | regionOne | cinder       | volume          |
| 646a640472fc42e0bcb709fef5cc0083 | regionOne | keystone     | identity        |
| a10ad8b99c5a45f597cda02040d45b04 | regionOne | swift        | object-store    |
+----------------------------------+-----------+--------------+-----------------+

Comment 10 Marios Andreou 2016-11-04 15:08:50 UTC
*** Bug 1391552 has been marked as a duplicate of this bug. ***

Comment 11 Julie Pichon 2016-11-08 08:51:22 UTC
The upstream patch is merged, in both master and stable/newton.

Comment 12 Marios Andreou 2016-11-08 09:12:24 UTC
thanks jpichon moving to POST then

Comment 14 mlammon 2016-11-15 21:43:18 UTC
Deploy latest RHOS 9 (http://download-node-02.eng.bos.redhat.com/rcm-guest/puddles/OpenStack/9.0-RHEL-7/2016-10-28.2/) using InfraRed

Looked good on this latest RHOS 9 deployment

[stack@undercloud-0 ~]$ . overcloudrc
[stack@undercloud-0 ~]$ openstack catalog list
+------------+-----------------+---------------------------------------------------------------------------------+
| Name       | Type            | Endpoints                                                                       |
+------------+-----------------+---------------------------------------------------------------------------------+
| nova       | compute         | regionOne                                                                       |
|            |                 |   publicURL: http://10.0.0.101:8774/v2.1/d0f7e43850ea4455bbd963940fbbbdda       |
|            |                 |   internalURL: http://172.17.1.10:8774/v2.1/d0f7e43850ea4455bbd963940fbbbdda    |
|            |                 |   adminURL: http://172.17.1.10:8774/v2.1/d0f7e43850ea4455bbd963940fbbbdda       |
|            |                 |                                                                                 |
| neutron    | network         | regionOne                                                                       |
|            |                 |   publicURL: http://10.0.0.101:9696/                                            |
|            |                 |   internalURL: http://172.17.1.10:9696/                                         |
|            |                 |   adminURL: http://172.17.1.10:9696/                                            |
|            |                 |                                                                                 |
| cinderv2   | volumev2        | regionOne                                                                       |
|            |                 |   publicURL: http://10.0.0.101:8776/v2/d0f7e43850ea4455bbd963940fbbbdda         |
|            |                 |   internalURL: http://172.17.1.10:8776/v2/d0f7e43850ea4455bbd963940fbbbdda      |
|            |                 |   adminURL: http://172.17.1.10:8776/v2/d0f7e43850ea4455bbd963940fbbbdda         |
|            |                 |                                                                                 |
| aodh       | alarming        | regionOne                                                                       |
|            |                 |   publicURL: http://10.0.0.101:8042/                                            |
|            |                 |   internalURL: http://172.17.1.10:8042/                                         |
|            |                 |   adminURL: http://172.17.1.10:8042/                                            |
|            |                 |                                                                                 |
| glance     | image           | regionOne                                                                       |
|            |                 |   publicURL: http://10.0.0.101:9292/                                            |
|            |                 |   internalURL: http://172.17.3.10:9292/                                         |
|            |                 |   adminURL: http://172.17.3.10:9292/                                            |
|            |                 |                                                                                 |
| ceilometer | metering        | regionOne                                                                       |
|            |                 |   publicURL: http://10.0.0.101:8777/                                            |
|            |                 |   internalURL: http://172.17.1.10:8777/                                         |
|            |                 |   adminURL: http://172.17.1.10:8777/                                            |
|            |                 |                                                                                 |
| cinder     | volume          | regionOne                                                                       |
|            |                 |   publicURL: http://10.0.0.101:8776/v1/d0f7e43850ea4455bbd963940fbbbdda         |
|            |                 |   internalURL: http://172.17.1.10:8776/v1/d0f7e43850ea4455bbd963940fbbbdda      |
|            |                 |   adminURL: http://172.17.1.10:8776/v1/d0f7e43850ea4455bbd963940fbbbdda         |
|            |                 |                                                                                 |
| heat       | orchestration   | regionOne                                                                       |
|            |                 |   publicURL: http://10.0.0.101:8004/v1/d0f7e43850ea4455bbd963940fbbbdda         |
|            |                 |   internalURL: http://172.17.1.10:8004/v1/d0f7e43850ea4455bbd963940fbbbdda      |
|            |                 |   adminURL: http://172.17.1.10:8004/v1/d0f7e43850ea4455bbd963940fbbbdda         |
|            |                 |                                                                                 |
| swift      | object-store    | regionOne                                                                       |
|            |                 |   publicURL: http://10.0.0.101:8080/v1/AUTH_d0f7e43850ea4455bbd963940fbbbdda    |
|            |                 |   internalURL: http://172.17.3.10:8080/v1/AUTH_d0f7e43850ea4455bbd963940fbbbdda |
#
|            |                 |   adminURL: http://172.17.3.10:8080/v1                                          |
|            |                 |                                                                                 |
| sahara     | data-processing | regionOne                                                                       |
|            |                 |   publicURL: http://10.0.0.101:8386/v1.1/d0f7e43850ea4455bbd963940fbbbdda       |
|            |                 |   internalURL: http://172.17.1.10:8386/v1.1/d0f7e43850ea4455bbd963940fbbbdda    |
|            |                 |   adminURL: http://172.17.1.10:8386/v1.1/d0f7e43850ea4455bbd963940fbbbdda       |
|            |                 |                                                                                 |
| gnocchi    | metric          | regionOne                                                                       |
|            |                 |   publicURL: http://10.0.0.101:8041/                                            |
|            |                 |   internalURL: http://172.17.1.10:8041/                                         |
|            |                 |   adminURL: http://172.17.1.10:8041/                                            |
|            |                 |                                                                                 |
| keystone   | identity        | regionOne                                                                       |
|            |                 |   publicURL: http://10.0.0.101:5000/v2.0                                        |
|            |                 |   internalURL: http://172.17.1.10:5000/v2.0                                     |
|            |                 |   adminURL: http://192.0.2.6:35357/v2.0                                         |
|            |                 |                                                                                 |
+------------+-----------------+---------------------------------------------------------------------------------+
[stack@undercloud-0 ~]$ openstack endpoint list
+----------------------------------+-----------+--------------+-----------------+
| ID                               | Region    | Service Name | Service Type    |
+----------------------------------+-----------+--------------+-----------------+
| a9d462dfd5684d769ccb5740339196f9 | regionOne | glance       | image           |
| d1d80777a7da44e79bf827f787bf8b67 | regionOne | ceilometer   | metering        |
| 17b7e14fb66e49fbac2f9356960411c8 | regionOne | gnocchi      | metric          |
| a66828d6940b476e8d54c548a626a535 | regionOne | aodh         | alarming        |
| e21c08bf942f47219dac98c800447682 | regionOne | swift        | object-store    |
| 39c386929a0b484d8dbcc05b98492514 | regionOne | cinder       | volume          |
| ea5c302505b64a84838b5eb4e2a38dc7 | regionOne | sahara       | data-processing |
| 754c1c4a9efa46729f80a0063a9c2912 | regionOne | neutron      | network         |
| 38d639906ee842e996a6a342057fcff8 | regionOne | heat         | orchestration   |
| de231ee2c46a4db7a95408a3f0902430 | regionOne | keystone     | identity        |
| d42d256f4a644c1684712735c49a6132 | regionOne | nova         | compute         |
| ec72cc9e791a43189f362922b23b8141 | regionOne | cinderv2     | volumev2        |
+----------------------------------+-----------+--------------+-----------------+

Comment 15 Julie Pichon 2016-11-17 16:46:05 UTC
I don't think this requires doc text, as it was a temporary regression. There should be no changes from the user perspective.

Comment 17 errata-xmlrpc 2016-12-14 16:29:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.