Bug 139178 - Anaconda spews diagnostics about parted on some disks
Anaconda spews diagnostics about parted on some disks
Status: CLOSED DUPLICATE of bug 138419
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-13 13:32 EST by Alan Cox
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2004-11-13 13:32:07 EST
Description of problem:

Some BIOSes had problems with 256 heads being reported by drives.
Therefore many have a strap that changes the LBA geometry mode to
report 255 heads and do the maths on that basis. Enabling this causes
Anaconda to spew assert warnings all over the place. It seems parted
is being overly paranoid and doesn't know this specific corner case
and that upsets anaconda.

How reproducible:
Use a disk set to 255 heads

Actual results:
A lot of spewed diagnostics

Expected results:
A quiet install
Comment 1 Edwin Chan 2004-11-14 06:04:22 EST
Bug 138419 looks like the same issue as described above
Comment 2 Alan Cox 2004-11-14 07:19:02 EST

*** This bug has been marked as a duplicate of 138419 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:06:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.