Bug 1391832 - "restore" ends up with an error popup
Summary: "restore" ends up with an error popup
Alias: None
Product: Fedora
Classification: Fedora
Component: mediawriter
Version: 25
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Martin Bříza
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2016-11-04 07:44 UTC by lnie
Modified: 2016-11-28 05:36 UTC (History)
1 user (show)

Fixed In Version: mediawriter-4.0.4-0.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2016-11-15 13:34:06 UTC
Type: Bug

Attachments (Terms of Use)
screenshot (113.15 KB, image/png)
2016-11-04 07:44 UTC, lnie
no flags Details
journal (24.01 KB, text/x-vhdl)
2016-11-04 07:45 UTC, lnie
no flags Details
screenshot2 (139.71 KB, image/png)
2016-11-09 05:11 UTC, lnie
no flags Details
journal (11.99 KB, text/x-vhdl)
2016-11-09 05:14 UTC, lnie
no flags Details
screenshot (79.10 KB, image/png)
2016-11-14 02:34 UTC, lnie
no flags Details
journal (259.87 KB, text/x-vhdl)
2016-11-14 02:34 UTC, lnie
no flags Details
screenshot (81.51 KB, image/png)
2016-11-16 07:24 UTC, lnie
no flags Details
journal (262.78 KB, text/x-vhdl)
2016-11-17 04:30 UTC, lnie
no flags Details
screenshot (53.78 KB, image/png)
2016-11-17 04:31 UTC, lnie
no flags Details

Description lnie 2016-11-04 07:44:24 UTC
Created attachment 1217316 [details]

Description of problem:
Just start mediawriter and click on "restore",and an error message will pop up, as shown in the attached picture. 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:

Actual results:

Expected results:

Additional info:

Comment 1 lnie 2016-11-04 07:45:39 UTC
Created attachment 1217317 [details]

Comment 2 Martin Bříza 2016-11-07 11:11:06 UTC
Please try running FMW with SELinux in Permissive mode (by using setenforce 0). This is probably a SELinux policy issue.
If running in Permissive mode helps, please use the SELinux Troubleshoot Application to report the issue.

Comment 3 lnie 2016-11-08 02:49:27 UTC
Permissive mode dose not help,still get the same error message.

Comment 4 Martin Bříza 2016-11-08 09:27:32 UTC
Can you please try with this build and post the output or journal, as you like?


Comment 5 lnie 2016-11-09 05:11:31 UTC
Created attachment 1218800 [details]

Comment 6 lnie 2016-11-09 05:12:04 UTC
It seems that the issue is still there.

Comment 7 lnie 2016-11-09 05:14:42 UTC
Created attachment 1218801 [details]

Comment 8 Martin Bříza 2016-11-09 11:16:09 UTC
Ok, I think I found it this time. Thank you for the report!
Fixed upstream, coming in the next release

Comment 9 Fedora Update System 2016-11-11 08:09:32 UTC
mediawriter-4.0.4-0.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-239cdfbfd6

Comment 10 Fedora Update System 2016-11-11 16:58:03 UTC
mediawriter-4.0.4-0.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-239cdfbfd6

Comment 11 lnie 2016-11-14 02:32:45 UTC
Still got the same error with the newly mediawriter.

Comment 12 lnie 2016-11-14 02:34:03 UTC
Created attachment 1220222 [details]

Comment 13 lnie 2016-11-14 02:34:44 UTC
Created attachment 1220223 [details]

Comment 14 Martin Bříza 2016-11-14 10:26:43 UTC
Hmm, the same happens to me too. Seems the problem is somewhere else than in mediawriter. Discussing it with one of the storaged developers so we see what to do about it.

Comment 15 Fedora Update System 2016-11-15 13:34:06 UTC
mediawriter-4.0.4-0.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Martin Bříza 2016-11-15 15:09:45 UTC
This was actually a duplicate of #1393379 . It's now fixed in stable repositories.

Comment 17 lnie 2016-11-16 07:23:19 UTC
Still see this error even though I have updated libblockdev to the latest version.

Comment 18 lnie 2016-11-16 07:24:02 UTC
Created attachment 1221050 [details]

Comment 19 Martin Bříza 2016-11-16 10:32:00 UTC
Did you reboot your system (ar at least restart udisks2.service) after installing the update, please?

Comment 20 lnie 2016-11-17 04:29:45 UTC
Yes,I have rebooted my system after updated the libblockdev.And there is something else,not sure if mediawriter's bug:after "Custom image" with F25-workstation-live-RC1.3-x86_64,get a similar error popup :your drive is probably damaged.

Comment 21 lnie 2016-11-17 04:30:37 UTC
Created attachment 1221455 [details]

Comment 22 lnie 2016-11-17 04:31:43 UTC
Created attachment 1221456 [details]

Comment 23 Martin Bříza 2016-11-21 12:43:45 UTC
Hmm, are you sure the flash drive is not, in fact, corrupted? I've tested writing and restoring three different drives on three systems, one of them a clean f25 install and it worked okay.

Comment 24 lnie 2016-11-28 05:36:30 UTC
I have tested the newly 4.0.7,the error messages are gone.But just to be clear,It's pretty fine:after the "restore" error message pops up ,mediawriter still can recognize it,and after saw the "custom image" error message,I have created a virt-machine using it.

Note You need to log in before you can comment on or make changes to this bug.