Bug 1391911 - [RFE] repoquery: get list of all dependent packages (with even soft dependencies)
Summary: [RFE] repoquery: get list of all dependent packages (with even soft dependen...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core   
(Show other bugs)
Version: rawhide
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: ---
Assignee: Jaroslav Mracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: FutureFeature, Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-04 11:13 UTC by Pavel Raiskup
Modified: 2018-09-24 14:51 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-09-24 14:51:28 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pavel Raiskup 2016-11-04 11:13:57 UTC
I was told there's '--whatrequires --alldeps' [1] option, but that doesn't
show the soft dependents.  It would be fine to have something which
covers also soft deps too.

[1] https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/7QAOXOWESPKAN4RT3FNMAOZL3KVQHRXG/

Comment 1 Michael Mráka 2016-11-10 09:05:36 UTC
A request to list all kind of dependencies seems to be very common.

After a discussion we've come up with a proposal to create --depends and --whatdepends options with a similar meaning as --requires/--whatrequires which will include all types of dependencies (hard, weak and very weak).

Comment 2 Pavel Raiskup 2016-11-10 13:05:44 UTC
FTR (I learned that today) there was a bug 84176 where 'rpm --whatdepends' was
also proposed (with a slightly different semantics).  CCing RPM maintainer as
implementing this option differently in RPM/DNF could cause confusion.

Comment 3 Panu Matilainen 2016-11-11 07:11:46 UTC
The way I see it, --depends/whatdepends as a name for a selector for all the dependency variants seems remarkably sane. Never mind bug 84176, that happened a long time ago in a galaxy far far away.

And like with --whatrequires etc, whether the dependency tokens are actually resolved to providing packages should be another switch (eg --alldeps/exactdeps or whatever the exact names were).

Comment 4 Honza Silhan 2016-11-14 12:12:36 UTC
ok, we will do that. Thanks for opinion

Comment 5 Jaroslav Mracek 2017-10-20 14:17:25 UTC
I created a patch (https://github.com/rpm-software-management/dnf/pull/960) that provides requested functionality.

Comment 6 Jaroslav Mracek 2018-06-28 08:28:48 UTC
The issue is solved by dnf-3.0.1-1 that was released into rawhide.


Note You need to log in before you can comment on or make changes to this bug.