This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 139198 - Plugin installation system doesn't work
Plugin installation system doesn't work
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-13 17:34 EST by Kyrre Ness Sjøbæk
Modified: 2007-11-30 17:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-30 17:30:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kyrre Ness Sjøbæk 2004-11-13 17:34:25 EST
Description of problem:
When visiting pages that require a special plugin, such as Flash or
Java, you get a "this page require a plugin to be viewed correctly.
Click here to install it". If i click the button, i get a (really
nice) dialog which finds the correct plugin (in the case of flash, not
in the case of java), and downloads it. But when it is finished
downloading, it just gives a sour message about the instalation failing...

Version-Release number of selected component (if applicable):
1.0

How reproducible:
haven't tried

Steps to Reproduce:
1. go to "www.nrk.no"
2. se the nice litte firefox banner
3. click the install plugins button
4. next, next, next...
5. fails
  
Actual results:
no installation of plugin

Expected results:
plugin should be installed in user's home directory

Additional info:
This worked when using the official installer
Comment 1 Matthew Lenz 2004-11-15 16:24:36 EST
I can verify this as well.  The plugin finder fails to install flash.
Comment 2 Frederic Garzon 2004-11-21 19:40:16 EST
I have a similar problem, when trying to install search plugins in the
search bar.
The dirty trick is to make the
/usr/lib/firefox-1.0/{searchplugins,plugins} directories writable by
the user you normally use to run firefox. this is dirty and not secure.
Earlier, Firefox/Mozilla used to ask the user wether she/he wanted to
install the extension/plugin/searchplugin system-wide or for his sole
profile. Where did this code go ?
Comment 3 Kyrre Ness Sjøbæk 2004-11-22 05:05:24 EST
The best thing would, ofcource, be to have the plugin installer always
install in user's home folder.

If you want a system wide install - go grab a {flash | java} rpm.
Comment 4 petrosyan 2004-12-21 15:44:22 EST
Flash plugin installation works for me.
Java plugin installation still fails.
Comment 5 Kir Kolyshkin 2005-01-10 12:46:09 EST
I have the same problem while trying to install additional search
plugins ("Add Engines..." item in search toolbar menu). It's really
annoying and even painful.]

$ rpm -q firefox
firefox-1.0-2.fc3
Comment 6 Kyrre Ness Sjøbæk 2005-05-02 16:52:31 EDT
Ugh - when i start firefox on a remote machine over ssh with X11 transfer on, it
starts the local copy (of the i am sitting at)?!? Hmm... Strange...

Anyway:
On a fc4/rawhide system, i have firefox-1.0.3-2 installed. I have also used the
plugin finder to install flash.

I start firefox on the site "www.itavisen.no". It asks to open "ticker.swf" in
totem ( :P ), and then me to install flashplayer. I click to install the missing
plugin, installation completes, page reloaded. Same old'n'ugly message.

this is printed to the termial:
[kyrre@mona ~]$ firefox www.itavisen.no
LoadPlugin: failed to initialize shared library
/home/kyrre/.mozilla/plugins/libflashplayer.so
[/home/kyrre/.mozilla/plugins/libflashplayer.so: cannot restore segment prot
after reloc: Ikke tilgang]
UA: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416
Fedora/1.0.3-2 Firefox/1.0.3:, extra:  Firefox/1.0.3
LoadPlugin: failed to initialize shared library
/home/kyrre/.mozilla/plugins/libflashplayer.so
[/home/kyrre/.mozilla/plugins/libflashplayer.so: cannot restore segment prot
after reloc: Ikke tilgang]
LoadPlugin: failed to initialize shared library
/home/kyrre/.mozilla/plugins/libflashplayer.so
[/home/kyrre/.mozilla/plugins/libflashplayer.so: cannot restore segment prot
after reloc: Ikke tilgang]
LoadPlugin: failed to initialize shared library
/home/kyrre/.mozilla/plugins/libflashplayer.so
[/home/kyrre/.mozilla/plugins/libflashplayer.so: cannot restore segment prot
after reloc: Ikke tilgang]

(ikke tilgang == Access denied)
Comment 7 Sean Earp 2005-05-19 23:40:37 EDT
The Flash install should work fine with FC4T3 now.  The problem was originally
tracked on bug 152611, and then moved to bug 151870.  You can read both for
details, but RPM was setting the wrong SELinux security context on the home
directory, so that the plugins would not run after they were installed.  I just
verified that things are working great with Flash on FC4T3.

If someone wants to point me to a site that auto-installs Java, I'll give that a
shot as well.

-Sean
Comment 8 Kyrre Ness Sjøbæk 2005-05-20 10:46:40 EDT
Hmm.. i know one, but you'll need a password and username
(https://www.its-learning.com)

I don't think java install works on upstream either (at least not in Linux) - i
think it complained "could not find plugin" or something like that.

Could SE-linux also be the problem with translations?
Comment 9 Sean Earp 2005-05-29 03:10:36 EDT
Alright-

I just visited a webpage that required JAVA, and firefox correctly routed me to
Sun's page to install Java.  It also informed me that it could not be installed
automatically, and would have to be manually installed.  (As a separate issue,
the  Java RPM from Sun does not work after installation).  This is not a bug
with Firefox, however, which works correctly with both Flash (auto-install)
works fine, and Java (points to an RPM as it can not auto-install it).  I would
say that this bug can be closed as "Not A Bug" or "Rawhide" (as the Flash issue
did exist at one time, but works now in Rawhide).  Once I figure out what is
causing the Java install to not work via RPM, I will file a bug with the
appropriate component.

-Sean
Comment 10 Warren Togami 2005-05-29 03:29:47 EDT
FC4 users are advised to not use Sun's Java RPM.  It contains Provides that
conflict with names used in FC4's packages, meaning Sun Java might disappear
from an installed system during package upgrade operations. FC4 users should use
either jpackage's RPM or install manually the Sun Java tarball into /opt.  Sun
Java 1.5+ is recommended for stability purposes.
Comment 11 Matthew Miller 2006-07-10 16:24:55 EDT
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!
Comment 12 John Thacker 2006-10-30 17:30:44 EST
Closing per lack of response to previous request for information.
This bug was originally filed against a much earlier version of Fedora
Core, and significant changes have taken place since the last version
for which this bug is confirmed.

Note that FC3 and FC4 are supported by Fedora Legacy for security
fixes only.  Please install a still supported version and retest.  If
it still occurs on FC5 or FC6, please reopen and assign to the correct
version.  Otherwise, if this a security issue, please change the
product to Fedora Legacy.  Thanks, and we are sorry that we did not
get to this bug earlier.

Note You need to log in before you can comment on or make changes to this bug.