Bug 1391987 - Wi-fi randomly not working
Summary: Wi-fi randomly not working
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 25
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-04 14:28 UTC by v0mqfish
Modified: 2017-02-28 15:11 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-28 15:11:42 UTC
Type: Bug


Attachments (Terms of Use)

Description v0mqfish 2016-11-04 14:28:20 UTC
Description of problem:
I have randomly periodically disconnect with my wireless pci-e card ASUS PCE-N10
================================================================================
Version-Release number of selected component (if applicable):
Fedora 24, 25. kernel package version: 4.8.4-200.fc24.x86_64
On 4.7.9-200.fc24.x86_64 everything good.
================================================================================
How reproducible:
Use pci-e card ASUS PCE-N10 with kernel 4.8.4-200.fc24.x86_64
================================================================================
Steps to Reproduce:
1. Install Fedora 24 or 25 with kernel 4.8.4-200.fc24.x86_64 (or upgrade your kernel to 4.8.4-200.fc24.x86_64)
2. Use pci-e card ASUS PCE-N10 for network connection
================================================================================
Actual results:
Network randomly periodically (2-3 min) not work properly (after some minutes from boot). Ping result to any destination is "packet loss". Switch airplane mode to "on" and to "off" solves the problem.
================================================================================
Expected results:
Properly network working.
================================================================================
Additional info:
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
        Subsystem: ASUSTeK Computer Inc. PCE-N10
        Flags: bus master, fast devsel, latency 0, IRQ 19
        I/O ports at e800 [size=256]
        Memory at febfc000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [40] Power Management version 3
        Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [70] Express Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Virtual Channel
        Capabilities: [160] Device Serial Number 01-91-81-fe-ff-4c-e0-00
        Kernel driver in use: rtl8192ce
        Kernel modules: rtl8192ce

Comment 1 Justin M. Forbes 2016-11-04 17:05:54 UTC
Is there anything in the logs when it disconnects? There were very few changes to that specific driver in between these two revisions, so I am wondering if it is elsewhere and this is a symptom?

Comment 2 v0mqfish 2016-11-05 07:09:44 UTC
I have updated the kernel to 4.8.6-300.fc25.x86_64 and the problem is still relevant

Nov 05 11:58:26 v0hws NetworkManager[899]: <debug> [1478329106.5096] device[0x55f9a846f410] (wlp2s0): add_pending_action (1): 'scan'
Nov 05 11:58:26 v0hws NetworkManager[899]: <debug> [1478329106.5105] device[0x55f9a846f410] (wlp2s0): remove_pending_action (0): 'scan'
Nov 05 11:58:30 v0hws NetworkManager[899]: <trace> [1478329110.9710] platform-linux: event-notification: NEWLINK, seq 0: 2: wlp2s0 <UP,LOWER_UP;broadcast,multicast,up,running,lowerup> mtu 0 arp 1 wifi? not-init addrgenmode none addr F4:6D:04:A1:6C:D8 rx:3,357 tx:2,288
Nov 05 11:58:30 v0hws NetworkManager[899]: <trace> [1478329110.9724] exported-object[0x7f7ef0004e10]: unexport: "/org/freedesktop/NetworkManager/AccessPoint/9"
Nov 05 11:58:30 v0hws NetworkManager[899]: <trace> [1478329110.9731] exported-object[0x55f9a843cdf0]: unexport: "/org/freedesktop/NetworkManager/AccessPoint/13"
Nov 05 11:58:30 v0hws NetworkManager[899]: <trace> [1478329110.9913] exported-object[0x55f9a84ef040]: export: "/org/freedesktop/NetworkManager/AccessPoint/16"

Comment 3 Laura Abbott 2017-01-17 01:20:21 UTC
*********** MASS BUG UPDATE **************
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 25 kernel bugs.
 
Fedora 25 has now been rebased to 4.9.3-200.fc25.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 26, and are still experiencing this issue, please change the version to Fedora 26.
 
If you experience different issues, please open a new bug report for those.

Comment 4 v0mqfish 2017-01-18 14:52:51 UTC
Unfortunately I can not reproduce this problem, due to the fact that the changed network adapter on the Qualcomm Atheros AR9227. And the problem persists itself.

Comment 5 pjhavariotis 2017-01-23 19:30:23 UTC
I have the same problem on my desktop with RTL8192CE PCIe Wireless Network Adapter and latest kernel (4.9.4-201.fc25.x86_64). In order to connect to the Internet, I setup a wired connection.

Comment 6 czbrooking 2017-01-23 21:02:14 UTC
Also happening on Lenovo E525 laptop. I'm currently booting with the previous kernel on the grub menu.

Comment 7 pjhavariotis 2017-01-24 18:13:37 UTC
The problem still remains with the latest kernel (4.9.5-200.fc25.x86_64)

Comment 8 pjhavariotis 2017-01-24 18:36:17 UTC
The problem is resolved with the latest 4.8 kernel (4.8.6-300.fc25.x86_64)

Comment 9 czbrooking 2017-01-24 19:18:34 UTC
I can report:

Error occurs on kernel-4.9.4-201.fc25.x86_64

Error occurs on kernel-4.9.5-200.fc25.x86_64

Error does not occur on kernel-4.8.6-300.fc25.x86_64

Now I am worried, if it doesn't work with the next kernel upgrade I may lose my working kernel from the grub menu!

Comment 10 pjhavariotis 2017-01-24 19:25:22 UTC
(In reply to czbrooking from comment #9)
> I can report:
> 
> Error occurs on kernel-4.9.4-201.fc25.x86_64
> 
> Error occurs on kernel-4.9.5-200.fc25.x86_64
> 
> Error does not occur on kernel-4.8.6-300.fc25.x86_64
> 
> Now I am worried, if it doesn't work with the next kernel upgrade I may lose
> my working kernel from the grub menu!

Don't worry.
You can install whenever you want the 4.8 "working" kernel:
sudo dnf install kernel-4.8.6-300.fc25
Just bear in mind that you might need to increase the "installonly_limit" value in the appropriate file: /etc/dnf/dnf.conf

Comment 11 czbrooking 2017-01-24 19:26:14 UTC
(In reply to pjhavariotis from comment #10)
> (In reply to czbrooking from comment #9)
> > I can report:
> > 
> > Error occurs on kernel-4.9.4-201.fc25.x86_64
> > 
> > Error occurs on kernel-4.9.5-200.fc25.x86_64
> > 
> > Error does not occur on kernel-4.8.6-300.fc25.x86_64
> > 
> > Now I am worried, if it doesn't work with the next kernel upgrade I may lose
> > my working kernel from the grub menu!
> 
> Don't worry.
> You can install whenever you want the 4.8 "working" kernel:
> sudo dnf install kernel-4.8.6-300.fc25
> Just bear in mind that you might need to increase the "installonly_limit"
> value in the appropriate file: /etc/dnf/dnf.conf


Thanks that's useful!

Comment 12 czbrooking 2017-01-24 19:28:33 UTC
I don't know if it is a symptom or cause but when shutting down with a non-working kernel it hangs in the shutting down dynamic firewall until it times out

Comment 13 Dmitry Stremkouski 2017-01-25 22:55:45 UTC
(In reply to pjhavariotis from comment #10)
> (In reply to czbrooking from comment #9)
> > I can report:
> > 
> > Error occurs on kernel-4.9.4-201.fc25.x86_64
> > 
> > Error occurs on kernel-4.9.5-200.fc25.x86_64
> > 
> > Error does not occur on kernel-4.8.6-300.fc25.x86_64
> > 
> > Now I am worried, if it doesn't work with the next kernel upgrade I may lose
> > my working kernel from the grub menu!
> 
> Don't worry.
> You can install whenever you want the 4.8 "working" kernel:
> sudo dnf install kernel-4.8.6-300.fc25
> Just bear in mind that you might need to increase the "installonly_limit"
> value in the appropriate file: /etc/dnf/dnf.conf

Thank you! Now my wifi card works!

Comment 14 lu4nx 2017-01-26 05:41:02 UTC
I have the same problem on ThinkPad X230 and latest kernel(4.9.5-200.fc25).

I'm currently booting with the old kernel(4.8.16-300.fc25.x86_64) no problem.

Comment 15 kat 2017-01-26 06:38:22 UTC
I also have this problem on a ThinkPad X230 on kernel versions 4.9.5-100.fc24 and 4.9.4-100.fc24, with a Realtek RTL8188CE network controller. I connect to the network for about 1 second and then immediately lose the wireless connection and cannot get it back. 

When I boot with the third most recent kernel (4.8.15-200.fc24) the wireless connection works fine.

Comment 16 Tobias Guggenmos 2017-01-26 15:46:03 UTC
The same issue occurs on my ThinkPad T420 with a Realtek 8188CE wireless card.
Mostly Wifi crashes already while obtaining an IP Address via DHCP. In rare cases, usually after graphical login the internet connection remains for about 20 seconds.

On a 4.8 kernel everything works fine.

Comment 17 czbrooking 2017-01-29 12:26:00 UTC
Here is my wifi hardware from lspci:

------------------
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
04:00.0 System peripheral: Ricoh Co Ltd PCIe SDXC/MMC Host Controller (rev 07)
05:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
-------------------

Comment 18 czbrooking 2017-01-31 20:07:23 UTC
still not working with kernel-4.9.6-200.fc25.x86_64

Comment 19 Patrick Monnerat 2017-02-01 14:16:15 UTC
Same problem here on a Toshiba laptop (Realtek 8188CE): after dnf update and reboot (Jan 29, with kernel 4.9.6), connect is OK but no packet transmitted.
Original live F25 Mate DVD is OK.
I have tried to reinstall packages from the original F25 distro for kernel-*, wpa_supplicant and NetworkManager-*. This only resolves the problem partially: it works or not randomly.
Maybe this is also a linux-firmware problem (didn't try to use the original) ?

Comment 20 Tobias Guggenmos 2017-02-08 16:48:36 UTC
This seems to have been fixed by "[PATCH] rtlwifi: rtl8192ce: Fix loading of incorrect firmware" posted to lkml.

The patch has already been merged in linux-next.

Comment 21 Laura Abbott 2017-02-09 20:22:36 UTC
Can people confirm that https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=52f5631a4c05 ([PATCH] rtlwifi: rtl8192ce: Fix loading of incorrect firmware) fixes the issue either by running rawhide or building it yourself? If so I can pull it in.

Comment 22 Tobias Guggenmos 2017-02-10 20:24:47 UTC
The patch has not yet been included in rawhide. Im currently building myself and will come up with results tomorrow.

Comment 23 Tobias Guggenmos 2017-02-10 22:43:14 UTC
Applying the patch on top of v4.10-rc7 fixes the bug for me.

Since there have been no changes to that specific driver since v4.9, the patch should work with v4.9.x Kernels, too.

Comment 24 Tobias Guggenmos 2017-02-14 12:30:38 UTC
I think, we actually messed up two bugs here:

1. The Wireless instability initially mentioned by v0mqfish. Here the wireless connection breaks after a few minutes, but can be recovered by reconnecting the network. I experienced this bug myself since about May 2016 (back then on Fedora 23) and even with the patch mentioned before applied the Wifi connection breaks from time to time. 


2. The driver crash caused by loading the incorrect firmware. Somewhere between kernel 4.8 and 4.9 an if clause to decide which firmware to load had been removed, which sometimes causes the wrong firmware to be loaded and the Wireless driver to stop working. The result is that Wifi crashes after some seconds and is not recoverable, as described by kat@mindspillage.org. The mentioned change has been undone by "[PATCH] rtlwifi: rtl8192ce: Fix loading of incorrect firmware". After applying this patch (Tested with kernel v4.9 and v4.10-rc7) the second issue is resolved, while the first  one remains.

Comment 25 Tobias Guggenmos 2017-02-15 16:37:58 UTC
The patch is included in mainline kernel v4.9.10 so this problem(#2) will hopefully be fixed with the next kernel upgrade.

Comment 26 Tobias Guggenmos 2017-02-15 16:38:47 UTC
The patch is included in mainline kernel v4.9.10 so this problem(#2) will hopefully be fixed with the next kernel upgrade.

Comment 27 lu4nx 2017-02-17 14:39:34 UTC
(In reply to Tobias Guggenmos from comment #26)
> The patch is included in mainline kernel v4.9.10 so this problem(#2) will
> hopefully be fixed with the next kernel upgrade.

I load rtl8192ce module for 4.9.10 is no problem.

I download Linux 4.9.10 kernel source code from www.kernel.org, and build new rtl8192ce code:

$ cd ./drivers/net/wireless/realtek/rtlwifi/rtl8192ce
$ sudo make -C /lib/modules/`uname -r`/build M=`pwd` modules
$ sudo make -C /lib/modules/`uname -r`/build M=`pwd` modules_install

and remove old rtl8192ce module in memory, and load new module to memory:

$ sudo rmmod rtl8192ce
$ sudo insmod /lib/modules/`uname -r`/extra/rtl8192ce.ko

Now, it's ok.

Comment 28 Tobias Guggenmos 2017-02-22 21:01:49 UTC
The Bug discussed since at least comment 7 should have been fixed with the latest kernel update (4.9.10). Does the issue persist after upgrading and rebooting? 

On my system everything works normal again, now.

Comment 29 pjhavariotis 2017-02-25 18:33:14 UTC
On my system (4.9.11-200.fc25) works too!

Comment 30 czbrooking 2017-02-26 14:51:07 UTC
Also working on Lenovo E525 thinkpad

Comment 31 Laura Abbott 2017-02-28 15:11:42 UTC
Thanks everyone for testing. I'm going to close this bug. If the problem shows up again, please open a new bug.


Note You need to log in before you can comment on or make changes to this bug.