Bug 139203 - scanimage does not see libusb scanner for non-root user
scanimage does not see libusb scanner for non-root user
Status: CLOSED DUPLICATE of bug 121511
Product: Fedora
Classification: Fedora
Component: sane-backends (Show other bugs)
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Depends On:
  Show dependency treegraph
Reported: 2004-11-13 18:40 EST by David Lerner
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-11-16 04:20:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description David Lerner 2004-11-13 18:40:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
sane-find-scanner shows: found USB scanner (vendor=0x04b8 [EPSON],
product=0x0110 [EPSON Scanner]) at libusb:001:003 for both root and
non-root user.

scanimage -L shows: device `epson:libusb:001:003' is a Epson GT-8200
flatbed scanner for root but: No scanners were identified. for
non-root user.

scanimage -d epson:libusb:001:003>image produces image for root user
but scanimage: open of device epson:libusb:001:003 failed: Invalid
for non-root user.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Log in as non-root user
2. Attach and power-on Epson USB scanner
3. Run scanimage -L

Actual Results:  No scanners were identified

Expected Results:  device `epson:libusb:001:003' is a Epson GT-8200
flatbed scanner

Additional info:
Comment 1 Teppo Turtiainen 2004-11-14 08:27:40 EST
I'm having the same problem with HP PSC 2175 scanner.
Comment 2 David Lerner 2004-11-14 15:08:19 EST
Scanner ownership and permissions are defined in
/etc/udev/permissions.d/50-udev.permissions. Ownership should belong
to console user. A work around, since I don't know how to fix
ownership, is to set permissions for usb/scanner* to 0666.
Comment 3 Tim Waugh 2004-11-15 04:22:09 EST
What about when you switch off, and then on, the scanner?
Comment 4 David Lerner 2004-11-15 22:47:06 EST
No switch on scanner, but disconnecting and reconnecting either power
or usb cable make the scanner accessable to a non-root user.

My earlier observation about permissions was probably a
misinterpretation of steps that I took to get the scanner working.

On one of many tests the scanner was accessable without having to
disconnect and reconnect it.
Comment 5 Tim Waugh 2004-11-16 04:20:16 EST

*** This bug has been marked as a duplicate of 121511 ***

Note You need to log in before you can comment on or make changes to this bug.