Bug 139210 - The i2o block driver lists SCSI disks as hda
The i2o block driver lists SCSI disks as hda
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-13 20:15 EST by Glen
Modified: 2015-01-04 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-13 23:39:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Glen 2004-11-13 20:15:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
I have a Supermicro P4DC6+ motherboard with an Adaptec 2005S zero
channel RAID card.  Attched to the system are two 18 gig SCSI drives
which I configured as RAID 0 using the SCSI bios utility.  When I
booted up the Fedora Core 3 installer, first of all it didn't detect
my RAID until I loaded the i2o block module.  It listed my RAID as
hda1 and hda2, but they were kinda combined together.  I was still
able to install however by just deleting any existing partitions (it
thought there were partitions on there left over from when I had it in
RAID 1 mode I guess).  I find this strange since I'm used to the RAID
device simply being listed as sda.  What makes it even more strange
though is that my cd burner is on the primary ide channel, and so it's
hda.  Perhaps this isn't a bug though, and RedHat just has a different
way with dealing with this device?  If so, sorry to bother anyone.

Version-Release number of selected component (if applicable):
kernel-smp-2.6.9-1.667

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora Core 3
2.
3.
    

Additional info:
Comment 1 Warren Togami 2004-11-13 23:39:31 EST
2.6 kernel uses the i2o_block driver, which is a native interface to
I2O devices which really has nothing to do with SCSI.  /dev/i2o/hda is
the first logical disk of I2O, while partitions are hda1, hda2, etc.

Note You need to log in before you can comment on or make changes to this bug.