Bug 1392102 - Fix for sizing issues affecting programs using wxWidgets and gtk+3 > 19
Summary: Fix for sizing issues affecting programs using wxWidgets and gtk+3 > 19
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wxGTK3
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Scott Talbert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-04 19:59 UTC by David Hart
Modified: 2016-11-21 02:22 UTC (History)
2 users (show)

Fixed In Version: wxGTK3-3.0.2-29.fc25 wxGTK3-3.0.2-29.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-19 21:18:47 UTC
Type: Bug


Attachments (Terms of Use)
Sizing patch (4.77 KB, patch)
2016-11-04 19:59 UTC, David Hart
no flags Details | Diff

Description David Hart 2016-11-04 19:59:40 UTC
Created attachment 1217498 [details]
Sizing patch

fedora 24 and later come with gtk+3 versions >=20. These made changes that break wxWidgets sizing: see http://trac.wxwidgets.org/ticket/17585. This was particularly noticeable in 4Pane, of which I'm upstream and for which I managed to create a hackish workaround.

A proper fix has now been made in the wx3 branch: see http://trac.wxwidgets.org/changeset/6475376931bf316a4fd791114408f7c1fc2fe836/git-wxWidgets. The attached patch contains those changes in a way that applies cleanly to wxGTK3.git. I can confirm that this builds and works successfully in fedora 25.

I hope you will agree to apply it.

Comment 1 Scott Talbert 2016-11-04 21:51:34 UTC
Yes, we'll apply it.  I saw those patches by Paul.

TBH, the number of patches we're carrying is starting to get unwieldy.  I wonder if we should just consider packaging a git snapshot since upstream wx hasn't done a release in 2 years.

Comment 2 Jeremy Newton 2016-11-06 00:06:42 UTC
Agreed, I would suggest taking snapshots of WX_3_0_BRANCH if you feel the patches are getting out of hand.

Comment 3 Scott Talbert 2016-11-06 02:26:37 UTC
(In reply to Jeremy Newton from comment #2)
> Agreed, I would suggest taking snapshots of WX_3_0_BRANCH if you feel the
> patches are getting out of hand.

Yeah, maybe we could start doing that in F26, say.  I'd be hesitant to do it in a stable release though.

Comment 4 Fedora Update System 2016-11-14 03:58:40 UTC
wxGTK3-3.0.2-29.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b372d67ade

Comment 5 Fedora Update System 2016-11-14 03:59:19 UTC
wxGTK3-3.0.2-29.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-da57f5c618

Comment 6 Fedora Update System 2016-11-15 02:29:58 UTC
wxGTK3-3.0.2-29.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-da57f5c618

Comment 7 Fedora Update System 2016-11-15 13:26:40 UTC
wxGTK3-3.0.2-29.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b372d67ade

Comment 8 Fedora Update System 2016-11-19 21:18:47 UTC
wxGTK3-3.0.2-29.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2016-11-21 02:22:52 UTC
wxGTK3-3.0.2-29.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.