Bug 139215 - Installer error Bug: Assertion ((C * heads + H) * sectors + S == A) at disk_dos.c:495 in function probe_partition_for_geom() failed. (headers < 256)
Summary: Installer error Bug: Assertion ((C * heads + H) * sectors + S == A) at disk_d...
Status: CLOSED DUPLICATE of bug 138419
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-14 04:48 UTC by Adam Potter
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:07:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dump from anaconda. (734.78 KB, text/plain)
2004-11-14 04:50 UTC, Adam Potter
no flags Details
This is the Hardware info for my system (125.73 KB, text/plain)
2004-11-14 04:51 UTC, Adam Potter
no flags Details

Description Adam Potter 2004-11-14 04:48:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
On start of the anaconda installer, after selection of language, I get
a bug report error consisting of:

error: Bug: Assertion ((C * heads + H) * sectors + S == A) at 
disk_dos.c:495 in function probe_partition_for_geom() failed.

Can continue by clicking ignore or cancel; install procedure continues
fine until disk partitioning..the error comes up again when
partitioning.  Can still continue from this point by clicking ignore
or cancel multiple times; installation continues well until file
copying and drive formatting is about to begin.  I then get the
message that there is an assertion error, and get the option to copy
the output or write an output dump to the floppy drive (which I did,
and will include with this report).
Dump to floppy works, and installer exits.

Version-Release number of selected component (if applicable):
anaconda from FC3 isos

How reproducible:
Always

Steps to Reproduce:
1.Boot from either FC3 install disc 1, or boot cd.
2.Choose language.
3.As installer loads, error appears.
    

Actual Results:  I got the error message that is being reported.

Expected Results:  Continued through the installation.

Additional info:

/dev/hda1 vfat 9.4 GB
/dev/hda5 vfat 18.6 GB
/dev/hda6 reiserfs 9.8 GB (Mount Point "/" to be reformatted during
install)
/dev/hda7 swap
/dev/hda8 reiserfs 18.7 GB (Mount Point "/home" to be reformatted
during install)

More in attached HWinfo.txt

Comment 1 Adam Potter 2004-11-14 04:50:18 UTC
Created attachment 106658 [details]
Dump from anaconda.

This is the traceback and dump from the FC3 Anaconda installer.

Comment 2 Adam Potter 2004-11-14 04:51:23 UTC
Created attachment 106659 [details]
This is the Hardware info for my system

This is the hardware info for my system.

Comment 3 Edwin Chan 2004-11-14 14:10:57 UTC
Looks like a duplicate of Bug 138419

Comment 4 Adam Potter 2004-11-14 14:15:36 UTC
How does one go about fixing this?

Comment 5 Jeremy Katz 2004-11-15 15:16:05 UTC

*** This bug has been marked as a duplicate of 138419 ***

Comment 6 Red Hat Bugzilla 2006-02-21 19:07:00 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.