Bug 139241 - Java segfaults with SMP kernel
Java segfaults with SMP kernel
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-14 07:13 EST by Ronny Buchmann
Modified: 2015-01-04 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 13:44:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronny Buchmann 2004-11-14 07:13:45 EST
Description of problem:
Running any of j2re1.4.2-06(SUN), j2re1.4.2-03(Blackdown),
jre-1.5(SUN) results in segfault (1.4.2 immediate, 1.5 while running a
java app).

I'm not able to run it within gdb.
---
(gdb) r
Starting program: /opt/j2re1.4.2/bin/java
(no debugging symbols found)...[Thread debugging using libthread_db
enabled]
[New Thread 1119936 (LWP 5701)]
(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...Cannot find user-level thread for LWP 5701:
generic error
---

Version-Release number of selected component (if applicable):
kernel-smp-2.6.9-1.667

With UP kernel it runs fine.
There are no kernel messages.
System is a P4 with HT.
Comment 1 Sitsofe Wheeler 2004-12-03 16:57:08 EST
You are better off reporting this to the JRE vendors (for Sun go to
http://bugs.sun.com/bugdatabase/index.jsp ) since they have the source and can
see where this is crashing and can determine whether it is actually a bug in the
JVM.
Comment 2 Ronny Buchmann 2004-12-07 13:44:56 EST
It's ok with kernel-smp-2.6.9-1.698_FC3.

Could the 4G/4G split have been the cause?

Note You need to log in before you can comment on or make changes to this bug.