Bug 139242 - prism54 cardbus card does not ifups on boot
prism54 cardbus card does not ifups on boot
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-14 07:20 EST by Oleg I. Vdovikin
Modified: 2014-03-16 22:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-15 12:56:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oleg I. Vdovikin 2004-11-14 07:20:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
FC3 does not ifup cardbus prism54 cards and as seems hotplugging does
not work for ALL socketed cards. The problem is that /etc/rc.sysinit
modprobes all modules, including pcmcia ones, keeping hotplug
disabled. As the result all required modules are get loaded, but are
not hotplugged.


Version-Release number of selected component (if applicable):
initscripts-7.93.5-1

How reproducible:
Always

Steps to Reproduce:
1. Ensure that ONBOOT=no for the PC card in question
2. Boot PC with prism54 card installed in the cardbus slot
    

Actual Results:  Network interface is down

Expected Results:  Network interface is up and running

Additional info:

Seems rc.sysinit should not load kmodules marked as SOCKET, pcmcia
should load them.
kmodule output:

OTHER i8xx_tco
OTHER hw_random
NETWORK prism54
NETWORK e100
AUDIO snd-maestro3
USB uhci-hcd
SOCKET yenta_socket
SOCKET yenta_socket

As temporal workaround I've added yenta_socket to the
/etc/hotplug/blacklist, and it's now work as expected. But the right
thing should probaby check for "SOCKET" type and skipping these modules.
Comment 1 Bill Nottingham 2004-11-15 00:48:41 EST
What happens if you change it to ONBOOT=yes? :)
Comment 2 Oleg I. Vdovikin 2004-11-15 03:03:12 EST
with ONBOOT=yes and card inserted to the slot, interface is going up, 
during network startup. But, with no card inserted network fails (I 
mean it will write [FAILED] instead of [OK], breaking quite rhgb 
boot ;-) ).
So, just to clarify, with prior versions - RH8/9, FC1/2 card was 
properly initilized (with ONBOOT=no) during the pcmcia startup, just 
like it does when it inserted while linux is running. It's not the 
case now - pcmcia does not fire hotplug events during startup any 
longer... And yes, reinserting card with FC3 initiliaze it properly.
So, this is mostly generic problem as seems, not only network related.
Comment 3 Oleg I. Vdovikin 2004-11-15 12:56:32 EST
Just checked ONBOOT=yes, and yes it's work fine even with no card
installed in the slot. My apologise.
Thank you.

Note You need to log in before you can comment on or make changes to this bug.