Bug 13925 - ping -f works fast, ftp does not (Athlon)
ping -f works fast, ftp does not (Athlon)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i686 Linux
high Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-13 19:14 EDT by gsr.bugs
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-16 19:31:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gsr.bugs 2000-07-13 19:14:43 EDT
Testing the ethernet with flood pings from one machine to another works 
perfectly (less than 300 lost in a run of over 1.3 M tests), but when 
trying ftp transfers, the speed becomes slow, so you only get 10 or so KB/s 
(instead of a normal 1MB/s).

The Athlon card is a 3c905, the other computers have PCI Realteks 8029 or 
noname ISA ne2000 compatible. I also tried with another 8029, to check the 
problem is somewhere else, and not the 3com card. Among the other machines 
FTP works perfectly, and I even changed cables to test them, but the 
problem seems to be in the K7 one (kernel? ICMP vs TCP?).

The kernel is the one form 6.1 cos 6.2 is unable to launch Netscape 4.73. 
To be precisse the machine got 6.1, then upgraded to 6.2, and installed 
again old kernel, due the other faliure (reported in another bugreport as 
"K7 + 2.2.14 + Netscape = nothing", number 13924). The rest of things are 
6.2 (I kept 6.2's kernel with multiboot).

At this moment the machine is near networkless, moves as if I used a
modem or ISDN instead of Ethernet.

GSR
Comment 1 gsr.bugs 2000-07-16 19:31:42 EDT
Using the 2.2.16 for i386 the ftp (and http too, Apache in other machine, wget 
in the K7) test went up to 180 KB/s (+/-10). The ping -f works perfectly (aka a 
few losses in test of 100K or 1M ping packets), and a NFS test gave me 820 KB/s 
(more normal, IMO).

From watching the hub leds, I saw that ping had no collisions (or flashed so 
quickly that I could no view the LED). NFS had some, but few, and some small 
stops (normal? obviously it is the reason I get 820 KB/s instead of 1.1MB/s, I 
use NFS rarelly, so I do not know if that is normal with machines that work). 
But the ftp and http still had too many collisions and are extrangely slow.

BTW, I have tested with 3c59x driver (bad but works, results above) and 3c90x 
(crappy, worse than above results or does not work at all, sends some data and 
then stops) drivers that comes in latest kernels. I will keep on investigating. 
Any advices about where or what to look are appreciated.

GSR
Comment 2 gsr.bugs 2000-07-18 19:39:21 EDT
It seems it was about hardware config and bad cabling. I have not tested again 
the official 3c90x driver, but with the 3c59x works now. Sorry to bug you. I 
will check with the official 3com 3c90x module to see if this one is buggy... 
now that I have started to play with it.

GSR

Note You need to log in before you can comment on or make changes to this bug.