Bug 139254 - ctrl-c does not quit yum
Summary: ctrl-c does not quit yum
Status: CLOSED DUPLICATE of bug 139459
Alias: None
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-14 14:49 UTC by Sitsofe Wheeler
Modified: 2014-01-21 22:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-20 18:10:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sitsofe Wheeler 2004-11-14 14:49:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040804 Galeon/1.3.17

Description of problem:
Yum does not quit when ctrl-c if it is downloading packages during a
yum update.

Version-Release number of selected component (if applicable):
yum-2.1.11-3

How reproducible:
Always

Steps to Reproduce:
1. Install fedora core 3
2. Configure /etc/yum.repos.d/fedora-updates.repo not to use
mirrorlist and to instead use a single baseurl from a http:// for
ftp:// source.
3. Type yum update say y to upgrading packages and while a package is
being downloaded press ctrl-c.
    

Actual Results:
yum says
"Trying other mirror."
(even though only one mirror is configured!) and will skip to
downloading the next package.

Expected Results:
yum to quit.

Comment 1 Seth Vidal 2004-11-14 17:44:31 UTC
I can duplicate this one. The problem is this. Downloadpkgs is
supposed to be handled as a complete set and report errors on
downloading any of those packages as a whole, not individually. It was
a complaint of yum 2.0.X that any one package download failure would
make yum exit. They wanted it to download all of them then report on
which ones failed.

Your problem is different, you just want ctrl-c to do what you'd
expect it to do, abort when you don't have a mirror.

I'll see what I can do.


Comment 2 Rahul Sundaram 2005-06-20 18:10:56 UTC

*** This bug has been marked as a duplicate of 139459 ***


Note You need to log in before you can comment on or make changes to this bug.