Bug 1392605 - Most Qt5 applications crash when opening any file dialog under GNOME wayland session
Summary: Most Qt5 applications crash when opening any file dialog under GNOME wayland ...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk3
Version: 25
Hardware: All
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: https://fedoraproject.org/wiki/Common...
Keywords: CommonBugs
: 1392597 1392601 1392604 1398970 1399045 1405117 (view as bug list)
Depends On:
Blocks: WaylandRelated 1392597 1392601 1392604 1405117
TreeView+ depends on / blocked
 
Reported: 2016-11-07 21:33 UTC by Christian Stadelmann
Modified: 2017-04-04 15:19 UTC (History)
11 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-01-09 16:43:11 UTC


Attachments (Terms of Use)

Description Christian Stadelmann 2016-11-07 21:33:15 UTC
Description of problem:
It seems like most Qt5 applications crash whenever they should display a file chooser in a GNOME wayland session.

Version-Release number of selected component (if applicable):
gtk3-3.22.2-1.fc25.x86_64
glib2-2.50.1-1.fc25.x86_64
libwayland-client-1.12.0-1.fc25.x86_64
qt5-qtbase-5.7.0-3.fc25.x86_64

How reproducible:
always under a GNOME wayland session

Steps to Reproduce:
1. Open Qt5 application
2. open any file dialog
3. watch what happens

Actual results:
Application crashes right after logging this warning message:

Gdk-WARNING **: gdkwindow-x11.c:5554 drawable is not a native X11 window

Expected results:
No crash.

Additional info:
This bug affects:
TeXstudio (see bug #1392597)
KWrite (see bug #1392601)
Ark (see bug #1392604)
Konversation
Marble
KAlgebra

This bug does not affect:
Okular (Qt4)
VLC (Qt5)

Workaround:
Start all affected applications with GDK_BACKEND=x11 environment variable.

Comment 1 Christian Stadelmann 2016-11-07 21:55:43 UTC
Also affects:
Dolphin (in application chooser dialog for opening files with)
Calibre (see bug #1387928 and upstream https://bugreports.qt.io/browse/QTBUG-55583 )

I'm not closing these bugs as duplicates because the stacktraces differ slightly.

Nominating as Blocker because this bug affects quite many applications and is quite serious.

If you don't think this is a blocker, please consider adding a freeze exception.

This issue not only happens on Fedora, but also on other distros:
https://bbs.archlinux.org/viewtopic.php?id=218831
https://github.com/fritzing/fritzing-app/issues/3264
https://sourceforge.net/p/gnuplot/mailman/gnuplot-beta/

A KDE upstream bug report:
https://bugs.kde.org/show_bug.cgi?id=369467

A similar issue was present in nautilus but got fixed:
https://bugzilla.gnome.org/show_bug.cgi?id=758026

Other possible duplicates:
https://bugzilla.redhat.com/show_bug.cgi?id=1383069

Comment 2 Adam Williamson 2016-11-07 22:50:54 UTC
Do we have any affected apps in a default Workstation install?

Anyone close to a fix for it?

Comment 3 Christian Stadelmann 2016-11-07 22:59:55 UTC
(In reply to Adam Williamson from comment #2)
> Do we have any affected apps in a default Workstation install?

I don't think so. Removing qt5-qtbase doesn't remove anything important and nothing I've seen in Workstation composes.

Comment 4 Kamil Páral 2016-11-08 12:13:36 UTC
I can reproduce the crash with kwrite, as long as I don't have qgnomeplatform installed. If I have it installed, it seems to work OK. Christian, can you confirm?

Comment 5 Kamil Páral 2016-11-08 12:17:02 UTC
qgnomeplatform seems to be a part of a default Workstation installation.

Comment 6 Christian Stadelmann 2016-11-08 12:42:05 UTC
(In reply to Kamil Páral from comment #4)
> I can reproduce the crash with kwrite, as long as I don't have
> qgnomeplatform installed. If I have it installed, it seems to work OK.
> Christian, can you confirm?

I can confirm that. Since qgnomeplatform is in Fedora Workstation, I'm removing the blocker proposal for this bug. Sorry for the noise. I don't know why this package is not installed on my machine, but after installing qgnomeplatform, the issue is gone for me.

Anyway, Qt5 or Gtk3 (whoever is to blame) should bail out more gracefully instead of running into a SIGSEGV.

Comment 7 Kamil Páral 2016-11-08 13:37:25 UTC
It is possible that qgnomeplatform is not installed on system upgrades.

Comment 8 Matthias Clasen 2016-11-08 15:14:43 UTC
If qt applications crash, why is this bug filed against gtk3 ?

Comment 9 Adam Williamson 2016-11-08 17:05:02 UTC
At a quick glance, it seems like qgnomeplatform has only been in comps since f24. If you installed before f24 and upgraded, and nothing you have installed has an explicit qgnomeplatform dep, and you didn't do a 'dnf groupinstall workstation-product' or similar after upgrading, that could explain it not being present. Perhaps we should document that. I don't know if dnf-system-upgrade or the Software graphical upgrade 'refresh' group packages on upgrade or not.

Comment 10 Christian Stadelmann 2016-11-08 17:29:24 UTC
(In reply to Matthias Clasen from comment #8)
> If qt applications crash, why is this bug filed against gtk3 ?

Because it only happens with the Gtk3 filechooser and can be worked around by using GDK_BACKEND=x11. And from the backtrace it also looks more like Gtk/GLib than Qt. You probably know better so feel free to reassign.

(In reply to Adam Williamson from comment #9)
> At a quick glance, it seems like qgnomeplatform has only been in comps since
> f24. If you installed before f24 and upgraded, and nothing you have
> installed has an explicit qgnomeplatform dep, and you didn't do a 'dnf
> groupinstall workstation-product' or similar after upgrading, that could
> explain it not being present. Perhaps we should document that. I don't know
> if dnf-system-upgrade or the Software graphical upgrade 'refresh' group
> packages on upgrade or not.

That's the case for me. Installed with F23, then upgraded F23→F24 and F24→F25 with dnf system-upgrade.
How about adding a section to https://fedoraproject.org/wiki/Common_F25_bugs ?
How about adding a weak ("Recommends:") dependency to adwaita-qt5 or some similiar package as a workaround?

Comment 11 Adam Williamson 2016-11-08 17:56:17 UTC
"How about adding a section to https://fedoraproject.org/wiki/Common_F25_bugs ?"

That's why we set the CommonBugs keyword. :)

Comment 12 John Freed 2016-11-27 18:17:59 UTC
*** Bug 1398970 has been marked as a duplicate of this bug. ***

Comment 13 John Freed 2016-11-27 18:37:22 UTC
Comment #7 and Comment #9 are correct. Suggest you include qgnomeplatform in the default upgrade. I can confirm that this solved the problem:

sudo dnf install qgnomeplatform

Also noticed that when I do:

dnf group list

"Fedora Workstation" is listed in the "Available environment groups" and not "Installed groups". Solved that with:
sudo dnf group install "Fedora Workstation" --best --allowerasing

Again, should this not be included by default on a Fedora Workstation upgrade?

Comment 14 Markus S. 2016-12-20 13:24:29 UTC
(In reply to Adam Williamson from comment #9)
> At a quick glance, it seems like qgnomeplatform has only been in comps since
> f24. If you installed before f24 and upgraded, and nothing you have
> installed has an explicit qgnomeplatform dep, and you didn't do a 'dnf
> groupinstall workstation-product' or similar after upgrading, that could
> explain it not being present.

Sounds like qgnomeplatform should be a dependency of gnome-session-wayland-session until that bug is resolved.

I didn't have qgnomeplatform installed either and suffered from that bug until I found this report.

Comment 15 Emmanuel Touzery 2017-01-08 19:35:18 UTC
*** Bug 1399045 has been marked as a duplicate of this bug. ***

Comment 16 Rex Dieter 2017-01-08 21:40:51 UTC
Is this still reproducible with
qt5-qtbase-5.7.1-10.fc25
from
https://bodhi.fedoraproject.org/updates/FEDORA-2017-e2f57cb7cd
?

Comment 17 Christian Stadelmann 2017-01-08 23:19:40 UTC
After uninstalling qgnomeplatform and upgrading to qt5-qtbase-5.7.1-10.fc25, this issue is gone.

Comment 18 Rex Dieter 2017-01-08 23:42:21 UTC
and qt5-qtbase-5.7.1-10.fc25 *with* qgnomeplatform?  (still crashes?)

Comment 19 Christian Stadelmann 2017-01-09 09:56:53 UTC
(In reply to Rex Dieter from comment #18)
> and qt5-qtbase-5.7.1-10.fc25 *with* qgnomeplatform?  (still crashes?)

No, with qgnomeplatform it did not crash. Installing qgnomeplatform was the workaround described in comment #4comment #7.

Comment 20 Rex Dieter 2017-01-09 15:23:53 UTC
OK, so issue is resolved?

Comment 21 Christian Stadelmann 2017-01-09 16:09:26 UTC
(In reply to Rex Dieter from comment #20)
> OK, so issue is resolved?

As far as I can tell, yes.

Comment 22 Rex Dieter 2017-01-09 16:43:11 UTC
Thanks.

Comment 23 Christian Stadelmann 2017-04-04 14:45:41 UTC
*** Bug 1392601 has been marked as a duplicate of this bug. ***

Comment 24 Christian Stadelmann 2017-04-04 14:45:42 UTC
*** Bug 1392597 has been marked as a duplicate of this bug. ***

Comment 25 Christian Stadelmann 2017-04-04 14:46:05 UTC
*** Bug 1392604 has been marked as a duplicate of this bug. ***

Comment 26 NMueller 2017-04-04 15:19:16 UTC
*** Bug 1405117 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.