Bug 139263 - wifi not connecting using NetworkManager
wifi not connecting using NetworkManager
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-14 12:14 EST by Justin Georgeson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-10 00:22:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Georgeson 2004-11-14 12:14:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
I have a laptop with a Linksys WPC11v3 (prism chipset) for which I use
the orinoco_cs driver and have the SSID and WEP key specified in
/etc/sysconfig/network-scripts/ifcfg-eth1. It works fine using the old
way, but I want to set up NetworkManager and be cool. :p I haven't
seen a HOWTO on setting up NetworkManager (I guess the point is you
don't have to 'set it up') and I'm having some issues. I get the
impression that if I turn on the NetworkManager service (which is
required to use it) I should turn of the network service, is that
right? Also, set all interfaces to not start at boot? If so, check.
When I start NetworkManagerInfo after logging in (not as root), I get
the radar applet looking for a net. 

My wifi network uses 128 bit WEP and does not broadcast the SSID. So I
select Other Wireless Networks and am prompted for the ESSID. So I
type it in and click the Connect button. The first time I did this my
machine froze hard. I had to hold down the power button to turn it off
and reboot. The second time it didn't lock the machine, I got the blue
swirly thing with two dots. Then it crashed and I had no more network
connectivity. I rebooted just to make sure I was working in a clean
state. So now, the third time I'm trying, after setting the SSID
clicking Connect I seem to be perpetually waiting with the blue swirly
and two dots. If I click on the applet it lists my SSID with a
selected radio button to the left and an empty status/progress bar on
the right. I have never been prompted for a WEP key.

I tried to read all the bugs related to NetworkManager in bugzilla,
and read something about disabling ipv6 in /etc/modprobe.conf and
another bug that says NM breaks ipv6. I don't use ipv6 so don't mind
disabling it but don't know how (bug didn't specify). I've seen a few
bugs with similar problems to mine, but couldn't derive any solutions
from them.

Version-Release number of selected component (if applicable):
NetworkManager[-gnome]-0.3.1-3

How reproducible:
Always

Steps to Reproduce:
1. Enable NetworkManager service
2. Log in
3. Run NetworkManagerInfo
    

Actual Results:  either the laptop crashes, the NetworkManager system
crashes (didn't see if it was client, daemon, or both), or it just
never connects, 

Expected Results:  I should be able to enter my SSID and be prompter
for a WEP key, after which the NIC will assosciate and connect, and
balance will be restored to the universe

Additional info:
Comment 1 Jon Savage 2004-11-14 19:09:20 EST
I'm seeing the same thing with a WPC11v3 as well.
The card does work fine when configured oldstyle(tm).
Following the same sequence as Justin.

Comment 2 Jon Savage 2004-11-20 10:55:47 EST
Well I got it working (sort of).
started the daemon
removed the wireless card via the network config tool
did cardctl eject, reinserted the card
readded the nic, configured it
saved config
ran NetworkManagerInfo
machine did not lock up but also did not
connect.
rebooted system (saved settings)
the nic came up, NMINFO shows up in notification area
and things seem to be working; Off to Barnes & Noble to see if I can
hook into their WAP :).
Comment 3 Justin Georgeson 2004-11-21 12:52:19 EST
I just tried NetworkManagerInfo again using a WEP network with the
SSID broadcasted. There are actually two networks in range
broadcasting their SSID, and neither show up in the applet. I've seen
some forum posts mention patching the orinoco_cs driver so that it can
scan. I've also read that the linux-wlan-ng prism2 driver can scan.
Once I start NetworkManagerInfo and the aplet loads, I select Other
Network and enter the SSID. The applet changes from the radar to the
two dots with a 'swoosh' rotating between them. But I'm never prompted
for a password, even logged in as root. When I double-click on the
aplet, the laptop hard crashes. Should I try patching the orinoco_cs
driver? What about installing the linux-wlan-ng prism2 driver? Any
notes on how to do either?
Comment 4 Jon Savage 2004-11-23 09:18:33 EST
It seems to work for me *only* for a device that I've already
configured manually. Trying to connect to another WAP w/ a known ESSID
via the 'other wireless network' dialog results in either the radar
going on forever (or) the two swirly dots dancing forever (or) a hard
lockup that takes a hard boot to fix. Any of these scenarios can
occur, seems almost random.

I also suspect that it may have to do with using the unpatched drivers
for this card, I'll try to get the patched drivers & see it that makes
a difference.
Comment 5 Dan Williams 2004-11-23 11:39:50 EST
The orinoco drivers in the Linux Kernel (upstream, not specifically
Fedora) are not quite up to date.  They don't support scanning, and
there are further fixes that haven't been merged to the kernel.  You'd
best either try upstream orinoco (http://orinoco.sf.net) or use HostAP.

dan
Comment 6 Justin Georgeson 2004-11-24 16:56:12 EST
I downloaded the 0.15rc2 orinoco driver, and it installed without
incident. After reseating the card the NM applet now shows a list of
all broadcasted SSIDs in range, along with the signal strength bar and
a lock icon for WEP enabled networks. So that's nice. But when I
select one of them the laptop does a hard crash and I have to power
cycle. This happens with root and user accounts. My current process is
to log into a text consol (vt1) as root, bring down the wifi
interface, start the NetworkManager service, log into X, and launch
NetworkManagerInfo. I haven't had opportunity to try this with any
non-WEP networks, so it could just be that. Question, in the event
that I ever do get asked for a WEP key, does it have to be the long
hex key, or can I put in a passphrase that will be automagically used
to generate the hex key (like Mac OS X, the linux-wlan-ng driver, and
the Windows linksys tool for Win 2k and below)?
Comment 7 Dan Williams 2004-11-24 18:20:49 EST
NetworkManager supports 128-bit passphrases, so when a dialog pops up
and asks you for it, make sure that "128-bit Passphrase (WEP)" is
selected in the dropdown and you can then enter the passphrase. 
Assuming you get the dialog ever :)

So it seems that orinoco cards have problems, I'll have to pull mine
out of the closet and test it.

Dan
Comment 8 Justin Georgeson 2004-12-07 12:07:16 EST
Making any headway on this? Is there any testing I can do to help?
Comment 9 Jon Savage 2004-12-07 23:10:48 EST
>Making any headway on this?
sort of, been trying to discern patterns w/ breakage, hopfully will
add info to this bug later this week which may (or may not) be useful;
short version: sometimes 'just works' 
         sometimes its hosed :)

Comment 10 Dan Williams 2004-12-07 23:25:51 EST
Been bogged down with OOo stuff, I haven't had time yet to test with
my orinoco card...
Comment 11 Dan Williams 2005-01-29 17:06:24 EST
One thing you could do to help is to try to grab the kernel panic when
it happens...  Right after you pick the network in the menu, hit
CTL+ALT+F1 to switch to the console, and see if anything comes up
there...  CTL+ALT+F7 will get you back to your desktop.

If you get the kernel panic, copy down the text and post it here...

Thanks,
Dan
Comment 12 Justin Georgeson 2005-01-31 15:39:58 EST
Having kept up with kernel upgrades, currently using 2.6.10-1.741, the
orinoco 0.15rc2 release doesn't compile. It looks like something
they're aware of, but haven't been able to fix. I might try a CVS
version of the driver. 
Comment 13 Justin Georgeson 2005-01-31 20:18:19 EST
Well, I grabbed the CVS version of the drivers, and it seems to be
working now! I got the applet listing WLANs in range, selected the one
I wanted, got the security dialog, entered my passphrase, and I'm
connected with an IP. This rocks! Question, the next time I boot, will
I have to enter the passphrase again? If so, how do I save it as a
preferred network?
Comment 14 Dan Williams 2005-02-10 00:22:10 EST
Nope, when you've selected a network at least once from the menu, it gets stored
along with the passphrase, and will be used next time.  If you've picked
multiple networks, then NM will prefer the one you last clicked on.

Note You need to log in before you can comment on or make changes to this bug.