Bug 139264 - Installer unable to locate loaded network driver
Installer unable to locate loaded network driver
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-14 12:42 EST by Bob Allison
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-15 10:24:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Allison 2004-11-14 12:42:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6) Gecko/20040113

Description of problem:
Trying to install FC3 on a machine without a CDROM drive.  I want to
do an NFS install from a directory tree made from unpacking all of the
ISO images.  The system has an ISA D-Link ethernet card.

I use etherboot to create a PXE boot disk, and boot the installer
using pxelinux.  Kernel and initrd come from images/pxeboot on first
CD.  System boots fine and anaconda starts.  When I get to the prompt
to select the installation type, I select NFS (I have also tried HTTP
with the same results).  I get the dialog asking about selecting a
driver.  I select the proper driver (ne) and enter the proper I/O port
address.  I get the prompt to select a driver again.

VC3 contains:
* modules to insert 8390 ne
* loaded 8390 from /modules/modules.cgz
* loaded ne from /modules/modules.cgz
* inserted /tmp/8390.ko
* inserted /tmp/ne.ko

VC4 contains:
<6>ne.c:v1.10 9/23/94 ...
<6>Last modified Nov 1, 2000 ...
<6>NE*000 ethercard probe at 0x300: 00 80 c8 d9 38 a2
<4>eth%d: NE2000 found at 0x300, using IRQ 5.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot using PXE
2. Start install
3. Select NFS or HTTP install method
4. Select driver
    

Actual Results:  Infinite loop asking for network driver (the ne
driver is not in the list after the first time)

Expected Results:  Request for network parameters or NFS server

Additional info:
Comment 1 Jeremy Katz 2004-11-15 10:24:26 EST
Installation from ISA network cards isn't supported. 
Comment 2 Bob Allison 2004-11-15 18:09:58 EST
Since I see nothing indicating that certain types of cards are
supported and certain types are not, would you care to enlighten me on
what types of cards are now supported?  Since it looks like floppies
are no longer valid boot media and my ethernet cards are no longer
valid installation sources, I'm left without no way to install Fedora.

Note You need to log in before you can comment on or make changes to this bug.