Bug 1392654 - Logging out from first user after switching to second user and then back to first user crashes SDDM
Summary: Logging out from first user after switching to second user and then back to f...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sddm
Version: 25
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Martin Bříza
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F25FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2016-11-08 01:12 UTC by Adam Williamson
Modified: 2016-11-10 16:38 UTC (History)
7 users (show)

Fixed In Version: sddm-0.14.0-6.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-10 16:38:56 UTC


Attachments (Terms of Use)
black screen instead of login screen - journal (330.99 KB, text/plain)
2016-11-08 01:14 UTC, Adam Williamson
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1382001 None None None Never

Internal Links: 1382001

Description Adam Williamson 2016-11-08 01:12:50 UTC
This report splits out the issue described in https://bugzilla.redhat.com/show_bug.cgi?id=1382001#c5 to its own report, as it is distinct from #c4 in that report. kparal's reproduction steps, starting from a current Fedora 25 KDE installation:

Only black screen instead of login screen is shown, if user1 logs out. Reproducer:

1. create user1 and user2
2. boot the system
3. log in with user1
4. switch to user2
5. switch to user1
6. log out user1
7. see only black screen, no login screen. However, you can manually switch to TTY2 to see that user2 session is still running. So this is just the login screen being hung.

I have reproduced this with both qxl and modesetting drivers after an install of Fedora-KDE-Live-x86_64-25-20161107.n.0.iso . https://github.com/sddm/sddm/pull/735 , which is in scratch build http://koji.fedoraproject.org/koji/taskinfo?taskID=16279725 , appears to fix this in testing.

I am applying the 'accepted blocker' decision from #1382001 to this; for now we must consider it to apply to both bugs.

Comment 1 Adam Williamson 2016-11-08 01:14:22 UTC
Created attachment 1218330 [details]
black screen instead of login screen - journal

Clone of same attachment from original bug.

Comment 2 Adam Williamson 2016-11-08 20:34:25 UTC
Dennis claimed not to be able to reproduce this on bare metal, but I could, no problem.

I'm doing a 0.14.0-6.fc25 build with the fix for this, plus all rdieter's theme fixes between -1 and -5. Technically we should really only build a 0.14.0-1.1.fc25 with this patch on top of -1, but I really can't deal with the git work and frankly we should pull rex's theme fixes anyway, because they make it look a lot better. If there turns out to be a bad bug we can revert the theme stuff in a -7.

Comment 3 Fedora Update System 2016-11-08 20:56:32 UTC
sddm-0.14.0-6.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-3980d451a4

Comment 4 Adam Williamson 2016-11-09 00:06:32 UTC
I verified the fix for this myself, rex has also tested the build.

Comment 5 Fedora Update System 2016-11-09 02:27:55 UTC
sddm-0.14.0-6.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3980d451a4

Comment 6 Adam Williamson 2016-11-09 09:06:47 UTC
back to verified. damnit, bodhi, stop this.

Comment 7 Fedora Update System 2016-11-10 16:38:56 UTC
sddm-0.14.0-6.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.