Bug 139266 - No match for EPSON Stylus Photo 790
No match for EPSON Stylus Photo 790
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: foomatic (Show other bugs)
3
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-14 13:13 EST by Samuli Kärkkäinen
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-16 04:05:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/usr/share/foomatic/db/source/printer/Epson-Stylus_Photo_790.xml (989 bytes, text/plain)
2004-11-15 11:42 EST, Tim Waugh
no flags Details

  None (edit)
Description Samuli Kärkkäinen 2004-11-14 13:13:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
For the first time with FC3, I plugged in my printer by USB. After
about half a minute the Specify Printer Driver window popped up
(confusingly long delay). I selected the driver, and pressed OK.
top(1) showed some foomatic process running for a while, after which
nothing happened. This may be how it is intended to work, but a user
would assume _something_ visible to happen after clicking OK in the
Specify Printer Driver window. Probably have it show the
system-config-printer app. If not, the Specify Printer Dialog should
tell so, and tell why the it asked about the driver in the first place.

So I ran system-config-printer, where there was a presumably new entry
stylus-photo-790-1. I selected Edit from context menu of that entry,
and got on stdout:

No match for USB device:
  mfr "EPSON"
  model "Stylus Photo 790"
  desc "EPSON Stylus Photo 790"
  cmdset "ESCPL2,BDC,D4"
Please report this message in Bugzilla:
  https://bugzilla.redhat.com/bugzilla
Choose 'foomatic' as the component.

Otherwise, printing works fine however.

Except CUPS test page entry should mention it's Letter format.
Comment 1 Tim Waugh 2004-11-15 10:26:11 EST
Thanks for the report.

Fixed upstream in CVS.  Fixed in Fedora development CVS.

The CUPS test page is not Letter format per se: it is dynamic and fits to the
paper size you have for that queue.  If the "Specify Printer Driver" is creating
queues with the wrong paper size for the locale I think that should be reported
as a separate bug.
Comment 2 Tim Waugh 2004-11-15 11:42:06 EST
Created attachment 106717 [details]
/usr/share/foomatic/db/source/printer/Epson-Stylus_Photo_790.xml

Please save this attachment as:

/usr/share/foomatic/db/source/printer/Epson-Stylus_Photo_790.xml

and see if the printer model is now automatically selected when you run
system-config-printer.
Comment 3 Samuli Kärkkäinen 2004-11-15 17:53:01 EST
I removed the existing queues from system-config-printer, reconnected
the printer, and correct queues were created. So I guess it works.

The CUPS test page issue seems to be a more generic one: the prints
are not in middle of the paper but some 4 mm too far toward bottom
left corner. That's quite noticeable when doing marginless prints.
Comment 4 Tim Waugh 2004-11-16 04:05:47 EST
Glad that it works.

The CUPS test page border shows the actual printing limits according
to the queue settings, IIRC.  Anyway, that's a separate issue to this
one; closing.

Note You need to log in before you can comment on or make changes to this bug.