Bug 139268 - kernel hang associated with pcmcia wireless card detection
Summary: kernel hang associated with pcmcia wireless card detection
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 3
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-14 18:26 UTC by Will McCammon
Modified: 2015-01-04 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-15 23:15:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg.txt (12.88 KB, text/plain)
2004-11-14 18:27 UTC, Will McCammon
no flags Details
lsmod.txt (1.67 KB, text/plain)
2004-11-14 18:28 UTC, Will McCammon
no flags Details
lspci.txt (1.02 KB, text/plain)
2004-11-14 18:28 UTC, Will McCammon
no flags Details
chkconfig.txt (3.30 KB, text/plain)
2004-11-14 18:29 UTC, Will McCammon
no flags Details

Description Will McCammon 2004-11-14 18:26:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
laptop hangs on bootup when pcmcia wireless card installed.  last
message after starting pcmcia services refers to "mounting other
filesystems".  kernel becomes unresponsive to keyboard and mouse input.  

hang also reproduced immediately upon inserting pcmcia wireless card
after a successful system startup (without the pcmcia card initially
installed). 

pertinent hardware:
- sharp actius av18 laptop
- yenta pcmcia card bus
- orinoco gold classic wireless pcmcia card

Version-Release number of selected component (if applicable):
2.6.9-1.667

How reproducible:
Always

Steps to Reproduce:
scenario 1:
1. insert pcmcia wireless card
2. power up laptop
3. kernel hang after "mounting other filesystems"
    
scenario 2:
1. power up laptop without pcmcia wireless card installed
2. insert pcmcia wireless card after displaying login screen
3. kernel hang without kernel debugging messages to console

Actual Results:  
- keyboard and mouse become unresponsive.
- cpu temperature rises (area on laptop warm to touch)
- cpu fan increases rpms

Expected Results:  pcmcia wireless card should automagically power on
and configure using dhcp.  wireless configuration used successfully on
kernel-2.6.8 series.  kernel hang reproducible on vanilla kernel-2.6.9
series.

Additional info:

Comment 1 Will McCammon 2004-11-14 18:27:23 UTC
Created attachment 106677 [details]
dmesg.txt

Comment 2 Will McCammon 2004-11-14 18:28:09 UTC
Created attachment 106678 [details]
lsmod.txt

Comment 3 Will McCammon 2004-11-14 18:28:41 UTC
Created attachment 106679 [details]
lspci.txt

Comment 4 Will McCammon 2004-11-14 18:29:12 UTC
Created attachment 106680 [details]
chkconfig.txt

Comment 5 Will McCammon 2004-11-14 18:34:47 UTC
pertinent /var/log/messages:

-- snip --

Nov 14 12:45:39 localhost pcmcia: cardmgr[2603]: open_sock(socket 1)
failed: Bad file descriptor
Nov 14 12:45:39 localhost cardmgr[2603]: open_sock(socket 1) failed:
Bad file descriptor
Nov 14 12:45:39 localhost cardmgr[2603]: watching 1 socket
Nov 14 12:45:39 localhost kernel: cs: IO port probe 0x0c00-0x0cff: clean.
Nov 14 12:45:39 localhost pcmcia: cardmgr[2603]: watching 1 socket
Nov 14 12:45:39 localhost kernel: cs: IO port probe 0x0100-0x04ff:
excluding 0x4d0-0x4d7
Nov 14 12:45:39 localhost kernel: cs: IO port probe 0x0a00-0x0aff: clean.
Nov 14 12:45:39 localhost kernel: cs: memory probe
0xa0000000-0xa0ffffff: clean.
Nov 14 12:45:39 localhost cardmgr[2604]: socket 0: Lucent Technologies
WaveLAN/IEEE Adapter
Nov 14 12:45:39 localhost pcmcia: done.
Nov 14 12:45:39 localhost rc: Starting pcmcia:  succeeded

-- snip --

forced power off by holding power button down

Comment 6 Dave Jones 2005-07-15 18:28:46 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 7 Will McCammon 2005-07-15 22:18:57 UTC
This problem is resolved for the laptop used in the original post.  However, I'm
experiencing a nearly identical problem with the 2.6.11-1.1369_FC4 kernel on a
sony vaio laptop model s460.  I will post dmesg, lsmod, lspci, etc. from that
machine when I get a chance.

Comment 8 Dave Jones 2005-07-15 23:15:28 UTC
please file a seperate bug for the other case, even if it does look similar.
(Also note that theres a 1398 kernel for FC4 out today)

Thanks for testing.



Note You need to log in before you can comment on or make changes to this bug.