Bug 1392693 - [virtio-win][vioser][whql] job "PCI Hardware Compliance Test For a Single Device(PCIHCT)" fail w/ "-M q35"
Summary: [virtio-win][vioser][whql] job "PCI Hardware Compliance Test For a Single Dev...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Ladi Prosek
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1416681
Blocks: 1401400
TreeView+ depends on / blocked
 
Reported: 2016-11-08 02:44 UTC by Yu Wang
Modified: 2017-08-01 12:53 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 12:53:08 UTC
Target Upstream Version:


Attachments (Terms of Use)
failed logs (4.13 MB, application/zip)
2016-11-08 02:44 UTC, Yu Wang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2341 0 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2017-08-01 16:52:38 UTC

Description Yu Wang 2016-11-08 02:44:35 UTC
Created attachment 1218361 [details]
failed logs

Description of problem:
job "PCI Hardware Compliance Test For a Single Device(PCIHCT)" fail w/ "-M q35"

influence OS:
win2008,win2008R2,win7, win8 and win8.1


Version-Release number of selected component (if applicable):
virtio-win-prewhql-128
qemu-kvm-rhev-2.6.0-27.el7.x86_64
kernel-3.10.0-518.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. boot w/ "-M q35" and pcie device

/usr/libexec/qemu-kvm -name 128SRLWIN832JTU -enable-kvm -m 3G -smp 4 -uuid 9c0b7b6e-9beb-44ea-b1a2-72e541349142 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/128SRLWIN832JTU,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb -drive file=128SRLWIN832JTU,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_8_enterprise_x86_dvd_917587.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=128SRLWIN832JTU.vfd,if=floppy,id=drive-fdc0-0-0,format=raw,cache=none -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device e1000,netdev=hostnet0,id=net0,mac=00:52:4a:6e:12:1a -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:0 -vga cirrus -M q35 -device ioh3420,bus=pcie.0,id=root1.0,slot=1 -device virtio-serial-pci,id=serial0,bus=root1.0 -chardev socket,id=serialchardev0,path=/tmp/128SRLWIN832JTU_port0,server,nowait -device virtserialport,id=port0,chardev=serialchardev0,bus=serial0.0

2. run job "PCI Hardware Compliance Test For a Single Device(PCIHCT)" 

Actual results:
Failed 

Expected results:
Pass

Additional info:
It can pass with "-M pc"

Comment 1 Yu Wang 2016-11-08 03:35:16 UTC
Hit the same issue with build 126, so it is not a regression

Thanks
Yu Wang

Comment 2 xiagao 2016-11-08 06:04:51 UTC
Hit the same issue on the following guests:
Win8.1-32
Win8.1-64
Win2012-64
Win2012-R2

Comment 4 Yu Wang 2016-11-10 05:32:13 UTC
Hit the same issue w/ balloon driver

Thanks
Yu Wang

Comment 7 Ladi Prosek 2016-11-25 10:37:58 UTC
It looks like this will require QEMU changes. I'll take a look.

Comment 8 Yvugenfi@redhat.com 2016-11-27 07:27:12 UTC
(In reply to Ladi Prosek from comment #7)
> It looks like this will require QEMU changes. I'll take a look.

I think Marchel already started to fix it. Better ask him: Marcel Apfelbaum <marcel@redhat.com>

Comment 9 Ladi Prosek 2016-11-28 11:51:06 UTC
(In reply to Yan Vugenfirer from comment #8)
> (In reply to Ladi Prosek from comment #7)
> > It looks like this will require QEMU changes. I'll take a look.
> 
> I think Marchel already started to fix it. Better ask him: Marcel Apfelbaum
> <marcel@redhat.com>

Thanks, QEMU's PCIe devices (and virtio PCIe in particular) really are out of spec in terms of error reporting, power management, and more.

Marcel, please let me know if this is already worked on and if I can help in any way. Thanks!

Comment 10 Marcel Apfelbaum 2016-11-28 13:24:49 UTC
(In reply to Ladi Prosek from comment #9)
> (In reply to Yan Vugenfirer from comment #8)
> > (In reply to Ladi Prosek from comment #7)
> > > It looks like this will require QEMU changes. I'll take a look.
> > 
> > I think Marchel already started to fix it. Better ask him: Marcel Apfelbaum
> > <marcel@redhat.com>
> 
> Thanks, QEMU's PCIe devices (and virtio PCIe in particular) really are out
> of spec in terms of error reporting, power management, and more.
> 

Hi Ladi,

> Marcel, please let me know if this is already worked on and if I can help in
> any way. Thanks!

I have received from Gal a way to reproduce the tests, I intend to
run them this week. I'll let you know if I need help.

Thanks,
Marcel

Comment 11 Marcel Apfelbaum 2017-01-05 11:30:44 UTC
Solution posted upstream:
https://www.mail-archive.com/qemu-devel@nongnu.org/msg420299.html

Thanks,
Marcel

Comment 12 Ladi Prosek 2017-01-26 09:06:36 UTC
I have opened bug 1416681 to track the QEMU work. If there are no surprises, this virtio-win BZ will become TestOnly. Thanks!

Comment 13 Ladi Prosek 2017-04-24 07:16:45 UTC
Fix is available in qemu-kvm-rhev-2.9.0-1.el7

Comment 14 Ladi Prosek 2017-05-02 12:14:08 UTC
I guess this BZ should be ON_QA now.

Comment 15 Peixiu Hou 2017-05-06 00:59:26 UTC
Tried this issue with qemu-kvm-rhev-2.9.0-1.el7 under q35, it also failed(3/3).

Used version:
kernel-3.10.0-657.el7.x86_64
qemu-kvm-rhev-2.9.0-1.el7.x86_64
seabios-1.10.2-2.el7.x86_64
virtio-win-prewhql-136

Best regards~
Peixiu

Comment 16 Ladi Prosek 2017-05-09 07:00:56 UTC
(In reply to Peixiu Hou from comment #15)
> Tried this issue with qemu-kvm-rhev-2.9.0-1.el7 under q35, it also
> failed(3/3).

Peixiu Hou, can you please attach the logs? Thanks!

Comment 17 Peixiu Hou 2017-05-09 11:30:54 UTC
(In reply to Ladi Prosek from comment #16)
> (In reply to Peixiu Hou from comment #15)
> > Tried this issue with qemu-kvm-rhev-2.9.0-1.el7 under q35, it also
> > failed(3/3).
> 
> Peixiu Hou, can you please attach the logs? Thanks!

Hi Ladi,

I rerun it with win8-32 and qemu-kvm-rhev-2.9.0-1.el7 under q35, it can be passed.

And comment#15 result is for win2008-32, although it failed, but it can be filter passed.

Best Regards~
Peixiu

Comment 18 lijin 2017-05-11 05:44:40 UTC
Hi Amnon,

Could you help to ack?

Thanks

Comment 19 Yvugenfi@redhat.com 2017-05-11 09:04:13 UTC
(In reply to lijin from comment #18)
> Hi Amnon,
> 
> Could you help to ack?
> 
> Thanks

Acked.

Comment 22 errata-xmlrpc 2017-08-01 12:53:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2341


Note You need to log in before you can comment on or make changes to this bug.