Bug 1392773 - Ceilometer-compute-agent: Unknown discovery extension: local_instances
Summary: Ceilometer-compute-agent: Unknown discovery extension: local_instances
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 10.0 (Newton)
Assignee: Pradeep Kilambi
QA Contact: Yurii Prokulevych
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-08 08:41 UTC by Yurii Prokulevych
Modified: 2016-12-14 16:30 UTC (History)
10 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.0.0-1.7.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, after upgrading from Red Hat OpenStack Platform 9 (Mitaka) to Red Hat OpenStack Platform 10 (Newton), the 'ceilometer-compute-agent' failed to collect data. With this update, restarting the 'ceilometer-compute-agent' post upgrade fixes the issue and allows the 'ceilometer-compute-agent' to restart correctly and gather the relevant data.
Clone Of:
Environment:
Last Closed: 2016-12-14 16:30:30 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 395693 None None None 2016-11-09 18:52:21 UTC
Launchpad 1640177 None None None 2016-11-09 10:39:40 UTC

Description Yurii Prokulevych 2016-11-08 08:41:56 UTC
Description of problem:
-----------------------

After upgrading compute nodes during upgrade from RHOS-9 to RHOS-10 ceilometer-compute-agent fails to collect data with next message in ceilometer/compute.log:

2016-11-07 17:07:09.040 17826 WARNING ceilometer.agent.manager [-] Unknown discovery extension: local_instances
2016-11-07 17:07:09.041 17826 INFO ceilometer.agent.manager [-] Skip pollster network.incoming.bytes.rate, no resources found this cycle
2016-11-07 17:07:09.042 17826 WARNING ceilometer.agent.manager [-] Unknown discovery extension: local_instances
2016-11-07 17:07:09.042 17826 INFO ceilometer.agent.manager [-] Skip pollster network.incoming.packets, no resources found this cycle
2016-11-07 17:07:09.042 17826 WARNING ceilometer.agent.manager [-] Unknown discovery extension: local_instances



Version-Release number of selected component (if applicable):
-------------------------------------------------------------
openstack-ceilometer-notification-7.0.0-2.2.el7ost.noarch
openstack-ceilometer-compute-7.0.0-2.2.el7ost.noarch
python-ceilometerclient-2.6.1-2.el7ost.noarch
python-ceilometer-7.0.0-2.2.el7ost.noarch
openstack-ceilometer-collector-7.0.0-2.2.el7ost.noarch
openstack-ceilometer-common-7.0.0-2.2.el7ost.noarch
openstack-ceilometer-polling-7.0.0-2.2.el7ost.noarch
openstack-ceilometer-central-7.0.0-2.2.el7ost.noarch
python-ceilometermiddleware-0.5.0-1.el7ost.noarch
openstack-ceilometer-api-7.0.0-2.2.el7ost.noarch
puppet-ceilometer-9.4.0-2.el7ost.noarch

openstack-tripleo-heat-templates-compat-2.0.0-34.3.el7ost.noarch
openstack-tripleo-0.0.8-0.2.4de13b3git.el7ost.noarch
openstack-tripleo-image-elements-5.0.0-2.el7ost.noarch
openstack-tripleo-ui-1.0.4-2.el7ost.noarch
openstack-tripleo-puppet-elements-5.0.0-1.el7ost.noarch
openstack-tripleo-common-5.3.0-3.el7ost.noarch
openstack-tripleo-validations-5.1.0-1.el7ost.noarch
openstack-tripleo-heat-templates-5.0.0-1.2.el7ost.noarch
puppet-tripleo-5.3.0-4.el7ost.noarch

Steps to Reproduce:
-------------------
1. Run upgrade from RHOS-9 -> RHOS-10
2. After upgrading computes check ceilometer/compute.log


Additional info:
----------------
Restart of openstack-ceilometer-compute.service eliminates the issue.

Comment 1 Yurii Prokulevych 2016-11-08 13:44:20 UTC
So this happens after upgrading compute node with upgrade-non-controller.sh

Comment 7 Yurii Prokulevych 2016-11-18 14:05:15 UTC
Verified with openstack-tripleo-heat-templates-5.0.0-1.7.el7ost

Comment 9 errata-xmlrpc 2016-12-14 16:30:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.