Bug 139283 - /sbin/loader Freezes then causes kernel panic
/sbin/loader Freezes then causes kernel panic
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-14 16:43 EST by Daniel Brodie
Modified: 2015-01-04 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-02 21:22:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Brodie 2004-11-14 16:43:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Not much information to give (sorry.)
When trying to install FC3 on older hardware (old pentium 2's)
everything starts up ok, but once it prints out that it is starting
/sbin/loader, the computer freezes, and after a number of seconds
(5-10) I get a kernel panic.

this has been reproduced on 2 VERY different boxes hardware-wise, but
they were both pentium 2 old.

If there is any other information I could give, please tell me.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Try to install Fedora Core 3 normally, either in text only, nofb,
and/or noprobe mode.

Additional info:
Comment 1 Daniel Brodie 2004-11-21 15:50:14 EST
I would like to add that using the kernel option
ide=nodma
seemed to have fixed this,
Comment 2 Need Real Name 2004-12-03 18:58:36 EST
The same thing is happening to me, but on brand new x86_64 hardware
(dual Opteron CPUs on an Iwill motherboard using a 3ware
RAID). /sbin/loader starts, after about 20 or 30 seconds
I see a 'loading aic7xxx driver' message, then after another 20
or 30 seconds I get a kernel panic that says something about
waiting on a traversal list.
Comment 3 Need Real Name 2004-12-03 19:07:51 EST
I also tried Daniel's 'ide=nodma' trick, but it did not work for me.
I still get a

Kernel panic - not syncing: Waiting List traversal

message while the aic7xxx driver is trying to load during the
initial part of the installation.
Comment 4 Daniel Brodie 2004-12-07 05:11:10 EST
Your problem is a different problem. Mine is because of a ide
configuration in FC. Yours is because of the aic7xxx driver problems.

Anyway, try setting the boot option to:
aic7xxx=no_reset
or
aic7xxx=no_probe
(try one and if that dosn't work  then try the second)
Comment 5 Need Real Name 2004-12-07 18:07:10 EST
Thanks for the suggestions, Daniel.

Unfortunately, neither 'aic7xxx=no_reset' nor 'aic7xxx=no_probe'
made any difference. I am still dead in the water here.
Too bad there isn't any 'aic7xxx=nokernelpanic'. :-)
Comment 6 Dave Jones 2005-07-15 16:48:34 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 7 Dave Jones 2005-10-02 21:22:27 EDT
This bug has been automatically closed as part of a mass update.
It had been in NEEDINFO state since July 2005.
If this bug still exists in current errata kernels, please reopen this bug.

There are a large number of inactive bugs in the database, and this is the only
way to purge them.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.