Bug 139284 - shutdown -h doesn't power off the computer
Summary: shutdown -h doesn't power off the computer
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-14 21:47 UTC by Patrick Pichon
Modified: 2015-01-04 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-19 18:53:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Patrick Pichon 2004-11-14 21:47:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.6)
Gecko/20040113

Description of problem:
I have a look to the existing bug and found several request around the
power off, but none of them where matching mine.

I have just move from Fedora Core 1 to Fedora Core 3, and since that
when I'm doing a shutdown -h now, the system stop at the Power Down
message without powering off the computer.

I'm running a HP Kayac XU ( which is a quiet old machine with 2 PII CPU).

Searching on the web I have also found several issues around the
pwoeroff and tried the following :

- add in grub.conf  apm=on acpi=off  --> No improvement
- add in grub.conf  apm=power-off    --> Panic
- add in grub.conf  apm=power_off    --> Panic


I have indeed an SMP Kernel.

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.667smp

How reproducible:
Always

Steps to Reproduce:
1. /sbin/shutdown -h now
2.
3.
    

Actual Results:  The system stop and display Power Down, but doesn't
power off the computer.

Expected Results:  The computer/machine must be power off

Additional info:

/etc/grub.conf
default=0
timeout=5
splashimage=(hd0,0)/boot/grub/splash.xpm.gz
hiddenmenu
title Fedora Core (2.6.9-1.667smp)
        root (hd0,0)
        kernel /boot/vmlinuz-2.6.9-1.667smp ro root=LABEL=/ quiet
apm=force acpi=off
        initrd /boot/initrd-2.6.9-1.667smp.img

Comment 1 Chris Thomas 2004-11-14 22:09:25 UTC
it might be because acpi is turned off. Try turning it on and also 
make sure you have the latest flash of your bios.

Comment 2 Patrick Pichon 2004-11-15 20:03:49 UTC
Hello,

I have used the following grub.conf today and such without any
positive results:

kernel /boot/vmlinuz-2.6.9-1.667smp ro root=LABEL=/ quiet acpi=on 
kernel /boot/vmlinuz-2.6.9-1.667smp ro root=LABEL=/ quiet acpi=force
kernel /boot/vmlinuz-2.6.9-1.667smp ro root=LABEL=/ quiet acpi=power-off

Also I would like to confirm that when using Fedora Core1 with SMP
kernel, the powering off was correctly functioning.

Comment 3 Patrick Pichon 2004-11-15 20:36:59 UTC
Here are some additional information I found from dmesg
(/var/log/messages) :

Kernel command line: ro root=LABEL=/ quiet acpi=on
ACPI: Subsystem revision 20040816
ACPI: Interpreter disabled.
...
Nov 15 21:36:21 obelix kernel: apm: BIOS version 1.2 Flags 0x03
(Driver version 1.16ac)
Nov 15 21:36:21 obelix kernel: apm: disabled - APM is not SMP safe.


Comment 4 Patrick Pichon 2004-11-15 21:22:24 UTC
Sorry for comming back with an other comments, but I did further
investigation and :

1) whatever I configure the boot in mono processor with acpi=on or
with apm=on, shutdown works perfectly.
title Fedora Core (2.6.9-1.667)
        root (hd0,0)
        kernel /boot/vmlinuz-2.6.9-1.667 ro root=LABEL=/ quiet
apm=force apm=on
        initrd /boot/initrd-2.6.9-1.667.img

2) When looking to the message in dmesg, I don't understand if my
system is APM or ACPI based. However when shuting down from Single
Processor Kernel it works fine.

3) I have seen some patches flying around where they mentioned that
APM is not SMP safe, however if you pass explicitly the parameter
power-off or smp-power-off the kernel will try. I did the test to pass
apm=power-off and in such I got a panic at boot time. I did the test
with apm=smp-power-off no Panic but no power off.

Comment 5 Dave Jones 2004-11-16 04:29:58 UTC

*** This bug has been marked as a duplicate of 132761 ***

Comment 6 Patrick Pichon 2004-11-17 17:50:05 UTC
Are you sure that is a dupliacte of 132761, since the machine poweroff
correctly when not using the SMP kernel, but if using SMP kernel
doesn't poweroff.

Comment 7 Patrick Pichon 2004-11-17 18:09:48 UTC
Are you sure that is a dupliacte of 132761, since the machine poweroff
correctly when not using the SMP kernel, but if using SMP kernel
doesn't poweroff.

I felt it was more an APM problem than an ACPI's one

Comment 8 Patrick Pichon 2004-11-19 18:33:13 UTC
Here after are some comments extracted from the dmesg after booting:

Nov 19 19:32:46 obelix kernel: apm: BIOS version 1.2 Flags 0x03
(Driver version 1.16ac)
Nov 19 19:32:46 obelix kernel: apm: entry f000:60f2 cseg16 f000 dseg
40 cseg len ffff, dseg len ffff cseg16 len ffff
Nov 19 19:32:46 obelix kernel: apm: disabled - APM is not SMP safe.


I have tried to put apm=realmode_power_off but doesn't work.


When looking into the sourcecode " ./arch/i386/kernel/apm.c" release
1.12 mentioned that apm=power-off should be mentioned to power off a
SMP box. However when doing that I'm getting a Panic a starting phase:

mkrootdev: label / not found
mount: error 2 mounting ext3
mount: error 2 mounting now
switchroot: mount failed 22
umount /etc/initrd/dev failed 2
Kernel panic

Comment 9 Patrick Pichon 2004-11-19 18:53:31 UTC
When reading the source code, I have got the solution. Here is the
source code :
        if ((num_online_cpus() > 1) && !power_off && !smp) {
                printk(KERN_NOTICE "apm: disabled - APM is not SMP
safe.\n");
                apm_info.disabled = 1;
                return -ENODEV;
        }


So we need to position smp AND power_off

So correct configuration is apm=smp,power_off



Note You need to log in before you can comment on or make changes to this bug.