Bug 139285 - Xclients fallbacks not working as expected
Xclients fallbacks not working as expected
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xinitrc (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
: Patch, Triaged
Depends On: 112478 142260
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2004-11-14 17:22 EST by Ville Skyttä
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-05 08:56:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Fix Xclients fallbacks (1.40 KB, patch)
2004-11-14 17:24 EST, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2004-11-14 17:22:35 EST
I've just installed a fresh FC3, chose KDE, no Gnome or XFCE during
install.  Before logging in the first time (to X), fetched all
updates.  Then, login... whoa, twm!  /etc/sysconfig/desktop has
DESKTOP="GNOME", and I don't have Gnome installed.

What this has to do with xinirc: while looking into this, I dug into
Xclients, the fallbacks of which do not work as I would expect, ie.
even given the above /etc/sysconfig/desktop setting, I would have
expected KDE to be launched as the system default.  Attached is a
patch that fixes it.  It also avoids a few "which" calls, and IMO
makes it a bit easier to follow.

What component should I file a bug about the incorrect
/etc/sysconfig/desktop setting against?
Comment 1 Ville Skyttä 2004-11-14 17:24:38 EST
Created attachment 106682 [details]
Fix Xclients fallbacks

(Against xinitrc-4.0.14-1.)
Comment 2 Ville Skyttä 2004-12-09 15:23:34 EST
ping
Comment 3 Mike A. Harris 2004-12-10 14:47:15 EST
I've reviewed the above patch, and it looks good to me, with the
added bonus of making the code cleaner and less crackrockish.

Thanks Ville, I'm applying it to the next xinitrc build.
Comment 4 Ville Skyttä 2004-12-10 15:00:06 EST
Thanks.  Would you happen to have an idea what component to report the
root cause (see first paragraph in this bug report) against? 
/etc/sysconfig/desktop is not owned by any package.
Comment 5 Mike A. Harris 2004-12-10 19:49:57 EST
The "distribution" component is best used when one isn't quite
sure of the correct component for a particular problem.  Bugs
filed against distribution are for both distribution generic issues
and requests, as well as for bugs that people aren't sure where to
file.  The component owner (notting) will reassign them to the
component most likely to fit the problem domain.

Hope this helps.
Comment 8 Mike A. Harris 2005-04-05 08:56:30 EDT
Fixes integrated into xinitrc-4.0.16-1 in rawhide.  Please test and
provide feedback.

Thanks again.
Comment 9 Ville Skyttä 2005-04-13 11:07:16 EDT
Fallback seems to work ok in FC4t2, xinitrc-4.0.18-1.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.