Bug 1392854 - ppc64: no .eh_frame_hdr table will be created
Summary: ppc64: no .eh_frame_hdr table will be created
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: binutils
Version: rawhide
Hardware: ppc64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nick Clifton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2016-11-08 11:19 UTC by gil cattaneo
Modified: 2016-11-10 12:20 UTC (History)
3 users (show)

Fixed In Version: sqlite-jdbc-3.15.1-2.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-10 12:20:39 UTC


Attachments (Terms of Use)

Description gil cattaneo 2016-11-08 11:19:53 UTC
Description of problem:
from http://koji.fedoraproject.org/koji/taskinfo?taskID=16325379
[exec] /usr/bin/ld: error in target/sqlite-3.15.1-Linux-ppc64/NativeDB.o(.eh_frame); no .eh_frame_hdr table will be created.

Version-Release number of selected component (if applicable):
2.27-10.fc26.ppc64

How reproducible:
Always

Comment 1 Dan Horák 2016-11-08 11:29:12 UTC
might be a duplicate of bug 1392848

Comment 2 Nick Clifton 2016-11-10 10:37:03 UTC
This appears to be a problem with the makefile being used to build the libsqlitejdbc.so library.  Running a parallel make results in the error reported, but running a sequential make does not.  Hence I am currently of the opinion that this is not actually a bug in the linker, but rather a bug in the sqlite-jdbc build system.

As a suggested fix try adding "-j 1" to the make command line, like this:

diff --git a/sqlite-jdbc.spec b/sqlite-jdbc.spec
index 9e045f4..414e7ce 100644
--- a/sqlite-jdbc.spec
+++ b/sqlite-jdbc.spec
@@ -124,6 +124,7 @@ sed -i '/SQLiteDataSourceTest/d' src/test/java/org/sqlite/AllTests.java
        </javac>
        <exec executable="make">
         <arg line="%{?_smp_mflags}
+       -j 1
         JAVA_HOME=%{_jvmdir}/java
         JAVA=%{_jvmdir}/java/bin/java
         JAVAC=%{_jvmdir}/java/bin/javac

Comment 3 gil cattaneo 2016-11-10 12:20:39 UTC
Thanks for your help! Solved using native task, as you said, "to avoid to run multiple, conflicting, operations at the same time"
Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=16383709


Note You need to log in before you can comment on or make changes to this bug.