Bug 1392887 - pygame image tests (colorkey tests) fails on ppc64le
Summary: pygame image tests (colorkey tests) fails on ppc64le
Status: CLOSED DUPLICATE of bug 1392465
Alias: None
Product: Fedora
Classification: Fedora
Component: pygame
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Kaluža
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2016-11-08 12:21 UTC by Hans de Goede
Modified: 2016-11-08 12:29 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-08 12:29:29 UTC


Attachments (Terms of Use)

Description Hans de Goede 2016-11-08 12:21:06 UTC
When trying to build pygame on ppc64le the %check section fails:

FAIL: make sure the color key is not changed when saving.
----------------------------------------------------------------------
Traceback (most recent call last):
  File "test/image_test.py", line 284, in test_save_colorkey
    self.assertEqual(p1, s2.get_at((0,0)))
AssertionError: (23, 23, 23, 255) != (23, 23, 255, 23)
----------------------------------------------------------------------

Although only the last 2 bytes of the 32 bit are swapped, which
is weird. To make sure this really is an endian-ness issue
I've also started a scratchbuild for just ppc64 and that
did complete successfully.

Looking at pygame itself, there seems to be no ppc specific
code in there, all endian specific bits are done based on
SDL_BYTEORDER which does get set correctly on ppc64le.

Looking at SDL there also is not a whole lot of ppc specific
code (I've grepped for both ppc and powerpc) and certainly
nothing which would explain this.

Comment 1 Dan Horák 2016-11-08 12:29:29 UTC

*** This bug has been marked as a duplicate of bug 1392465 ***


Note You need to log in before you can comment on or make changes to this bug.