Bug 13929 - running rpm core dumps and logs out from console
Summary: running rpm core dumps and logs out from console
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-14 05:07 UTC by Christian Rose
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-21 18:58:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of rpm --help (11.64 KB, text/plain)
2000-07-14 18:02 UTC, Christian Rose
no flags Details
the output of dmesg (3.59 KB, text/plain)
2000-07-14 18:44 UTC, Christian Rose
no flags Details
strace of rpm --help with rpm-4.0-0.56 (deleted)
2000-07-21 17:59 UTC, Christian Rose
no flags Details

Description Christian Rose 2000-07-14 05:07:27 UTC
I performed a rather minimalist custom GUI install of beta3. This machine
has a rather small disk.

When I try running rpm in console mode, if run as root rpm just makes the
current user log out. 

If I use su to become root and then run rpm, I instantly become my normal
user again. If I log in from the console as root and then run rpm, I end up
at the login prompt again. This is true for all kinds of ways to invoke
rpm, including upgrading with rpm -Uvh and even rpm --help.
When I check later, rpm has spit out a core file in the directory.

When I run rpm as a normal user, rpm just takes forever to run. Doing a rpm
-qa results in minutes of waiting with no activity at all (not even a
harddrive spinning) but 80 - 99 % CPU usage, and then all of the sudden the
output comes.

Unfortunately, I haven't got gdb installed on the system, and the rpm
behavior makes it kind of hard to install it...

Comment 1 Christian Rose 2000-07-14 18:02:34 UTC
Created attachment 1127 [details]
strace of rpm --help

Comment 2 Christian Rose 2000-07-14 18:29:48 UTC
I might as well provide some additional info about the system:

CPU:	Pentium 233 MMX
Memory:	96 MB
Disks:	600 MB IDE	 (/ 436 MB, swap 64 MB)
	100 MB IDE
Cdrom:	24x
Video:	Matrox Mystique
NIC:	Intel Etherexpress 100+
Mouse:	Regular two-button PS/2

It might be some sort of clue that most programs on the system when invoked take
a very long time and use 99% CPU, like for example mv when moving a strace file
onto a floppy disk...


Comment 3 Christian Rose 2000-07-14 18:44:55 UTC
Created attachment 1129 [details]
the output of dmesg

Comment 4 Christian Rose 2000-07-14 19:11:22 UTC
export LANG=C (and thus LC_ALL=C) solved all problems. msw@redhat.com and
jbj@redhat.com gave that solution.

Comment 5 Glen Foster 2000-07-18 20:29:34 UTC
This defect is considered MUST-FIX for Winston Beta-5


Comment 6 Jeff Johnson 2000-07-19 16:06:20 UTC
Does  rpm-4.0-0.56 fix your problem? Otherwise, I do not know how to reproduce
this problem.

Comment 7 Christian Rose 2000-07-20 16:23:44 UTC
Where can I get that version? Could it be put somewhere on the beta ftp site?

Comment 8 Christian Rose 2000-07-21 17:32:55 UTC
Tested with rpm-4.0-0.56 on the same beta3 system (I upgraded the rpm and the
rpm-python packages, as it was those two packages that was installed).

Now, with LANG=sv, "rpm --help" just outputs

RPM version 4.0
Copyright (C) 1998 - Red Hat Software

and after those two lines nothing happens for 7 minutes (timed with stopwatch),
then suddenly the memory usage peaks until there is hardly free main memory left
in the machine and there is some slow output of --help lines, getting written
slooowly, and after about 8 minutes "rpm --help" finishes correctly, and all
memory is released properly.

At peak, about 94 MB of the machines 96 MB of main memory was used (watched top
during the run).

I don't think that I'll add that there still seems to be something wrong. Simple
tasks like like "rpm --version" work like a charm though.

I'll add a strace when that rpm run finishes.


Comment 9 Christian Rose 2000-07-21 17:41:13 UTC
I might add that I still use the original glibc from beta3.
I will test this issue in beta4 when my beta4 download finishes.

Comment 10 Christian Rose 2000-07-21 18:57:54 UTC
Upgrading to glibc-2.1.91-16 solved the problems. rpm now runs just fine.

I found another issue though... rpm doesn't display swedish characters in its
output, but replaces them with question marks... Should I file this in another
bug?

Comment 11 Jeff Johnson 2000-07-21 19:05:55 UTC
Thanks for the verification. Could you please file a different bug report for
the Swedish
characters problem, as this bug # has found it's way onto various MUST-FIX
lists?
Thanks ...


Note You need to log in before you can comment on or make changes to this bug.