Bug 139291 - Graphical setup phase does not offer to create a GRUB boot disk.
Summary: Graphical setup phase does not offer to create a GRUB boot disk.
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-14 23:34 UTC by Lance Kujala
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-02 03:09:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lance Kujala 2004-11-14 23:34:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
Graphical setup phase does not offer to create a GRUB boot disk.

On a multi-boot system, where NTLDR is the main boot loader, a GRUB
boot disk is needed in order to boot the Linux system (at least until
you get the linux boot sector copied over).

Yes, there are instructions etc for creating the boot disk; it only
took me 10 hours to figure it out. And I knew what the problem was. 
The recovery CD worked fine, btw; used that to create the GRUB boot disk.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. No option given to Create Grub Boot Disk, during setup.
2.
3.
    

Additional info:

Comment 1 Jeremy Katz 2004-11-15 15:30:54 UTC
With the size of the 2.6 kernel, creation of a boot disk isn't
possible due to capacity limits of floppy disks.  

Comment 2 Lance Kujala 2004-11-15 17:35:25 UTC
You are as bad as Microsoft. I have been harassing them over design 
flaws and all they say is "by design wont fix".

Anyway, you missed the point; I didn't ask for a LINUX boot disk, I 
asked for a GRUB boot disk. Which does fit on a floppy. For which RH 
has instructions on how to MANUALLY create.

(for those that need a GRUB boot disk, this works, use recovery cd to 
get shell)
# fdformat /dev/fd0
# mke2fs /dev/fd0
# mount -t ext2 /dev/fd0 /mnt/floppy
# grub-install --root-directory=/mnt/floppy '(fd0)'
# cp /boot/grub/grub.conf /mnt/floppy/boot/grub/grub.conf
# umount /mnt/floppy



Note You need to log in before you can comment on or make changes to this bug.