Bug 139295 - Can't print to a hp business inkjet 1100
Can't print to a hp business inkjet 1100
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-14 19:19 EST by Chris Croome
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-20 07:32:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
cups error log (59.03 KB, text/plain)
2004-11-15 12:19 EST, Chris Croome
no flags Details
printconf-tui --Xexport (2.04 KB, text/plain)
2004-11-15 12:30 EST, Chris Croome
no flags Details
relevent output of 'ps axf' (1021 bytes, text/plain)
2004-11-18 17:52 EST, Chris Croome
no flags Details
relevent output of 'ps axf' (1.78 KB, text/plain)
2004-11-18 17:57 EST, Chris Croome
no flags Details

  None (edit)
Description Chris Croome 2004-11-14 19:19:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040124

Description of problem:
I tried for a while getting this printer to work with a USB lead, but
I had the "Media tray empty!" error that has been reported a _lot_ in
the help forum (http://sourceforge.net/forum/forum.php?forum_id=53439)
on the sourceforge hp printer drivers project (and I couldn't find an
answer to this problem) and then it locked the whole machine up a few
times and so I am now trying using the parallel port connector...

When I launch system-config-printer in a terminal I get this error:

/usr/bin/ptal-devid: Unable to open device "device"!

Syntax: /usr/bin/ptal-devid [<devname>] [-previous] [[<modifiers>]
<queries>]...
Where <devname> may be one of:
Supported <modifiers> (for following <queries>):
        -previous    -- Gets previous string (must be first option)
        -short       -- Displays field values only
        -long        -- Displays leading field name through semicolon
Supported <queries>:
        -field <key> -- Queries specific field
        -mfg         -- Queries manufacturer fields
        -mdl         -- Queries model fields
        -cmd         -- Queries command set fields
        -sern        -- Queries serial number fields

If I continue and add it as a new printer and try to print a test page
nothing is printed. 

I brought this printer as it was listed as being 100% supported
(http://www.linuxprinting.org/show_printer.cgi?recnum=HP-Business_Inkjet_1100)
and I didn't want have to spend ages messing around to get the thing
working... so much for that plan... :-/

Anyone have any ideas?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run system-config-printer
2. install printer
3. try to print - nothing happens
    

Additional info:
Comment 1 Tim Waugh 2004-11-15 11:12:29 EST
The "media tray empty" message is a red herring: it is incorrect, but
harmless.  It is not indicating something that would cause a problem
to print.

If your machine locks up at all during printing, this indicates a
kernel bug.

You can ignore the ptal-devid messages, since I don't believe the
Business Inkjet series is for multifunction devices (is it?).

Reassigning to kernel for lock-up problem.  What does 'uname -rm' say?
Comment 2 Chris Croome 2004-11-15 11:23:12 EST
The HP Business Inkjet 1100 is just a printer and not a scanner so I
guess this means it is not a "multifunction device"?

uname -rm
2.6.8-1.521 i686

Comment 3 Chris Croome 2004-11-15 11:33:41 EST
I guess it would be nice for this printer not to lock up Fedora Core 2
when connected via a USB lead, however I can't remember exactly how
this happened, though it has happened about 3 times. Existing ssh
sessions have also been locked up so that a remote reboot was not
possible. If you do think this is important I guess I could try to
duplicate this problem.

But my concern is more to get some prints from the printer -- I
haven't managed to print a single thing from this printer since I
brought it and I don't really care if it is attached with a parallel
lead and not a USB one as long as I can actually get it to actually
print things...
Comment 4 Tim Waugh 2004-11-15 11:39:59 EST
I think I may have misinterpreted.  When you said:

"and so I am now trying using the parallel port connector..."

did you mean that the problems you've reported (ptal-devid messages,
no output) have been from trying the parallel port connection, or that
you would try the parallel port connection next to see what difference
it makes?

If you've tried the parallel port connection and still can't get it to
print I'd like to focus on that.
Comment 5 Chris Croome 2004-11-15 11:44:19 EST
Sorry if I have been unclear. The lockups were with the USB lead. I
have now given up with USB and I'm trying with a parallel lead, the
error message above (ptal-devid) is from using the parallel connector,
with a USB connector I get the "media tray empty!" message.
Comment 6 Tim Waugh 2004-11-15 11:52:13 EST
Okay, reassigning back to concentrate on this first.
Comment 7 Tim Waugh 2004-11-15 11:54:23 EST
Please attach the output of 'printconf-tui --Xexport'.

I'd like you to edit /etc/cups/cupsd.conf and change the LogLevel line
to read:

LogLevel debug2

Then do this:

service cups stop
>/var/log/cups/error_log
service cups start

Then wait a few seconds and submit a print job, and attach
/var/log/cups/error_log if you don't get inked paper.
Comment 8 Chris Croome 2004-11-15 12:19:03 EST
Created attachment 106724 [details]
cups error log

I had to upload this using Lynx because the new file browser in FC3 dosn't list
plain text file for some reason....
Comment 9 Chris Croome 2004-11-15 12:22:20 EST
The error log attached above was generated while from adding the
printer using system-config-printer and then asking it to print a test
page.

I'm not 100% sure that nothing was printed because I'm not at this
computer at the moment but I will be able to check it withing a hour,
however I have does exactly the same thing several times already... so
I don't expect it to have printed anything.
Comment 10 Tim Waugh 2004-11-15 12:26:31 EST
Thanks.  I also need the output of 'printconf-tui --Xexport'.
Comment 11 Chris Croome 2004-11-15 12:30:40 EST
Created attachment 106726 [details]
printconf-tui --Xexport
Comment 12 Tim Waugh 2004-11-16 08:09:48 EST
Does 'dmesg' show any lp or parport messages?
Comment 13 Chris Croome 2004-11-16 08:29:18 EST
Yes, it has this:

parport0: PC-style at 0x378 [PCSPP,TRISTATE]
parport0: Printer, hp hp business inkjet 1100
lp0: using parport0 (polling).
lp0: console ready

Comment 14 Tim Waugh 2004-11-18 12:49:38 EST
What does 'ps axf' show?
Comment 15 Chris Croome 2004-11-18 17:52:53 EST
Created attachment 107004 [details]
relevent output of 'ps axf'
Comment 16 Chris Croome 2004-11-18 17:57:02 EST
Created attachment 107005 [details]
relevent output of 'ps axf'

Done with a wider terminal so that stuff is not chopped off...
Comment 17 Tim Waugh 2004-11-22 12:00:04 EST
Looks very much like the printer isn't accepting data.

Has the same hardware worked before with a different version of Linux, or with
anything?  It might well be a faulty cable or something like that.

Others with the same printer model have had success with Fedora Core 3.
Comment 18 Chris Croome 2004-11-22 15:18:29 EST
The printer is brand new, I have never managed to print a thing from
it, it dos have lights on it so it's not totally dead, I could try
printing from Windows in VMWare I suppose, also I could test the cable
on another machine. But first I'll try printing from a Fedora 1
machine and then I might also upgrade the machine to FC3 and try
that... I'll let you know how I get on...
Comment 19 Chris Croome 2004-11-22 15:47:23 EST
No luck with FC1, the printer is detected OK but the test page doesn't
come out. I don't know if any FC1 logs or settings would help at all,
I assume not since it's no longer supported.

With XP in VMWare connecting via the parallel port doesn't work -- XP
doesn't detect a printer and with the USB cable VMWare reports that
the device is in use by the host operating system and I don't know
what to do to fix this, so no joy in getting anything to print using
VMWare.

Now I'll upgrade to FC3 and see if that helps...
Comment 20 Chris Croome 2004-11-22 17:57:47 EST
OK, I have upgraded to FC3, I ran system-config-printer from a
terminal and everything was as before -- it all worked, apart from
that fact that the test page doesn't print.

There was this message in the terminal:

No match for parallel port device:
  mfr "hp"
  model "hp business inkjet 1100"
  desc "hp business inkjet 1100"
  cmdset "MLC,PCL,PML,DESKJET,DW-PCL,DYN"
Please report this message in Bugzilla:
  https://bugzilla.redhat.com/bugzilla
Choose 'foomatic' as the component.

I can't return the printer as all the packaging and windows drivers cd
etc have been binned :-/
Comment 21 Tim Waugh 2004-11-23 05:25:14 EST
Do you have another cable you can try?
Comment 22 Chris Croome 2004-12-18 13:21:25 EST
I have brought a brand new parallel port and usb cables, neither makes
any difference, I still can't get a single bit of paper out of this
printer.

Should I just give up on this at this stage?
Comment 23 Tim Waugh 2004-12-20 07:32:51 EST
Perhaps there's some newer firmware you can download?  Other uses with the same
model of printer have reported success with FC3, so I don't think there is a
problem in general with that model.  Closing as WORKSFORME due to other reports
of success.

Note You need to log in before you can comment on or make changes to this bug.