Bug 139313 - FC2 -> FC3, anaconda has unhandled exception
FC2 -> FC3, anaconda has unhandled exception
Status: CLOSED DUPLICATE of bug 138485
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2004-11-14 23:24 EST by John Gregg
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:07:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
full back trace barfed out by anaconda (zipped) (196.40 KB, application/octet-stream)
2004-11-14 23:30 EST, John Gregg
no flags Details

  None (edit)
Description John Gregg 2004-11-14 23:24:20 EST
Description of problem:

I currently run Fedora Core 2, with grub as my boot loader.
I downloaded and burned to CD all 4 iso images for FC3. When
I boot from FC3 disc 1 to install FC3 on my machine, however,
I run into a problem. Right after I accept the default option
with regard to my boot loader (i.e. update my existing one),
I get a box informing me of an unhandled exception. The box
told me to file this bug. Here is just the top screen's worth
of the backtrace:

Traceback (most recent call last):
  File "/usr/src/build/475969-i386/install//usr/lib/anaconda/gui.py",
line 789,
in nextClicked
"/usr/src/build/475969-i386/install//usr/lib/anaconda/dispatch.py", line
171, in gotoNext
"/usr/src/build/475969-i386/install//usr/lib/anaconda/dispatch.py", line
239, in moveStep
    rc = apply(func, self.bindArgs(args))
line 396, in upgradeFindPackages
line 149, in findpackageset
    val =
TypeError: argument 1, item 0 must be string or None, not long

Version-Release number of selected component (if applicable):

Fedora Core 3

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 John Gregg 2004-11-14 23:30:23 EST
Created attachment 106696 [details]
full back trace barfed out by anaconda (zipped)
Comment 2 Jeremy Katz 2004-11-15 10:35:11 EST

*** This bug has been marked as a duplicate of 138485 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:07:01 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.