This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 139315 - /dev/sequencer missing
/dev/sequencer missing
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: awesfx (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-15 00:18 EST by Keith Sornen
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-13 09:39:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith Sornen 2004-11-15 00:18:36 EST
Description of problem:Running sfxload gives the following error
"/dev/sequencer: No such file or directory"



Version-Release number of selected component (if applicable):


How reproducible:Very


Steps to Reproduce:
1.sfxload
2.
3.
  
Actual results:
/dev/sequencer: No such file or directory

Expected results:


Additional info:
This is the same problem as 129916, which according to bugzilla has
been resolved but I upgraded from FC2 to FC3 and updated all the
packages and still have the same problem.  Is there a simple workaround?
Comment 1 Bill Nottingham 2004-11-15 00:42:43 EST
What modules do you have loaded?
Comment 2 Keith Sornen 2004-11-27 02:20:20 EST
There is also a problem with loading the snd-seq-oss

$/sbin/modprobe snd-seq-oss
doesn't return unless ctrl c
The process does not complete as shown by this:

$ ps -aux
.
.
.
root      4831  0.0  0.0  2712  588 pts/3    D    20:21   0:00
/sbin/modprobe snd_seq_oss
root      4836  0.0  0.0     0    0 ?        S<   20:21   0:00 [khelper]
root      4837  0.0  0.0  2576  412 ?        S<   20:21   0:00
/sbin/modprobe -q -- snd_seq_oss
.
.
.
$kill 4837

will kill the process but the mod is loaded as shown by lsmod and
sfxload now works.
Comment 3 Keith Sornen 2004-11-27 02:27:16 EST
Loading the module snd_seq_oss creates /dev/seqencer and
/dev/sequencer2 but there is the error: modprobe will hang as stated
above.

Also awesfx binary package is not in FC3 x86_64 but the src.rpm is. 
The src can be compiled with --target i386 and loadsfx works fine, if
the snd-seq-oss module is loaded first.

Comment 4 Keith Sornen 2004-11-27 02:28:56 EST
Sorry about the delay in replying for some reason missed your reply :)
Comment 5 Keith Sornen 2004-11-27 02:36:16 EST
In reply to your comment, loading snd-seq-oss creates /dev/sequencer
but there is the problem of modprobe hanging.  
Identical behaviour was found for both an amd athlon box loaded with
the i386 version of FC3 and an amd64 box loaded with the x86_64 version.
Sorry that my reply has taken 3 additional comments, I wasnt spamming
your mail, I kept on thinking of additional things to say. :\

Comment 6 Bill Nottingham 2004-11-28 15:11:43 EST
What happens if you run 'modprobe -v'?
Comment 7 Keith Sornen 2004-11-30 00:15:19 EST
>/sbin/modprobe -v snd-seq-oss
insmod /lib/modules/2.6.9-1.681_FC3/kernel/sound/core/seq/snd-seq.ko
insmod
/lib/modules/2.6.9-1.681_FC3/kernel/sound/core/seq/snd-seq-midi-event.ko
insmod
/lib/modules/2.6.9-1.681_FC3/kernel/sound/core/seq/oss/snd-seq-oss.ko

and then it hangs

>ps -aux
.
.
.
root      5433  0.0  0.0  2732  584 pts/3    D    18:17   0:00
/sbin/modprobe -v snd_seq_oss
root      5542  0.0  0.0     0    0 ?        S<   18:17   0:00 [khelper]
root      5543  0.0  0.0  2576  412 ?        S<   18:17   0:00
/sbin/modprobe -q -- snd_seq_oss
.
.
.
Comment 8 Bill Nottingham 2004-11-30 00:58:34 EST
Hm, it works for me.

What lines related to sound modules do you have in /etc/modprobe.conf
and /etc/modprobe.conf.dist?
Comment 9 Keith Sornen 2004-12-02 00:20:59 EST
Is that with the x86_64 or i386 system?  
Correction to previous reply: the i386 version is working and
/dev/sequencer is there after boot up, I think I became confused as to
which machine I was logged on to.
Still having the same problem with x86_64 version.      

>cat /etc/modprobe.conf |grep snd
alias snd-card-0 snd-emu10k1
options snd-card-0 index=0
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 &&
/usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-emu10k1 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-emu10k1

>cat /etc/modprobe.conf.dist |grep snd
alias char-major-116-* snd
alias sound-service-*-0 snd-mixer-oss
alias sound-service-*-1 snd-seq-oss
alias sound-service-*-3 snd-pcm-oss
alias sound-service-*-8 snd-seq-oss
alias sound-service-*-12 snd-pcm-oss
install sound-slot-* /sbin/modprobe
snd-card-${MODPROBE_MODULE##sound[_-]slot[_-]}
install snd-pcm /sbin/modprobe --ignore-install snd-pcm &&
/sbin/modprobe snd-pcm-oss
install snd-pcm-device /sbin/modprobe --ignore_install snd-seq-device
&& /sbin/modprobe snd-seq-oss
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 &&
/sbin/modprobe snd-emu10k1-synth
Comment 10 Gérard Milmeister 2005-02-17 13:19:34 EST
I had problems running sfxload with emu10k1. I think the problem is with sfxload
using OSS only. There is a version on
http://www.alsa-project.org/~iwai/awedrv.html that uses ALSA that works.
Comment 11 Martin Stransky 2005-02-18 02:38:05 EST
New version of awesfx is in raw hide, but describet problem with
/dev/sequencer is probably somewhere in driver...
Comment 12 Tim Wegener 2005-03-19 03:06:50 EST
I had similar problem on FC3 i386/i686 with SBLive:
$ sfxload Creative/SBLive/SFBank/8mbgmsfx.sf2
/dev/sequencer: No such file or directory

The solution was to run the following command (as root):
modprobe snd_emu10k1_synth

(solution courtesy Cameron Meadors
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=143314#c3 )

However, that fix does not survive a reboot. 

(This bug seems to be the same as 143314.)

Some debug info prior to running the modprobe command above:
$ /sbin/lsmod |grep seq
snd_seq_device          8137  2 snd_emu10k1,snd_rawmidi
snd                    54053  11
snd_emu10k1,snd_rawmidi,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_seq_device,snd_ac97_codec,snd_hwdep

$ cat /etc/modprobe.conf |grep snd
alias snd-card-0 snd-emu10k1
options snd-card-0 index=0
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 &&
/usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-emu10k1 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-emu10k1

Comment 13 Martin Stransky 2005-05-09 06:31:31 EDT
Any news on new kernel/drivers and alsa?
Comment 14 Keith Sornen 2005-05-12 06:14:03 EDT
What Wegener suggests that is
modprobe snd_emu10k1_synth
works for me as well. I can now load a sfont library with FC3 x86_64.

This is odd because the last line of modprobe.conf.dist
contains the following:

install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 &&
/sbin/modprobe snd-emu10k1-synth 

and yet snd-emu10k1-synth still requires manual loading after boot up.
Comment 15 Martin Stransky 2005-05-12 06:24:53 EDT
Great, I'll fix it.
Comment 16 Keith Sornen 2005-05-13 00:51:28 EDT
Just one other thing which I hadn't picked up because I load different
sf using scripts
Comment 17 Keith Sornen 2005-05-13 00:52:14 EDT
>aconnect 
want work without manually entering
>modprobe snd_emu10k1_synth

but then sfxload requires aconnect to run before hand otherwise the 
>/dev/sequencer: No such file or directory error occurs

Note You need to log in before you can comment on or make changes to this bug.