Bug 1393158 - [abrt] xorg-x11-server-Xwayland: Segmentation fault at address 0x30002022c8
Summary: [abrt] xorg-x11-server-Xwayland: Segmentation fault at address 0x30002022c8
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:815128c5a06f8cf9c32bb303e0d...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-09 02:15 UTC by Diogo Campos
Modified: 2016-11-27 06:30 UTC (History)
3 users (show)

Fixed In Version: xorg-x11-server-1.19.0-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-26 22:53:08 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (529 bytes, text/plain)
2016-11-09 02:15 UTC, Diogo Campos
no flags Details
File: dmesg (57.72 KB, text/plain)
2016-11-09 02:15 UTC, Diogo Campos
no flags Details
File: dso_list (244 bytes, text/plain)
2016-11-09 02:15 UTC, Diogo Campos
no flags Details
File: etc_X11_xorg_conf_d.tar.gz (331 bytes, application/octet-stream)
2016-11-09 02:15 UTC, Diogo Campos
no flags Details
File: usr_share_xorg_conf_d.tar.gz (1.72 KB, application/octet-stream)
2016-11-09 02:15 UTC, Diogo Campos
no flags Details

Description Diogo Campos 2016-11-09 02:15:34 UTC
Version-Release number of selected component:
xorg-x11-server-Xwayland-1.19.0-0.7.rc2.fc25

Additional info:
reporter:       libreport-2.8.0
executable:     /usr/bin/Xwayland
kernel:         4.8.6-300.fc25.x86_64
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           xorg
uid:            0

Truncated backtrace:
0: /usr/bin/Xwayland (OsLookupColor+0x139) [0x5906c9]
1: /lib64/libpthread.so.0 (__restore_rt+0x0) [0x7f1d8f5ab5bf]
2: /usr/bin/Xwayland (CloseInput+0x208) [0x4280e8]
3: /usr/bin/Xwayland (miPointerUpdateSprite+0x26b) [0x47431b]
4: /usr/bin/Xwayland (mieqProcessInputEvents+0x186) [0x470116]
5: /usr/bin/Xwayland (SendErrorToClient+0x126) [0x5563b6]
6: /usr/bin/Xwayland (InitFonts+0x428) [0x55a5d8]
7: /lib64/libc.so.6 (__libc_start_main+0xf1) [0x7f1d8f1f4401]
8: /usr/bin/Xwayland (_start+0x2a) [0x423d8a]
9: ? (?+0x2a) [0x2a]

Comment 1 Diogo Campos 2016-11-09 02:15:37 UTC
Created attachment 1218770 [details]
File: backtrace

Comment 2 Diogo Campos 2016-11-09 02:15:40 UTC
Created attachment 1218771 [details]
File: dmesg

Comment 3 Diogo Campos 2016-11-09 02:15:42 UTC
Created attachment 1218772 [details]
File: dso_list

Comment 4 Diogo Campos 2016-11-09 02:15:43 UTC
Created attachment 1218773 [details]
File: etc_X11_xorg_conf_d.tar.gz

Comment 5 Diogo Campos 2016-11-09 02:15:45 UTC
Created attachment 1218774 [details]
File: usr_share_xorg_conf_d.tar.gz

Comment 6 Olivier Fourdan 2016-11-09 10:09:02 UTC
$ addr2line -fe /usr/lib/debug/usr/bin/Xwayland.debug 0x4280e8 0x47431b 0x470116 0x5563b6 0x55a5d8 

xwl_seat_set_cursor() in /usr/src/debug/xorg-server-1.18.99.902/hw/xwayland/xwayland-cursor.c:46
miPointerUpdateSprite() in /usr/src/debug/xorg-server-1.18.99.902/mi/mipointer.c:472
mieqProcessInputEvents() in /usr/src/debug/xorg-server-1.18.99.902/mi/mieq.c:559
Dispatch() in /usr/src/debug/xorg-server-1.18.99.902/dix/dispatch.c:317
dix_main() in /usr/src/debug/xorg-server-1.18.99.902/dix/main.c:314

There are a few other cases like this in our bugzilla, it appears that we're trying to update the cursor with one that has been been freed just before.

Unfortunately I have not yet been able to reproduce this issue, anything in particular you were doing at the time of the crash,  what application where you running or started (if you remember)?

Comment 7 Diogo Campos 2016-11-09 18:51:24 UTC
I didn't notice what happened, it looks like ABRT does not show a notification for this kind of thing (and it don't go to the 'retrace' thing as well).

And I can't reproduce it, too.

But I will keep an eye open. Thanks :)

Comment 8 Olivier Fourdan 2016-11-10 15:10:53 UTC
Quick update, making progress on this issue, I start to have a pretty good understanding of what happens and now have some recipe to reproduce (but it's very random). I don't have a fix yet, though.

Comment 9 Olivier Fourdan 2016-11-16 07:59:36 UTC
I have posted a patch upstream that should fix this issue:

  https://patchwork.freedesktop.org/series/15344/

And also prepared a test package for Fedora which includes this patch:

  F25:     http://koji.fedoraproject.org/koji/taskinfo?taskID=16471034
  rawhide: http://koji.fedoraproject.org/koji/taskinfo?taskID=16471224

Could you try this build and see if that fixes the issue for you?

Note: these builds are scratch builds, they will automatically be deleted shortly.

Comment 10 Diogo Campos 2016-11-16 22:12:48 UTC
I tried. Everything is fine.

As I can't reproduce, I also can't tell you if this specific bug is fixed :/

Thank you, Olivier :)

Comment 11 Olivier Fourdan 2016-11-21 19:40:30 UTC
On further investigation and even more testing, I don't think the previous patch actually fixed the issue...

So new patch, new scratch build here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=16555185

Comment 12 Diogo Campos 2016-11-22 23:53:58 UTC
Tried. Everything looks fine again.

Comment 13 Fedora Update System 2016-11-23 10:53:23 UTC
xorg-x11-server-1.19.0-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-45775f3dcf

Comment 14 Fedora Update System 2016-11-25 09:41:19 UTC
xorg-x11-server-1.19.0-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-45775f3dcf

Comment 15 Fedora Update System 2016-11-26 22:53:08 UTC
xorg-x11-server-1.19.0-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.