Bug 139327 - string error in the ko_KR locale
string error in the ko_KR locale
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-display (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-15 03:45 EST by Lawrence Lim
Modified: 2014-03-25 20:51 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-29 19:20:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scrrenshot of firstboot in the ko_KR locale (106.51 KB, image/png)
2004-11-15 03:45 EST, Lawrence Lim
no flags Details
screenshot showing ko_KR screen with current cvs firstboot (49.00 KB, image/png)
2004-12-07 12:49 EST, Adrian Likins
no flags Details

  None (edit)
Description Lawrence Lim 2004-11-15 03:45:41 EST
Description of problem:
The string "Display" is not shown correctly in the ko_KR locale.

I did a msgunfmt on the mo file and the entry is correct.
msgid "Display"
msgstr "화면 표시"

Version-Release number of selected component (if applicable):
firstboot-1.3.37-2
up2date-4.3.61-2

How reproducible:
Always

Steps to Reproduce:
1.LANG=ko_KR.UTF-8 firstboot
2.
3.
  
Actual results:
The string "Display" is shown as "3"

Expected results:
The string should be displayed as "화면 표시"

Additional info:
Comment 1 Lawrence Lim 2004-11-15 03:45:41 EST
Created attachment 106699 [details]
scrrenshot of firstboot in the ko_KR locale
Comment 2 Michelle Kim 2004-11-16 20:22:09 EST
Thanks larry for creating the bugzilla.

I confirm that po file has correct translation..so let's light the
fire and find the cause of this problem!

Michelle 

Comment 3 Adrian Likins 2004-12-07 12:46:50 EST
huh, interesting. I haven't a slightest idea why that
displays the "display" string as "3"

It seems to display "3" regardless of whats in
the translated string. No other translations
seem to do this. 

Course, now that I do a make install from cvs,
it seems to work. screenshot attached.

I'll refresh the po's and rebuild and see if
that works. But since this isnt on any blocker
lists, it's probably too late. 
Comment 4 Adrian Likins 2004-12-07 12:49:02 EST
Created attachment 108051 [details]
screenshot showing ko_KR screen with current cvs firstboot
Comment 5 Michelle Kim 2004-12-07 19:12:49 EST
From the latest screenshot just posted by Adrian, "the string
"Display" is shown as "3" problem seems fixed but I found
"Configure..." button is shown in English. 

This is odd. I checked the entry in the ko.po file and it is translated:

#~ msgid "Configure..."
#~ msgstr "설정..."

so it shouldn't be in English.
Could you look into this matter?

Michelle
Comment 6 Lawrence Lim 2005-05-12 02:30:19 EDT
Tested with firstboot-1.3.39-2 and up2date-4.4.5.6-2, this strange "3" still exist.
Comment 7 Chris Lumens 2005-07-07 15:16:43 EDT
This is actually a bug in system-config-display.  If you look at the display
module in firstboot, you'll see:

translate.textdomain("system-config-display")

So, we are translating in the s-c-display domain.  Then if you msgunfmt
/usr/share/locale/ko/LC_MESSAGES/system-config-display.mo, you'll see:

msgid "Display"
msgstr "3"

This domain's translation is overriding the correct one in firstboot.  Still
present in RHEL4 final, by the way.
Comment 8 Michelle Kim 2005-07-08 00:27:47 EDT
Thanks for spotting this.

Now I have updated the file as follows: 

msgid "Display"
msgstr "화면 표시"

The latest ko.po file's revision number is 1.57

Thank you Lawrence for looking into this matter as well as Chris!

Cheers,
Michelle

Comment 9 Adam Jackson 2007-01-29 18:47:06 EST
So does this still need fixing in RHEL4?
Comment 10 RHEL Product and Program Management 2007-01-29 19:04:14 EST
The component this request has been filed against is not planned for inclusion
in the next update. The decision is based on weighting the priority and number
of requests for a component as well as the impact on the Red Hat Enterprise
Linux user-base: other components are considered having higher priority and the
number of changes we intend to include in update cycles is limited.
Comment 11 RHEL Product and Program Management 2007-01-29 19:20:53 EST
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request. 

Note You need to log in before you can comment on or make changes to this bug.