Bug 139336 - bad window parameter from fc3 x server to solaris emacs
bad window parameter from fc3 x server to solaris emacs
Status: CLOSED DUPLICATE of bug 137685
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-15 07:27 EST by Don Caldwell
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-31 15:47:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Caldwell 2004-11-15 07:27:31 EST
Description of problem:


Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-12

How reproducible:
very

Steps to Reproduce:
1. log into a solaris 5.8 machine
2. start up an emacs edit session of some arbitrary text file
3. use the mouse to position the cursor to some place in the text
  
Actual results:
emacs dies with this error:
X protocol error: BadWindow (invalid Window parameter) on protocol
request 38

Expected results:
i expect the cursor to be positioned at the place where i clicked
the mouse

Additional info:
this did not happen when i used fedora core2
this does not happen on an emacs on SGI
Comment 1 Steffen Persvold 2004-11-26 09:24:22 EST
It is not related to Solaris, it is remote X displays in general.

I get the same logging into RHEL3 servers and FC3 servers (via ssh).

I can even force it on my own machine by logging into it via ssh :

[sp@sp-laptop ~]$ ssh localhost
Last login: Fri Nov 26 09:24:39 2004 from localhost.localdomain
[sp@sp-laptop ~]$ echo $DISPLAY
localhost:10.0
[sp@sp-laptop ~]$ emacs
X protocol error: BadWindow (invalid Window parameter) on protocol
request 38


Comment 2 Mike A. Harris 2004-12-03 15:52:01 EST
As per the Fedora Core 3 release notes, the official "openssh"
software developers have changed the default behaviour of
"ssh -X", which now no longer works the way it did previously.
In order to get the same behaviour that "ssh -X" previously
had, you must invoke it as "ssh -Y" instead.

Reassigning to openssh component, for consideration of changing
it to have "-Y" enabled by default, so it works out of the box
like people seem to expect.
Comment 3 Tomas Mraz 2005-01-31 15:45:15 EST

*** This bug has been marked as a duplicate of 137685 ***

Note You need to log in before you can comment on or make changes to this bug.