Bug 1393513 - Shutdown/reboot issues with kernel 4.8
Summary: Shutdown/reboot issues with kernel 4.8
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 25
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-09 18:00 UTC by Daniele Viganò
Modified: 2017-01-17 15:09 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-17 15:09:31 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Linux Kernel 187061 0 None None None 2019-05-30 13:41:09 UTC

Description Daniele Viganò 2016-11-09 18:00:37 UTC
Description of problem:

After upgrading from kernel 4.7.9 to 4.8.6 on Fedora 24 my Dell Latitude E5450 hangs for more than 30 seconds during shutdown/reboot. During the hangs the fan spins up at the maximum speed. After poweroff the machine leds turn on (one stable and two blinking).
These work as diagnostic leds and the combination should mean a GPU failure.

It is not an hardware failure because Dell diagnostic is happy and shutdown works well with Kernel 4.7.9-200 and with oter OSes/distros.

The issue is reproducible on F25 Beta.

Version-Release number of selected component (if applicable):

F24: kernel-4.8.6-201
F24: kernel-4.8.4-200
F25: kernel-4.8.6-300

How reproducible:

Always reproducible


Steps to Reproduce:
1. Start Fedora with kernel 4.8
2. Shutdown/reboot the machine

Actual results:

The machine hangs for ~30 secs during shutdown, the fan speed up, blinking leds after the shutdown. If a reboot is issued no reboot is performed and the machine stays of with diagnostic leds blinking.

Expected results:

A shutdown/reboot completed within 10 seconds (on a SSD)

Additional info:

Dell Latitude E5450 bios A13

Comment 1 Daniele Viganò 2016-11-09 19:13:54 UTC
Some more details:

running the kernel in verbose mode shows that the message just before the hang during shutdown/reboot is

Synchronizing SCSI cache (sda)

Disabling cache before rebooting the machine seems to solve the issue:

sudo hdparm -W0 /dev/sda && sudo reboot

and the reboot/shutdown works as expected.

So, this bug seems related to https://bugzilla.kernel.org/show_bug.cgi?id=151631 and https://bugzilla.kernel.org/show_bug.cgi?id=187061

A temporary workaround is creating /usr/lib/systemd/system-shutdown/cache.shutdown with this content

#!/bin/sh
/usr/sbin/hdparm -W0 /dev/sda

Comment 3 Daniele Viganò 2016-11-18 11:21:21 UTC
Bug is affecting v4.8.7 too

Comment 4 Alfredo Ferrari 2016-11-30 20:40:35 UTC
I have the exact same problem with v4.8 kernels (up to 4.8.10 at this moment) for F24 on a Dell Latitude E7450.

Comment 5 Daniele Viganò 2016-12-01 06:40:33 UTC
The bad commit causing this issue has been reverted in 4.9-rc7: https://bugzilla.kernel.org/show_bug.cgi?id=187061#c16

For the 4.8 tree I think the only solution is to have the patch backported by the Fedora/RedHat maintainers.

By the end of the week I will upgrade my builds (see https://bugzilla.redhat.com/show_bug.cgi?id=1393513#c2), with the commit reverted, to 4.8.10 (currently 4.8.8 is available), if you want to try them.

Comment 6 Daniele Viganò 2016-12-17 18:02:34 UTC
Kernel 4.9 from Rawhide works correctly on F24 and F25 too. You can try it running:

sudo dnf install fedora-repos-rawhide
sudo dnf --enablerepo=rawhide upgrade kernel*

Comment 7 Manni Heumann 2016-12-25 09:31:53 UTC
I now am on 4.8.15-300.fc25.x86_64 and the problem seems to be gone.

Comment 8 Daniele Viganò 2016-12-28 12:16:26 UTC
4.8.15-200.fc24.x86_64 and 4.8.15-300.fc25.x86_64 works for me too. I think this bug should be mark as resolved now.

Comment 9 Laura Abbott 2017-01-17 01:09:28 UTC
*********** MASS BUG UPDATE **************
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 25 kernel bugs.
 
Fedora 25 has now been rebased to 4.9.3-200.fc25.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 26, and are still experiencing this issue, please change the version to Fedora 26.
 
If you experience different issues, please open a new bug report for those.

Comment 10 Daniele Viganò 2017-01-17 09:07:03 UTC
Works well with kernel 4.9.3. The bad commit causing this issue was reverted before 4.9rc and backported to 4.8.15, thus kernel >= 4.8.15 and >= 4.9.0 are not affected.


Note You need to log in before you can comment on or make changes to this bug.