Bug 139357 - openoffice zombies when opening files
openoffice zombies when opening files
Status: CLOSED DUPLICATE of bug 144607
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-15 10:40 EST by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-26 04:45:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
package versions after FC3 update (65.86 KB, text/plain)
2004-11-29 03:29 EST, Stig Hackvan
no flags Details
these are the packages that i changed to get gnome working (4.80 KB, text/plain)
2004-11-29 03:34 EST, Stig Hackvan
no flags Details

  None (edit)
Description Need Real Name 2004-11-15 10:40:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020 Epiphany/1.4.4

Description of problem:
openoffice writer sometimes zombies when opening a file and will not
restart as the same user

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
see above

Additional info:
Comment 1 Caolan McNamara 2004-11-15 11:47:13 EST
Is it a particular file, or any file ?. If its a particular file if
you could attach it to the bug that would be very useful.
Comment 2 Need Real Name 2004-11-15 12:13:04 EST
No particular file, happens on occasion and the only solution is to reboot
Comment 3 Emmanuel Viennet 2004-11-23 04:37:48 EST
I observe a similar problem: fress FC 3 install + updates,
OpenOffice hangs when:
 - ooffice
 - Menu File / Open => hangs before displaying any dialog or window
Comment 4 Emmanuel Viennet 2004-11-23 05:08:40 EST
Even after reboot, the problem persists: OpenOffice is unusable !

Emmanuel
Comment 5 Emmanuel Viennet 2004-11-23 06:00:02 EST
Err, I think this is *not* related to OpenOffice.
I have a problem with gnome (HAL and gnome-volume-manager don't work).

Sorry, but on a fresh FC3 install I assumed Gnome will be working.

Emmanuel
Comment 6 Stig Hackvan 2004-11-27 21:32:55 EST
here's an strace of the glitch...  to reproduce, run oo(whatever),
attach strace to the process, click the folder icon in the toolbar and
you'll get something like this:

socket(PF_FILE, SOCK_STREAM, 0)         = 39
fcntl64(39, F_SETFL, O_RDONLY|O_NONBLOCK) = 0
fcntl64(39, F_SETFD, FD_CLOEXEC)        = 0
connect(39, {sa_family=AF_FILE,
path="/tmp/orbit-stig/linc-2a91-0-2dd029fcb75de"}, 44) = 0
write(33, "A", 1)                       = 1
futex(0x9fa7e4c, FUTEX_WAKE, 1)         = 1
writev(39, [{"GIOP\1\2\1\0\214\1\0\0", 12},
{"\220H\347\376\3\0\0\0\0\0\0\0\34\0\0\0\0\0\0\0\353\254"..., 396}],
2) = 408
futex(0x99d1cf4, FUTEX_WAIT, 7, NULL)   = -1 EAGAIN (Resource
temporarily unavailable)
futex(0x99d1cd0, FUTEX_WAKE, 1)         = 0
writev(39, [{"GIOP\1\2\1\0\224\1\0\0", 12},
{"\20I\347\376\3\0\0\0\0\0\0\0\34\0\0\0\0\0\0\0\353\254 "..., 404}],
2) = 416
futex(0x99d1cf4, FUTEX_WAIT, 9, NULL)   = 0
futex(0x99d1cd0, FUTEX_WAKE, 1)         = 0
Comment 7 Stig Hackvan 2004-11-29 03:29:19 EST
Created attachment 107527 [details]
package versions after FC3 update

I managed to resolve the openoffice open dialog (and nautilus wasn't working
either) problem by closely scrutinizing my installed rpms looking for stuff
that should've been removed or updated or replaced but hadn't been.

my HUNCH is/was that libxslt and glib2 (from the FC2 update channel) were not
updated because the version shipping with FC3 did not seem to be newer...  

after forced installation of a few packages from the FC3 dvd, I had to force a
full prelink (rm /var/lib/misc/prelink.full /etc/prelink.cache; sh -x
/etc/cron.daily/prelink) and then reboot.

now gnome works.  (i wish the kernel worked with my use-once-then-reboot dvd
writer, though...)

-- stig
Comment 8 Stig Hackvan 2004-11-29 03:34:51 EST
Created attachment 107528 [details]
these are the packages that i changed to get gnome working

glib2 and libxslt were from the FC2 updates channel and the FC3 didn't replace
them...there were no complaints in /root/update.log about these packages, but
they were stale.
Comment 9 Stig Hackvan 2005-01-15 12:10:12 EST
was there any clear understanding of what caused this problem?  I'm
having it again.  last time, i purged old libraries and did a full
prelink and that seemed to change things for the better...gnome worked
again.  now the old libraries haven't come back and i've done the
prelink again but it's no good.

firefox hangs (in save file dialogs), openoffice hangs (in open file
dialogs), and mouse selections larger than a few dozen characters
don't seem to work between applications!

so this seems way worse than before.  I've re-built and re-installed
firefox too and that didn't fix the problem either... so my earlier
prelink assumptions don't hold.

help!?  FC3 has worsened my productivity by leaps and bounds.
Comment 10 Emmanuel Viennet 2005-01-15 12:42:29 EST
Did you apply all FC3 updates (and especially "hal") ?
Comment 11 Stig Hackvan 2005-01-15 21:45:57 EST
yes, i have all the latest fc3 updates.  in fact, probably the last
hal update should be suspect if hal was part of the cause before...

but why would it be?  it seems that there's a lock on
/tmp/orbit-somethingorother...



kernel-2.6.10-1.737_FC3             Tue Jan 11 12:41:38 2005
vim-enhanced-6.3.054-0.fc3.1        Thu Jan 13 09:35:18 2005
vim-common-6.3.054-0.fc3.1          Thu Jan 13 09:35:21 2005
vim-minimal-6.3.054-0.fc3.1         Thu Jan 13 09:35:41 2005
NetworkManager-0.3.3-1.cvs20050112.1.fc3    Thu Jan 13 09:46:52 2005
selinux-policy-targeted-sources-1.17.30-2.72    Thu Jan 13 09:46:56 2005
selinux-policy-targeted-1.17.30-2.72    Thu Jan 13 09:47:04 2005
synaptic-0.55.3-1.1.fc3.fr          Thu Jan 13 09:47:05 2005
system-config-samba-1.2.26-0.fc3.1    Thu Jan 13 09:47:14 2005
NetworkManager-gnome-0.3.3-1.cvs20050112.1.fc3    Thu Jan 13 09:47:19 2005
dbus-devel-0.22-10                  Thu Jan 13 14:13:06 2005
hal-0.4.5-1.FC3                     Thu Jan 13 14:13:14 2005
hal-devel-0.4.5-1.FC3               Thu Jan 13 14:13:41 2005
hal-gnome-0.4.5-1.FC3               Thu Jan 13 14:13:42 2005
fortune-mod-1.0-25dune              Thu Jan 13 22:43:03 2005
kernel-2.6.10-1.741_FC3             Fri Jan 14 10:36:28 2005
kernel-doc-2.6.10-1.741_FC3         Fri Jan 14 10:39:09 2005
firefox-debuginfo-1.0-2.fc3         Fri Jan 14 18:33:26 2005
firefox-1.0-2.fc3                   Fri Jan 14 18:33:59 2005
Comment 12 Stig Hackvan 2005-01-17 15:22:32 EST
the wording in my last entry was perhaps vague...

why is HAL related to this bug?  

The problem seems to be that gnome file selection dialogs called via
orbit never appear and hang the calling application.

-- stig
Comment 13 Caolan McNamara 2005-01-27 08:52:47 EST
I wonder if this is the same problem as bug 144607
Comment 14 Petr Baudis 2005-03-30 14:38:59 EST
I think it could be. I had this problem too (clean recent FC3 install with
latest updates and everything, no extras) and killing hald fixed it for me.
Comment 15 Caolan McNamara 2005-08-26 04:45:30 EDT

*** This bug has been marked as a duplicate of 144607 ***

Note You need to log in before you can comment on or make changes to this bug.