Bug 139363 - Remote invocation of firefox no longer working
Summary: Remote invocation of firefox no longer working
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-15 16:06 UTC by Nigel Metheringham
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-31 10:15:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nigel Metheringham 2004-11-15 16:06:17 UTC
Description of problem:
Since upgrade (previous version firefox-0.10.1-1.0PR1.20) invocation
of firefox by other programs (evolution, liferea) or by using
gnome-open or even the firefox command causes the profile manager to
pop up.


Version-Release number of selected component (if applicable):
firefox-1.0-2.fc3

How reproducible:
Every time.
Still happens after logging right out and restarting session.

Steps to Reproduce:
1. Start firefox
2. gnome-open http://www.redhat.com/    (needs firefox as gnome default)
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Warren Togami 2004-11-15 20:57:37 UTC
It is likely that an older version of firefox screwed up your gconf
key.  Go into Applications -> Preferences -> More Preferences ->
Preferred Applications and reconfigure the default browser.  Does it
work after that?

Comment 2 Nigel Metheringham 2004-11-16 11:15:03 UTC
I had tried resetting the default browser already, to no effect.  ALso
tried again this morning - still the same.

However I have seen slightly different behaviour this morning
(possibly seen yesterday and missed).  On initial login today firefox
was reacting correctly to URLs from other apps.  However after a
couple of hours it went back to yesterday's behaviour of putting up a
profile manager box.

What can I do to get better debugging information (this bug report is
very fuzzy at present).

Comment 3 Nigel Metheringham 2004-11-16 11:17:21 UTC
Restarting firefox makes it work for a while too.
Fairly obvious, but worth stating.

Comment 4 Christopher Aillon 2004-12-04 09:44:32 UTC
This is a known problem upstream when using multiple displays.  Is that the
issue you're seeing here?

Comment 5 Nigel Metheringham 2004-12-06 10:14:56 UTC
I have 3 workspaces defined (ie using the workspace switcher tool), and
use at least 2 of them daily, with URLs despatched to firefox from both
of those workspaces.   I don't have any esoteric multiple display hardware
(single laptop display panel).

Does that answer the question? [Unsure whether workspaces count as displays for
this]

Comment 6 Christopher Aillon 2005-03-31 09:51:29 UTC
Is this still an issue?

Comment 7 Nigel Metheringham 2005-03-31 10:09:13 UTC
Thanks for bringing this back to my attention.

I am no longer seeing this problem.

BUT I am using a customised start script at present - which I think should have
no effect on this, but just to let you know that I'm "non standard".  The
customised start script has "openurl($opt,new-window)" changed to
"openurl($opt,new-tab)", and I am using "~/bin/firefox %s" (the modded script)
as my default Gnome URL handler.


Comment 8 Christopher Aillon 2005-03-31 10:15:10 UTC
Fair enough.  I'll resolve this then as WORKSFORME.  As a note, you may wish to
try firefox >= 1.0.2-3 (available in the devel tree) which contains a fix for
bug 138789 and should obsolete your custom script (unless it does other things)

Comment 9 Nigel Metheringham 2005-03-31 10:36:40 UTC
Thats very good news - since modified scripts break on every update.


Note You need to log in before you can comment on or make changes to this bug.